zap channel did or inbound route with not working

Discussion in 'General' started by telecomtechnician, Jan 12, 2009.

  1. telecomtechnician

    Joined:
    Jan 8, 2008
    Messages:
    422
    Likes Received:
    0
    Hi there, when I put a did on a zap channel and create the appropiate route with the zap channel DID and then you dial in, the phone line is not answered, but I receive the following information from the CLI:


    -- Starting simple switch on 'Zap/1-1'
    -- Executing [s@from-zaptel:1] NoOp("Zap/1-1", "Entering from-zaptel with DID == ") in new stack
    -- Executing [s@from-zaptel:2] Ringing("Zap/1-1", "") in new stack
    -- Executing [s@from-zaptel:3] Set("Zap/1-1", "DID=s") in new stack
    -- Executing [s@from-zaptel:4] NoOp("Zap/1-1", "DID is now s") in new stack
    -- Executing [s@from-zaptel:5] GotoIf("Zap/1-1", "1?zapok:notzap") in new stack
    -- Goto (from-zaptel,s,8)
    -- Executing [s@from-zaptel:8] NoOp("Zap/1-1", "Is a Zaptel Channel") in new stack
    -- Executing [s@from-zaptel:9] Set("Zap/1-1", "CHAN=1-1") in new stack
    -- Executing [s@from-zaptel:10] Set("Zap/1-1", "CHAN=1") in new stack
    -- Executing [s@from-zaptel:11] Macro("Zap/1-1", "from-zaptel-1|s|1") in new stack
    -- Executing [s@macro-from-zaptel-1:1] NoOp("Zap/1-1", "Entering macro-from-zaptel-1 with DID = s and setting to: 117") in new stack
    -- Executing [s@macro-from-zaptel-1:2] Set("Zap/1-1", "__FROM_DID=117") in new stack
    -- Executing [s@macro-from-zaptel-1:3] Goto("Zap/1-1", "from-trunk|117|1") in new stack
    -- Goto (from-trunk,117,1)
    == Channel 'Zap/1-1' jumping out of macro 'from-zaptel-1'
    -- Hungup 'Zap/1-1'

    When I delete this route or change it to no DID, the phone line is answered by the IVR.

    What could be the problem?

    Waiting for your comments

    David Medina
     

Share This Page