yum will not complete due to missing dependencies

izrunas

Joined
Mar 4, 2009
Messages
94
Likes
0
Points
0
#1
I am trying to do a yum update to a 1.5 box.

First question is, WHY IS YUM TRYING TO INSTALL A RELEASE CANDIDATE?????

Ok, now that I got that question out... its more important that I know how to resolve this dependency issue.

Ideas? Thanks!

<<SNIP>>
--> Finished Dependency Resolution
2009020507:asterisk-1.4.25-0.rc1.i386 from elastix-updates has depsolving problems
--> Missing Dependency: libspeexdsp.so.1 is needed by package 2009020507:asterisk-1.4.25-0.rc1.i386 (elastix-updates)
2009020507:asterisk-1.4.25-0.rc1.i386 from elastix-updates has depsolving problems
--> Missing Dependency: libpri.so.1.4 is needed by package 2009020507:asterisk-1.4.25-0.rc1.i386 (elastix-updates)
Error: Missing Dependency: libpri.so.1.4 is needed by package 2009020507:asterisk-1.4.25-0.rc1.i386 (elastix-updates)
Error: Missing Dependency: libspeexdsp.so.1 is needed by package 2009020507:asterisk-1.4.25-0.rc1.i386 (elastix-updates)
[root@pbx ~]#
 

a_villacis

Joined
Jun 2, 2008
Messages
36
Likes
0
Points
0
#2
The updates resolve correctly on our test machine. Please try "yum clean all" and then try again.

This release candidate, in addition to fixing a couple of bugs, includes a patch to enable H.323 channels which links to a newer H.323 library, h323plus (the successor to OpenH323).
 

nachogomez

Joined
Sep 11, 2008
Messages
65
Likes
0
Points
0
#3

izrunas

Joined
Mar 4, 2009
Messages
94
Likes
0
Points
0
#4
After the "yum clean all" I tried again....

<snip>
--> Finished Dependency Resolution
2009020507:asterisk-1.4.25-0.rc1.i386 from elastix-updates has depsolving problems
--> Missing Dependency: libspeexdsp.so.1 is needed by package 2009020507:asterisk-1.4.25-0.rc1.i386 (elastix-updates)
2009020507:asterisk-1.4.25-0.rc1.i386 from elastix-updates has depsolving problems
--> Missing Dependency: libpri.so.1.4 is needed by package 2009020507:asterisk-1.4.25-0.rc1.i386 (elastix-updates)
Error: Missing Dependency: libpri.so.1.4 is needed by package 2009020507:asterisk-1.4.25-0.rc1.i386 (elastix-updates)
Error: Missing Dependency: libspeexdsp.so.1 is needed by package 2009020507:asterisk-1.4.25-0.rc1.i386 (elastix-updates)
[root@pbx ~]#


What now?
 

centritech

Joined
Jul 23, 2008
Messages
63
Likes
0
Points
0
#5
I have the same issue. Any body have any suggestions? This is preventing me from doing any yum updates on my customers PBX.

Thanks
Scott Brown
Centritech
 

rafael

Joined
May 14, 2007
Messages
1,454
Likes
1
Points
0
#6
did you try
Code:
yum clean all
 

izrunas

Joined
Mar 4, 2009
Messages
94
Likes
0
Points
0
#7
As noted in a previous post, yes, we did a "yum clean all" before trying again. Same error regarding missing dependencies.
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
#8
Strange. I have just completed a yum update without problems.
Did you compile libpri form source?
 

izrunas

Joined
Mar 4, 2009
Messages
94
Likes
0
Points
0
#9
Nothing special. Just a straightforward Elastix install. No tweaks. Nothing compiled from source.
 

izrunas

Joined
Mar 4, 2009
Messages
94
Likes
0
Points
0
#10
[root@pbx ~]# yum clean all
Loaded plugins: fastestmirror, priorities
Cleaning up Everything
Cleaning up list of fastest mirrors
[root@pbx ~]# yum update
Loaded plugins: fastestmirror, priorities
Determining fastest mirrors
* rpmforge: apt.sw.be
* base: www.gtlib.gatech.edu
* updates: mirror.newnanutilities.org
* addons: styx.biochem.wfubmc.edu
* extras: mirror.atlanticmetro.net
rpmforge | 1.1 kB 00:00
primary.xml.gz | 3.1 MB 00:09
rpmforge 8638/8638
elastix-base | 951 B 00:00
primary.xml.gz | 36 kB 00:00
elastix-base 48/48
base | 1.1 kB 00:00
primary.xml.gz | 878 kB 00:02
base 2508/2508
elastix-updates | 951 B 00:00
primary.xml.gz | 58 kB 00:00
elastix-updates 109/109
updates | 951 B 00:00
primary.xml.gz | 147 kB 00:00
updates 235/235
addons | 951 B 00:00
primary.xml.gz | 157 B 00:00
extras | 1.1 kB 00:00
primary.xml.gz | 96 kB 00:00
extras 309/309
Excluding Packages from Base RPM Repository for Elastix
Finished
Excluding Packages from CentOS-5 - Base
Finished
Excluding Packages from Updates RPM Repository for Elastix
Finished
Excluding Packages from CentOS-5 - Updates
Finished
Excluding Packages from CentOS-5 - Addons
Finished
Excluding Packages from CentOS-5 - Extras
Finished
159 packages excluded due to repository priority protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package poppler.i386 0:0.5.4-4.4.el5_3.9 set to be updated
---> Package audit-libs.i386 0:1.7.7-6.el5_3.3 set to be updated
---> Package kernel-devel.i686 0:2.6.18-92.1.22.el5 set to be installed
---> Package kernel-module-rhino.i686 2:0.99.1-4_2.6.18_92.1.22.el5 set to be updated
---> Package acpid.i386 0:1.0.4-7.el5_3.1 set to be updated
---> Package systemtap-runtime.i386 0:0.7.2-3.el5_3 set to be updated
---> Package udev.i386 0:095-14.20.el5_3 set to be updated
---> Package php-mysql.i386 0:5.1.6-23.2.el5_3 set to be updated
---> Package NetworkManager.i386 1:0.7.0-4.el5_3 set to be updated
---> Package elastix-vtigercrm.noarch 0:5.0.3-6 set to be updated
---> Package libopenr2-devel.i386 0:1.1.0-3 set to be updated
---> Package xulrunner.i386 0:1.9.0.10-1.el5 set to be updated
---> Package php-xml.i386 0:5.1.6-23.2.el5_3 set to be updated
---> Package file.i386 0:4.17-15.el5_3.1 set to be updated
---> Package mISDN-devel.i686 0:1.1.9.1-0 set to be updated
---> Package cups-libs.i386 1:1.3.7-8.el5_3.4 set to be updated
---> Package kernel-module-dahdi-xen.i686 0:2.1.0.4-15_2.6.18_92.1.22.el5 set to be updated
---> Package syslinux.i386 0:3.80-1.el5.rf set to be updated
---> Package rsync.i386 0:3.0.6-1.el5.rf set to be updated
---> Package gnome-session.i386 0:2.16.0-6.el5.centos.2 set to be updated
---> Package krb5-libs.i386 0:1.6.1-31.el5_3.3 set to be updated
---> Package ntp.i386 0:4.2.2p1-9.el5.centos.2 set to be updated
---> Package spandsp-devel.i386 0:0.0.4-3 set to be updated
--> Processing Dependency: libtiff-devel for package: spandsp-devel
---> Package php-imap.i386 0:5.1.6-23.2.el5_3 set to be updated
---> Package gstreamer-plugins-base.i386 0:0.10.20-3.0.1.el5_3 set to be updated
---> Package kernel-module-wanpipe.i386 0:3.4.1-1_2.6.18_92.1.22.el5 set to be updated
---> Package NetworkManager-glib.i386 1:0.7.0-4.el5_3 set to be updated
---> Package asterisk-sounds-es.i386 2009020507:1.4.25-1 set to be updated
---> Package php-gd.i386 0:5.1.6-23.2.el5_3 set to be updated
---> Package cups.i386 1:1.3.7-8.el5_3.4 set to be updated
---> Package krb5-devel.i386 0:1.6.1-31.el5_3.3 set to be updated
---> Package elastix.noarch 0:1.5.2-2.3 set to be updated
---> Package asterisk-devel.i386 2009020507:1.4.25-1 set to be updated
---> Package php.i386 0:5.1.6-23.2.el5_3 set to be updated
---> Package php-cli.i386 0:5.1.6-23.2.el5_3 set to be updated
---> Package freetype.i386 0:2.2.1-21.el5_3 set to be updated
---> Package lftp.i386 0:3.7.14-1.el5.rf set to be updated
---> Package mISDNuser-devel.i386 0:1.1.9.1-0 set to be updated
---> Package php-common.i386 0:5.1.6-23.2.el5_3 set to be updated
---> Package audit.i386 0:1.7.7-6.el5_3.3 set to be updated
---> Package mISDN.i686 0:1.1.9.1-0 set to be updated
---> Package asterisk-sounds-fr.i386 2009020507:1.4.25-1 set to be updated
---> Package iaxmodem.i386 0:1.2.0-1.1 set to be updated
---> Package audit-libs-python.i386 0:1.7.7-6.el5_3.3 set to be updated
---> Package systemtap.i386 0:0.7.2-3.el5_3 set to be updated
---> Package php-pdo.i386 0:5.1.6-23.2.el5_3 set to be updated
---> Package asterisk.i386 2009020507:1.4.25-1 set to be updated
--> Processing Dependency: libspeexdsp.so.1 for package: asterisk
--> Processing Dependency: libpt.so.2.4.2 for package: asterisk
--> Processing Dependency: libh323_linux_x86_n.so.1.20-beta5 for package: asterisk
--> Processing Dependency: libpri.so.1.4 for package: asterisk
---> Package asterisk-perl.noarch 0:0.10-2 set to be updated
---> Package kernel-module-dahdi.i686 0:2.1.0.4-15_2.6.18_92.1.22.el5 set to be updated
---> Package kpartx.i386 0:0.4.7-23.el5_3.4 set to be updated
---> Package wanpipe-util.i386 0:3.4.1-1 set to be updated
---> Package krb5-workstation.i386 0:1.6.1-31.el5_3.3 set to be updated
---> Package spandsp.i386 0:0.0.4-3 set to be updated
---> Package crash.i386 0:4.0-7.2.3.el5.centos.1 set to be updated
---> Package libvolume_id.i386 0:095-14.20.el5_3 set to be updated
---> Package freetype-devel.i386 0:2.2.1-21.el5_3 set to be updated
---> Package elastix-a2billing.noarch 0:1.3.0-3 set to be updated
---> Package subversion.i386 0:1.6.2-1.el5.rf set to be updated
---> Package ipsec-tools.i386 0:0.6.5-13.el5_3.1 set to be updated
---> Package kernel-headers.i386 0:2.6.18-92.1.22.el5 set to be updated
---> Package asterisk-addons.i386 1:1.4.8-0 set to be updated
---> Package dahdi.i686 0:2.1.0.4-15 set to be updated
---> Package NetworkManager-gnome.i386 1:0.7.0-4.el5_3 set to be updated
---> Package php-mbstring.i386 0:5.1.6-23.2.el5_3 set to be updated
---> Package rhino.i686 2:0.99.1-4 set to be updated
---> Package device-mapper-multipath.i386 0:0.4.7-23.el5_3.4 set to be updated
---> Package kernel-module-wanpipe-xen.i386 0:3.4.1-1_2.6.18_92.1.22.el5 set to be updated
---> Package mISDN-modules.i686 0:1.1.9.1-1.2.6.18_92.1.22.el5 set to be updated
---> Package openfire.i386 0:3.5.1-2 set to be updated
---> Package kernel-module-rhino-xen.i686 2:0.99.1-4_2.6.18_92.1.22.el5 set to be updated
---> Package tzdata.noarch 0:2009f-1.el5 set to be updated
---> Package sos.noarch 0:1.7-9.16.el5_3.5 set to be updated
---> Package mISDNuser.i386 0:1.1.9.1-0 set to be updated
---> Package libopenr2.i386 0:1.1.0-3 set to be updated
---> Package firefox.i386 0:3.0.10-1.el5.centos set to be updated
---> Package elastix-additionals.noarch 0:1.5-3 set to be updated
---> Package ghostscript.i386 0:8.15.2-9.4.el5_3.7 set to be updated
---> Package mISDN-modules-xen.i686 0:1.1.9.1-1.2.6.18_92.1.22.el5xen set to be updated
---> Package pango.i386 0:1.14.9-5.el5.centos set to be updated
--> Running transaction check
---> Package h323plus.i386 0:1.20.5-0.99.cvs20090515.2 set to be updated
---> Package libtiff-devel.i386 0:3.8.2-7.el5_2.2 set to be updated
---> Package ptlib.i386 0:2.4.2-2 set to be updated
---> Package asterisk.i386 2009020507:1.4.25-1 set to be updated
--> Processing Dependency: libspeexdsp.so.1 for package: asterisk
--> Processing Dependency: libpri.so.1.4 for package: asterisk
filelists.xml.gz | 251 kB 00:00
filelists.xml.gz | 3.5 MB 00:10
filelists.xml.gz | 2.8 MB 00:09
filelists.xml.gz | 241 kB 00:00
filelists.xml.gz | 1.0 MB 00:05
filelists.xml.gz | 150 B 00:00
filelists.xml.gz | 138 kB 00:00
--> Finished Dependency Resolution
2009020507:asterisk-1.4.25-1.i386 from elastix-updates has depsolving problems
--> Missing Dependency: libpri.so.1.4 is needed by package 2009020507:asterisk-1.4.25-1.i386 (elastix-updates)
2009020507:asterisk-1.4.25-1.i386 from elastix-updates has depsolving problems
--> Missing Dependency: libspeexdsp.so.1 is needed by package 2009020507:asterisk-1.4.25-1.i386 (elastix-updates)
Error: Missing Dependency: libpri.so.1.4 is needed by package 2009020507:asterisk-1.4.25-1.i386 (elastix-updates)
Error: Missing Dependency: libspeexdsp.so.1 is needed by package 2009020507:asterisk-1.4.25-1.i386 (elastix-updates)
[root@pbx ~]#
 

izrunas

Joined
Mar 4, 2009
Messages
94
Likes
0
Points
0
#11
Still can't complete yum updates due to the same errors. Ideas? Suggestions?
 

izrunas

Joined
Mar 4, 2009
Messages
94
Likes
0
Points
0
#12
I found the answer myself. The problem was that rpmforge had an entry for priority in the yum definition. All was well once I removed the offending line.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,886
Members
17,563
Latest member
dineshr
Top