Yum Update issues to Elastix 1.6-14

Discussion in 'General' started by Disaster, Feb 13, 2010.

  1. Disaster

    Joined:
    May 28, 2009
    Messages:
    59
    Likes Received:
    0
    Hi,

    I am having the below issues does anyone know how to resolve it.
    Is is asking for wanpipe-util to be instaled but this is allready up to date.



    Dependencies Resolved

    =============================================================================================================================
    Package Arch Version Repository Size
    =============================================================================================================================
    Updating:
    asterisk i386 2009020507:1.4.29-1 elastix-updates 10 M
    asterisk-devel i386 2009020507:1.4.29-1 elastix-updates 178 k
    asterisk-sounds-es i386 2009020507:1.4.29-1 elastix-updates 5.1 M
    asterisk-sounds-fr i386 2009020507:1.4.29-1 elastix-updates 4.9 M
    elastix noarch 1.6-14 elastix-updates 16 M

    Transaction Summary
    =============================================================================================================================
    Install 0 Package(s)
    Update 5 Package(s)
    Remove 0 Package(s)

    Total download size: 36 M
    Is this ok [y/N]: y
    Downloading Packages:
    (1/5): asterisk-devel-1.4.29-1.i386.rpm | 178 kB 00:01
    (2/5): asterisk-sounds-fr-1.4.29-1.i386.rpm | 4.9 MB 00:26
    (3/5): asterisk-sounds-es-1.4.29-1.i386.rpm | 5.1 MB 01:08
    (4/5): asterisk-1.4.29-1.i386.rpm | 10 MB 01:05
    (5/5): elastix-1.6-14.noarch.rpm | 16 MB 01:40
    -----------------------------------------------------------------------------------------------------------------------------
    Total 138 kB/s | 36 MB 04:26
    Running rpm_check_debug
    error: rpmdbNextIterator: skipping h# 901 Header V3 DSA signature: BAD, key ID d05c057c
    ERROR with rpm_check_debug vs depsolve:
    wanpipe-util is needed by elastix-1.6-14.noarch
    Complete!
    (1, [u'Please report this error in http://yum.baseurl.org/report'])
     
  2. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    use this commands to try to repare your yum libraries

    first
    yum clean all
    second download yum-utils --- yum install yum-utils

    then try again yum upgrade -y or yum-complete-transaction if it has any incomplete yum previously made

    bet regards
     
  3. Disaster

    Joined:
    May 28, 2009
    Messages:
    59
    Likes Received:
    0
    Still get the same error :(
     
  4. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    Try with:
    Code:
    rpm -e --nodeps wanpipe wanpipe-util
    yum update -y
    
     
  5. Disaster

    Joined:
    May 28, 2009
    Messages:
    59
    Likes Received:
    0
    Thanks but Still no luck

    [root@elastix ~]# rpm -e --nodeps wanpipe wanpipe-util
    error: package wanpipe is not installed
    error: rpmdbNextIterator: skipping h# 901 Header V3 DSA signature: BAD, key ID d05c057c


    When checking Package wanpipe-util-3.5.7-2.i686 already installed and latest version

    Any more help is appreciated

    Thanks
     
  6. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    try using gpgcheck as parameter in yum
    yum install -y --nogpgcheck

    best regards
     
  7. Disaster

    Joined:
    May 28, 2009
    Messages:
    59
    Likes Received:
    0
    Still no luck :(
     
  8. Disaster

    Joined:
    May 28, 2009
    Messages:
    59
    Likes Received:
    0
    Looks like the issue fixed it self, ran yum update today all update with no issues.
     
  9. kingmony

    Joined:
    Nov 12, 2009
    Messages:
    3
    Likes Received:
    0
    I can't upgrade via yum upgrade. I get this error.
    php-5.3.8-2.el5.art.i386 from atomic has depsolving problems
    --> php conflicts with php-zend-optimizer
    php-sqlite3-0.4-1.mf.i386 from installed has depsolving problems
    --> Missing Dependency: php-api = 20041225 is needed by package php-sqlite3-0.4-1.mf.i386 (installed)
    Error: Missing Dependency: php-api = 20041225 is needed by package php-sqlite3-0.4-1.mf.i386 (installed)
    Error: php conflicts with php-zend-optimizer
    You could try using --skip-broken to work around the problem
    You could try running: package-cleanup --problems
    package-cleanup --dupes
    rpm -Va --nofiles --nodigest
    any help please. thanks
     

Share This Page