Yum Update issue

clint

Joined
Oct 10, 2007
Messages
21
Likes
0
Points
0
#1
When doing a yum update i get the following error:

Resolving Dependencies
--> Running transaction check
---> Package gnutls.x86_64 0:1.4.1-3.el5_3.5 set to be updated
--> Processing Dependency: libspandsp.so.0()(64bit) for package: asterisk
---> Package spandsp.x86_64 0:0.0.6-0.1.pre12.el5 set to be updated
---> Package spandsp-devel.x86_64 0:0.0.6-0.1.pre12.el5 set to be updated
---> Package wget.x86_64 0:1.11.4-2.el5_4.1 set to be updated
--> Finished Dependency Resolution
2009020507:asterisk-1.4.26.1-4.x86_64 from installed has depsolving problems
--> Missing Dependency: libspandsp.so.0()(64bit) is needed by package 2009020507:asterisk-1.4.26.1-4.x86_64 (installed)
Error: Missing Dependency: libspandsp.so.0()(64bit) is needed by package 2009020507:asterisk-1.4.26.1-4.x86_64 (installed)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

How do i fix this?:laugh:
 

rafael

Joined
May 14, 2007
Messages
1,454
Likes
1
Points
0
#2
that error should be fixed.
 

daviramos

Joined
Jul 8, 2008
Messages
7
Likes
0
Points
0
#3
I ran the command now and also had the same problem.:S
 

rafael

Joined
May 14, 2007
Messages
1,454
Likes
1
Points
0
#4
I think you have to run "yum clean" before "yum update"

regards,

rafael
 

saleh

Joined
Apr 18, 2007
Messages
249
Likes
0
Points
0
#5
The EPEL repository has just updated spandsp to 0.0.6, but it conflicts
with the requirement for the elastix asterisk. The elastix development team trying to solve the problem.

For now, just run "yum --exclude=spandsp* update".

Best Regards,
Saleh
 

darrenmc

Joined
Nov 12, 2009
Messages
4
Likes
0
Points
0
#6
I tried to do this but I guess something went wrong somewhere as the elastix version has not changed from 1.5.2-2.3
 

clint

Joined
Oct 10, 2007
Messages
21
Likes
0
Points
0
#7
darrenmc said:
I tried to do this but I guess something went wrong somewhere as the elastix version has not changed from 1.5.2-2.3
The update to 1.6 via yum is not ready yet.
 

darrenmc

Joined
Nov 12, 2009
Messages
4
Likes
0
Points
0
#8
Ah...that would explain it...hope I haven't broke anything!

Thanks
 

saleh

Joined
Apr 18, 2007
Messages
249
Likes
0
Points
0
#9
Please see this link in the Elastix Mailing List to upgrades to 1.6

Tests upgrades to 1.6

Best Regards,

Saleh
 

excale

Joined
Apr 28, 2009
Messages
6
Likes
0
Points
0
#10
Hi,

we are facing similar issues. Any of you have been able so solve it?

thanks
 

darrenmc

Joined
Nov 12, 2009
Messages
4
Likes
0
Points
0
#11
Not yet no...waiting for the Dev's to come up with a solution. However, the "yum --exclude=spandsp* update" command does allow an update.
 

excale

Joined
Apr 28, 2009
Messages
6
Likes
0
Points
0
#12
thanks,

unlucky we are trying to install Asterix in proxmox and we need to install the packages and even doing that there is no luck...
 

nmartyd

Joined
Nov 17, 2009
Messages
1
Likes
0
Points
0
#13
I just installed a clean 1.6-12
Did yum update and the following problem is shown:

-> Finished Dependency Resolution
2009020507:asterisk-1.4.26.1-4.x86_64 from installed has depsolving problems
--> Missing Dependency: libspandsp.so.0()(64bit) is needed by package 2009020507:asterisk-1.4.26.1-4.x86_64 (installed)
Error: Missing Dependency: libspandsp.so.0()(64bit) is needed by package 2009020507:asterisk-1.4.26.1-4.x86_64 (installed)

I guess there is still some issues with update.
Can someone confirm please?
Thanks,

Néstor
 

clint

Joined
Oct 10, 2007
Messages
21
Likes
0
Points
0
#14
Hi Guys

Just done a fresh install on a Dell R300 Xeon 8GB mem 1 TB drives everything installs fine till you do a yum update you get the same problem as below.

Any idea's on a resolution time frame? This is my second box going into production today. I have not had problems with this issue, however i hope it is resolved soon.

Thanks Clint:(

clint said:
When doing a yum update i get the following error:

Resolving Dependencies
--> Running transaction check
---> Package gnutls.x86_64 0:1.4.1-3.el5_3.5 set to be updated
--> Processing Dependency: libspandsp.so.0()(64bit) for package: asterisk
---> Package spandsp.x86_64 0:0.0.6-0.1.pre12.el5 set to be updated
---> Package spandsp-devel.x86_64 0:0.0.6-0.1.pre12.el5 set to be updated
---> Package wget.x86_64 0:1.11.4-2.el5_4.1 set to be updated
--> Finished Dependency Resolution
2009020507:asterisk-1.4.26.1-4.x86_64 from installed has depsolving problems
--> Missing Dependency: libspandsp.so.0()(64bit) is needed by package 2009020507:asterisk-1.4.26.1-4.x86_64 (installed)
Error: Missing Dependency: libspandsp.so.0()(64bit) is needed by package 2009020507:asterisk-1.4.26.1-4.x86_64 (installed)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

How do i fix this?:laugh:
 

clint

Joined
Oct 10, 2007
Messages
21
Likes
0
Points
0
#15
Hi Guys this seems to work just fine!:woohoo:

rpm -qa | grep -i spandsp

to see what you have already. Then delete the spandsp packages you have.

rpm -del --nodeps spandsp

Run this command for everything that come up with the rpm -qa command.

now install spandsp

yum install spandsp

then update asterisk

yum update asterisk

then do a

yum update
 

ramoncio

Joined
May 12, 2010
Messages
1,663
Likes
0
Points
0
#16
Yes, it works for me too.
Thanks.
 

browsons

Joined
Sep 29, 2009
Messages
1
Likes
0
Points
0
#17
Gracias.

Yo no estoy muy familiarizado con centos y esta solucion me ayudo mucho.
 

Disaster

Joined
May 28, 2009
Messages
59
Likes
0
Points
0
#18
Thanks that fixed my problem as well B)
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,898
Messages
130,879
Members
17,560
Latest member
manuelc
Top