yum update fails in 1.3-2

Discussion in 'General' started by farhansabir, May 8, 2009.

  1. farhansabir

    Joined:
    Apr 11, 2008
    Messages:
    19
    Likes Received:
    0
    Hi,

    I have a system with Elastix 1.3-2 and am trying to upgrade to Elastix 1.5 stable
    (Linux xxx.example.com 2.6.18-53.1.19.el5 #1 SMP Wed May 7 08:20:19 EDT 2008 i686 i686 i386 GNU/Linux)

    When i type 'yum update' i get the following error:
    Code:
    --> Running transaction check
    ---> Package libselinux-utils.i386 0:1.33.4-5.1.el5 set to be updated
    ---> Package dbus-libs.i386 0:1.1.2-12.el5 set to be updated
    ---> Package kernel-module-dahdi.i386 0:2.1.0.4-7_2.6.18_92.1.22.el5 set to be updated
    ---> Package libopenr2.i386 0:1.1.0-1 set to be updated
    ---> Package kernel-module-dahdi-xen.i386 0:2.1.0.4-7_2.6.18_92.1.22.el5 set to be updated
    Traceback (most recent call last):
      File "/usr/bin/yum", line 29, in ?
        yummain.user_main(sys.argv[1:], exit_code=True)
      File "/usr/share/yum-cli/yummain.py", line 229, in user_main
        errcode = main(args)
      File "/usr/share/yum-cli/yummain.py", line 145, in main
        (result, resultmsgs) = base.buildTransaction()
      File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 647, in buildTransaction
        (rescode, restring) = self.resolveDeps()
      File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 704, in resolveDeps
        for po, dep in self._checkFileRequires():
      File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 939, in _checkFileRequires
        if not self.tsInfo.getOldProvides(filename) and not self.tsInfo.getNewProvides(filename):
      File "/usr/lib/python2.4/site-packages/yum/transactioninfo.py", line 414, in getNewProvides
        for pkg, hits in self.pkgSack.getProvides(name, flag, version).iteritems():
      File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 300, in getProvides
        return self._computeAggregateDictResult("getProvides", name, flags, version)
      File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 470, in _computeAggregateDictResult
        sackResult = apply(method, args)
      File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 861, in getProvides
        return self._search("provides", name, flags, version)
      File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 43, in newFunc
        return func(*args, **kwargs)
      File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 837, in _search
        for pkg in self.searchFiles(name, strict=True):
      File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 43, in newFunc
        return func(*args, **kwargs)
      File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 586, in searchFiles
        self._sql_pkgKey2po(rep, cur, pkgs)
      File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 470, in _sql_pkgKey2po
        pkg = self._packageByKey(repo, ob['pkgKey'])
      File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 413, in _packageByKey
        po = self.pc(repo, cur.fetchone())
      File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 68, in __init__
        self._read_db_obj(db_obj)
      File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 94, in _read_db_obj
        setattr(self, item, _share_data(db_obj[item]))
    TypeError: unsubscriptable object
    If anyone can help with this?

    Regards
    Farhan Sabir
    CIGear.com
     
  2. rafael

    Joined:
    May 14, 2007
    Messages:
    1,454
    Likes Received:
    1
    Did you try again? Else we should report a bug to bugs.elastix.org

    Regards,

    Rafael
     
  3. Telco

    Joined:
    Oct 4, 2007
    Messages:
    275
    Likes Received:
    0
    I tried it too... I have 1.3-2 as well. It did the exact same thing. Same errors.
     
  4. rafael

    Joined:
    May 14, 2007
    Messages:
    1,454
    Likes Received:
    1
    I believe the issue has to do with the reorganization of the repos since Elastix 1.5 now support 64 bits.

    From the beta- testers mailin list:


     
  5. farhansabir

    Joined:
    Apr 11, 2008
    Messages:
    19
    Likes Received:
    0
    Hi,

    I found a solution on google which worked great for me. It has probably something to do with yum cache or db.
    so you have to do a 'yum clean all' and then run the 'yum -y update'.

    It works fine.

    Regards
     
  6. Telco

    Joined:
    Oct 4, 2007
    Messages:
    275
    Likes Received:
    0
    Great work. Thanks I will try that tonight.
     
  7. nachogomez

    Joined:
    Sep 11, 2008
    Messages:
    65
    Likes Received:
    0
    That happened to me too, my solution was more empirical.

    First, try a "yum check-update", then select all packages that shows this command but leave the package "file" aside, I know this is a little bit tedious but in that way you can install everything you need to migrate to Elastix 1.5.X.

    By the way, I had to manually reconfigure my Sangoma Remora A400D Card. I think it was due to the change between Zaptel and DAHDI, but it's working fine now.

    Raul


    Hope that helps.
     

Share This Page