Yum update (error php-pear-DB)

Discussion in 'Elastix 2.x' started by mnemosin3, Apr 20, 2008.

  1. mnemosin3

    Joined:
    Dec 12, 2007
    Messages:
    22
    Likes Received:
    0
    Hola a todos en el foro, espero me puedan ayudar, tengo Elastix 0.9.2.4 en produccion funcionando muy bien con 16 troncales analogicas + Queuemetrics, hasta ahora todo muy bien si no es que excelente.

    Estoy intentando actualizae en un ambiente de prueba y no eh podido desde una instalacion fresca de Elastix 0.9.2.4 mediante yum update y me arroja esto depues de un buen rato de descargar cabeceras me marca lo siguiente:

    Error: Missing Dependency: php-pear-DB is needed by package elastix

    y nada que eh podido actualizar a la version 1.0

    Espero me puedan ayudar

    Saludos
     
  2. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    Tienes salida a Internet???
    Tiene un DNS, revisa por la parte web en red.

    Por que tengo la misma version en varios servidores y me trabaja bien cuando mando a actualizar;) ;) ;) ;)
     
  3. mnemosine

    Joined:
    Apr 23, 2007
    Messages:
    27
    Likes Received:
    0
    Security

    Si tengo salida a internet, como comento hace las descargas de cabeceras durante un buen rato y luego me da ese error de dependencias.
     
  4. hotbe

    Joined:
    Mar 10, 2008
    Messages:
    43
    Likes Received:
    0
    Localiza el paquete y bájalo con wget paquete, luego yum install paquete si no da resultado el yum install.

    rpm -ivh paquete, y si no da resultado.

    y te animas a forzar la instalación rpm -ivh paquete --nodeps

    y si no da resultado y si o si quieres instalar el paquete rpm -ivh paquete --force

    aunque recomiendo un upgrade a elastix 1.0, con una instalación limpia o sea borrando todo lo anterior.
     
  5. marcosb

    Joined:
    Sep 24, 2007
    Messages:
    24
    Likes Received:
    0
    A mí me pasa lo mismo y no he conseguido actualizar elastix
     
  6. bmacias

    Joined:
    Sep 27, 2007
    Messages:
    205
    Likes Received:
    0
  7. mnemosin3

    Joined:
    Dec 12, 2007
    Messages:
    22
    Likes Received:
    0
    Ya intente eso pero marca un conflicto con el php-pear qie es version 1.4.6.

    Que se puede hacer?

    Saludos
     
  8. bmacias

    Joined:
    Sep 27, 2007
    Messages:
    205
    Likes Received:
    0
    Hello, ok

    Mira si eliges solo estos repo para actualizar.
    Despues en una consola pones:

    yum update [​IMG]
     

Share This Page