Yum update does not work

Discussion in 'General' started by ziexpert, Jun 29, 2009.

  1. ziexpert

    Joined:
    May 25, 2009
    Messages:
    8
    Likes Received:
    0
    Hi,

    I have version 1.0-15
    When I try to upgrade using yum -y update here is what I get

    Loading "installonlyn" plugin
    Setting up Update Process
    Setting up repositories
    file:///media/CentOS/repodata/repomd.xml: [Errno 5] OSError: [Errno 2] No such file or directory: '/media/CentOS/repodata/repomd.xml'
    Trying other mirror.
    file:///media/cdrecorder/repodata/repomd.xml: [Errno 5] OSError: [Errno 2] No such file or directory: '/media/cdrecorder/repodata/repomd.xml'
    Trying other mirror.
    file:///media/cdrom/repodata/repomd.xml: [Errno 5] OSError: [Errno 2] No such file or directory: '/media/cdrom/repodata/repomd.xml'
    Trying other mirror.
    Error: Cannot open/read repomd.xml file for repository: c5-media

    What should I do?

    Appreciate your help in advance

    Kindest Regards.
     
  2. ronaldlw

    Joined:
    May 7, 2009
    Messages:
    81
    Likes Received:
    0
    you might try again, i got that error a little earlier, it's working for me now. maybe they were updating the repo or something.
     
  3. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Either put the cd that you installed the OS from in the cdrom drive, or edit/remove /etc/yum.repos.d/CentOS-Media.repo

    But as a caution please read tales (some of woe) on these fora, of folks trying to update from such an early version
     
  4. Bob

    Bob

    Joined:
    Nov 4, 2007
    Messages:
    2,400
    Likes Received:
    1
    ziexpert,

    It sounds like you enabled some repositories that don't need to be enabled, including the CENTOS 5 - Media, which is where your YUM Update is failing.

    Via the Elastix GUI, have a look at your UPDATE tab, select repositories and confirm that the following repositories are enabled only (The ones I have listed below with the *

    * CentOS-5 - Base
    * CentOS-5 - Updates
    * CentOS-5 - Addons
    * CentOS-5 - Extras

    CentOS-5 - Plus
    CentOS-5 - Contrib
    CentOS-5 - Media
    * Base RPM Repository for Elastix
    * Updates RPM Repository for Elastix


    If the GUI method doesn't work for you (I remember a bug in one of the versions), then you need to then go into the config files and disable the repo. Dicko's suggestion to edit the /etc/yum.repos.d/CentOS-Media.repo, and change the enable/disable line to 0/1 (sorry can't remember which way it is), should correct the issue.

    I have recently taken some 0.9X to 1.5-2 with yum updates, without any issues.

    If this is your problem, this is why I and another poster recommended to Elastix developers that there be a change control page added to the Elastix GUI (info stored in a SQLLite database), so when you make these changes, you can drop a line or two into there, so when you (or someone else) goes to upgrade several years later, they can remember the changes that were made..

    Otherwise, the only other rule, when YUM updates are failing is to do the following
    yum clean all (this clears out the YUM cache - especially if it is well outdated)
    yum update yum (brings it up to the latest version)
    then perform your usual yum update (this will not resolve the issue if you have the c5-media repo enabled though)


    Regards

    Bob
     
  5. ziexpert

    Joined:
    May 25, 2009
    Messages:
    8
    Likes Received:
    0
    Appreciate your help guys,

    I removed the unwanted repositories, things still did not work out.

    When I did
    yum clean all
    yum update yum

    I got:
    yum update yum
    Loading "installonlyn" plugin
    Setting up Update Process
    Setting up repositories
    base 100% |=========================| 1.1 kB 00:00
    updates 100% |=========================| 951 B 00:00
    addons 100% |=========================| 951 B 00:00
    extras 100% |=========================| 1.1 kB 00:00
    Reading repository metadata in from local files
    primary.xml.gz 100% |=========================| 878 kB 00:19
    base : ################################################## 2508/2508
    Added 2508 new packages, deleted 0 old in 5.75 seconds
    primary.xml.gz 100% |=========================| 193 kB 00:01
    updates : ################################################## 301/301
    Added 301 new packages, deleted 0 old in 1.16 seconds
    primary.xml.gz 100% |=========================| 157 B 00:00
    Added 0 new packages, deleted 0 old in 0.00 seconds
    primary.xml.gz 100% |=========================| 100 kB 00:00
    http://ftp.linux.org.tr/centos/5.3/extr ... ary.xml.gz: [Errno -1] Metadata file does not match checksum
    Trying other mirror.
    primary.xml.gz 100% |=========================| 100 kB 00:05
    ftp://ftp.cs.hacettepe.edu.tr/pub/mirro ... ary.xml.gz: [Errno -1] Metadata file does not match checksum
    Trying other mirror.
    primary.xml.gz 100% |=========================| 100 kB 00:00
    http://centos.bio.lmu.de/5.3/extras/i38 ... ary.xml.gz: [Errno -1] Metadata file does not match checksum
    Trying other mirror.
    primary.xml.gz 100% |=========================| 100 kB 00:00
    http://ftp.halifax.rwth-aachen.de/cento ... ary.xml.gz: [Errno -1] Metadata file does not match checksum
    Trying other mirror.
    primary.xml.gz 100% |=========================| 100 kB 00:00
    http://centos.intergenia.de/5.3/extras/ ... ary.xml.gz: [Errno -1] Metadata file does not match checksum
    Trying other mirror.
    primary.xml.gz 100% |=========================| 100 kB 00:01
    http://wftp.tu-chemnitz.de/pub/linux/ce ... ary.xml.gz: [Errno -1] Metadata file does not match checksum
    Trying other mirror.
    primary.xml.gz 100% |=========================| 100 kB 00:00
    http://mirror.silyus.net/centos/5.3/ext ... ary.xml.gz: [Errno -1] Metadata file does not match checksum
    Trying other mirror.
    primary.xml.gz 100% |=========================| 100 kB 00:01
    ftp://mirror.fraunhofer.de/centos.org/5 ... ary.xml.gz: [Errno -1] Metadata file does not match checksum
    Trying other mirror.
    primary.xml.gz 100% |=========================| 100 kB 00:01
    http://ftp-stud.fht-esslingen.de/pub/Mi ... ary.xml.gz: [Errno -1] Metadata file does not match checksum
    Trying other mirror.
    primary.xml.gz 100% |=========================| 100 kB 00:00
    http://mirror.atrpms.net/centos/5.3/ext ... ary.xml.gz: [Errno -1] Metadata file does not match checksum
    Trying other mirror.
    Error: failure: repodata/primary.xml.gz from extras: [Errno 256] No more mirrors to try.

    Appreciate your help
     
  6. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    perhaps a

    yum clean metadata

    will help.
     
  7. Patrick_elx

    Joined:
    Dec 14, 2008
    Messages:
    1,120
    Likes Received:
    0
    I was starting to have some asterisk crashes recently and I updated elastix and the kernel.

    Now on startup I have a many failed services with an error no dev/dahdi (but I don't know how to find the log of the console warning).

    The only thing i can find in the asterisk/full log is Unable to open '/dev/dahdi/channel': No such file or directory

    But I don't see anything in the other logs.


    - How to access the log of the console information?
    - What am I missing that I need to install to solve these errors?
     
  8. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Patrick:

    > The only thing i can find in the asterisk/full log is Unable to open '/dev/dahdi/channel': No such file or directory


    Is indicative of dahdi not loading, perhaps you should stop asterisk and see what /etc/init.d/dahdi restart(stop/start) does for your debugging .
     
  9. Patrick_elx

    Joined:
    Dec 14, 2008
    Messages:
    1,120
    Likes Received:
    0
    yes, you're right:

    # /etc/init.d/dahdi restart
    Unloading DAHDI hardware modules: doneLoading DAHDI hardware modules:
    FATAL: Module dahdi not found.
    wct4xxp: FATAL: Module wct4xxp not found.
    [FAILED]
    wcte12xp: FATAL: Module wcte12xp not found.
    [FAILED]
    wct1xxp: FATAL: Module wct1xxp not found.
    [FAILED]
    wcte11xp: FATAL: Module wcte11xp not found.
    [FAILED]
    wctdm24xxp: FATAL: Module wctdm24xxp not found.
    [FAILED]
    wcfxo: FATAL: Module wcfxo not found.
    [FAILED]
    wctdm: FATAL: Module wctdm not found.
    [FAILED]
    wcb4xxp: FATAL: Module wcb4xxp not found.
    [FAILED]
    wctc4xxp: FATAL: Module wctc4xxp not found.
    [FAILED]
    xpp_usb: FATAL: Module xpp_usb not found.
    [FAILED]
    opvxa1200: FATAL: Module opvxa1200 not found.
    [FAILED]
    ystdm8xx: FATAL: Module ystdm8xx not found.
    [FAILED]
    ystdm16xx: FATAL: Module ystdm16xx not found.
    [FAILED]
    ap400: FATAL: Module ap400 not found.
    [FAILED]
    dahdi_dynamic_eth: FATAL: Module dahdi_dynamic_eth not found.
    [FAILED]
    dahdi_dynamic_ethmf: FATAL: Module dahdi_dynamic_ethmf not found.
    [FAILED]

    Error: missing /dev/dahdi!


    I've tried a yum reinstall dahdi, but I still have the same error.
     
  10. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Personally I would get dahdi (and its tools) from digium and build it by hand.

    Less mystery and more feedback that way.
     

Share This Page