yum update broken | elastix 1.5.2-2.2

Discussion in 'General' started by pepsy, Apr 28, 2009.

  1. pepsy

    Joined:
    Apr 22, 2009
    Messages:
    5
    Likes Received:
    0
    After upgrading to 1.5.2-2.2 i cannot yum update anymore getting this error:

    Resolving Dependencies
    --> Running transaction check
    ---> Package dahdi-devel.i386 0:2.1.0.4-10 set to be updated
    --> Processing Dependency: libspandsp-0.0.3.so.0 for package: asterisk
    --> Processing Dependency: libspandsp-0.0.3.so.0 for package: libmfcr2
    --> Processing Dependency: libspandsp-0.0.3.so.0 for package: libsupertone
    ---> Package spandsp-devel.i386 0:0.0.4-3 set to be updated
    --> Processing Dependency: libtiff-devel for package: spandsp-devel
    ---> Package spandsp.i386 0:0.0.4-3 set to be updated
    ---> Package dahdi.i386 0:2.1.0.4-10 set to be updated
    --> Running transaction check
    ---> Package libtiff-devel.i386 0:3.8.2-7.el5_2.2 set to be updated
    --> Processing Dependency: libspandsp-0.0.3.so.0 for package: asterisk
    --> Processing Dependency: libspandsp-0.0.3.so.0 for package: libmfcr2
    --> Processing Dependency: libspandsp-0.0.3.so.0 for package: libsupertone
    --> Finished Dependency Resolution
    2009020507:asterisk-1.4.24.1-1.i386 from installed has depsolving problems
    --> Missing Dependency: libspandsp-0.0.3.so.0 is needed by package 2009020507:asterisk-1.4.24.1-1.i386 (installed)
    libmfcr2-0.0.3-20.i386 from installed has depsolving problems
    --> Missing Dependency: libspandsp-0.0.3.so.0 is needed by package libmfcr2-0.0.3-20.i386 (installed)
    libsupertone-0.0.2-17.i386 from installed has depsolving problems
    --> Missing Dependency: libspandsp-0.0.3.so.0 is needed by package libsupertone-0.0.2-17.i386 (installed)
    Error: Missing Dependency: libspandsp-0.0.3.so.0 is needed by package libmfcr2-0.0.3-20.i386 (installed)
    Error: Missing Dependency: libspandsp-0.0.3.so.0 is needed by package 2009020507:asterisk-1.4.24.1-1.i386 (installed)
    Error: Missing Dependency: libspandsp-0.0.3.so.0 is needed by package libsupertone-0.0.2-17.i386 (installed)

    Any idea how to fix it?

    Thanks a lot
    pep
     
  2. pepsy

    Joined:
    Apr 22, 2009
    Messages:
    5
    Likes Received:
    0
    Nevermind, found a solution:

    # yum provides libspandsp.so.0
    spandsp-0.0.4-3.i386 : A DSP library for telephony
    Matched from:
    Other : libspandsp.so.0

    # rpm -qa | grep -i spandsp
    spandsp-0.0.4-2
    spandsp-devel-0.0.4-2

    # rpm -del --nodeps spandsp
    # yum install spandsp


    now yum is back to work ;)
     
  3. cowboy47

    Joined:
    Jun 14, 2007
    Messages:
    276
    Likes Received:
    0
    That did not work for me. I followed your steps but still receive:

    2009020507:asterisk-1.4.24.1-1.i386 from elastix-updates has depsolving problems
    --> Missing Dependency: libspandsp-0.0.3.so.0 is needed by package 2009020507:asterisk-1.4.24.1-1.i386 (elastix-updates)
    Error: Missing Dependency: libspandsp-0.0.3.so.0 is needed by package 2009020507:asterisk-1.4.24.1-1.i386 (elastix-updates)
     
  4. pepsy

    Joined:
    Apr 22, 2009
    Messages:
    5
    Likes Received:
    0
    Maybe try to remove also the spandsp-devel with

    #rpm -del --nodeps spandsp-devel

    then check if package is really removed with

    #rpm -qa | grep -i spandsp

    and reinstall with

    #yum install spandsp spandsp-devel
     

Share This Page