yum help

mattrh

Joined
Jul 15, 2008
Messages
175
Likes
0
Points
0
#1
here is what i get when i type yum update

Code:
---> Package freePBX.noarch 0:2.5.1-12rc set to be updated
---> Package asterisk.i386 2009020507:1.4.25.1-3 set to be updated
--> Processing Dependency: libpt.so.2.4.2 for package: asterisk
--> Processing Dependency: libh323_linux_x86_n.so.1.20-beta5 for package: asteri                                                                                                                               sk
---> Package kpartx.i386 0:0.4.7-23.el5_3.4 set to be updated
---> Package kernel-devel.i686 0:2.6.18-92.1.22.el5 set to be installed
---> Package libopenr2-devel.i386 0:1.1.0-3 set to be updated
---> Package RoundCubeMail.noarch 0:0.2-8 set to be updated
---> Package redhat-logos.noarch 0:4.9.99-11.el5.centos set to be updated
---> Package dhcp.i386 12:3.0.5-18.el5 set to be updated
---> Package m2crypto.i386 0:0.16-6.el5.3 set to be updated
---> Package selinux-policy.noarch 0:2.4.6-203.el5 set to be updated
---> Package spamassassin.i386 0:3.2.5-1.el5 set to be updated
---> Package kernel.i686 0:2.6.18-92.1.22.el5 set to be installed
---> Package speex.i386 0:1.2rc1-1 set to be updated
---> Package elastix-additionals.noarch 0:1.5-3 set to be updated
---> Package openssh.i386 0:4.3p2-29.el5 set to be updated
---> Package rpm-libs.i386 0:4.4.2.3-9.el5 set to be updated
---> Package rpm-python.i386 0:4.4.2.3-9.el5 set to be updated
---> Package pm-utils.i386 0:0.99.3-10.el5.centos set to be updated
---> Package initscripts.i386 0:8.45.25-1.el5.centos set to be updated
---> Package findutils.i386 1:4.2.27-5.el5 set to be updated
---> Package libgcc.i386 0:4.1.2-44.el5 set to be updated
---> Package openssl.i686 0:0.9.8e-7.el5 set to be updated
---> Package module-init-tools.i386 0:3.3-0.pre3.1.42.el5 set to be updated
---> Package glibc.i386 0:2.5-34 set to be updated
---> Package elfutils.i386 0:0.137-3.el5 set to be updated
---> Package dosfstools.i386 0:2.11-7.el5 set to be updated
---> Package yum-fastestmirror.noarch 0:1.1.16-13.el5.centos set to be updated
---> Package curl.i386 0:7.15.5-2.1.el5_3.4 set to be updated
---> Package alsa-utils.i386 0:1.0.17-1.el5 set to be updated
---> Package newt.i386 0:0.52.2-12.el5 set to be updated
---> Package openssh-server.i386 0:4.3p2-29.el5 set to be updated
---> Package setup.noarch 0:2.5.58-4.el5 set to be updated
---> Package gcc.i386 0:4.1.2-44.el5 set to be updated
---> Package logrotate.i386 0:3.7.4-9 set to be updated
---> Package freetype.i386 0:2.2.1-21.el5_3 set to be updated
---> Package elastix.noarch 0:1.5.2-2.3 set to be updated
---> Package glibc-headers.i386 0:2.5-34 set to be updated
---> Package elfutils-libelf.i386 0:0.137-3.el5 set to be updated
---> Package ethtool.i386 0:6-2.el5 set to be updated
---> Package perl-Data-UUID.i386 0:1.149-0 set to be updated
---> Package mcstrans.i386 0:0.2.11-3.el5 set to be updated
---> Package cpp.i386 0:4.1.2-44.el5 set to be updated
---> Package newt-devel.i386 0:0.52.2-12.el5 set to be updated
---> Package mISDNuser.i386 0:1.1.9.1-0 set to be updated
---> Package libgcrypt.i386 0:1.2.4-1.el5 set to be updated
---> Package hal.i386 0:0.5.8.1-38.el5 set to be updated
---> Package libstdc++.i386 0:4.1.2-44.el5 set to be updated
---> Package strace.i386 0:4.5.18-2.el5_3.3 set to be updated
---> Package audit-libs.i386 0:1.7.7-6.el5_3.3 set to be updated
---> Package coreutils.i386 0:5.97-19.el5 set to be updated
---> Package vsftpd.i386 0:2.0.5-12.el5_3.1 set to be updated
---> Package gcc-c++.i386 0:4.1.2-44.el5 set to be updated
---> Package e2fsprogs-devel.i386 0:1.39-20.el5 set to be updated
---> Package binutils.i386 0:2.17.50.0.6-9.el5 set to be updated
---> Package glib2.i386 0:2.12.3-4.el5_3.1 set to be updated
---> Package asterisk-perl.noarch 0:0.10-2 set to be updated
---> Package nfs-utils.i386 1:1.0.9-40.el5 set to be updated
---> Package cryptsetup-luks.i386 0:1.0.3-4.el5 set to be updated
---> Package tcp_wrappers.i386 0:7.6-40.6.el5 set to be updated
---> Package device-mapper-event.i386 0:1.02.28-2.el5 set to be updated
---> Package selinux-policy-targeted.noarch 0:2.4.6-203.el5 set to be updated
---> Package dbus.i386 0:1.1.2-12.el5 set to be updated
--> Processing Dependency: dbus-libs = 1.1.2-12.el5 for package: dbus
---> Package iproute.i386 0:2.6.18-9.el5 set to be updated
---> Package authconfig.i386 0:5.3.21-5.el5 set to be updated
---> Package iputils.i386 0:20020927-45.el5 set to be updated
---> Package psacct.i386 0:6.3.2-44.el5 set to be updated
---> Package mISDNuser-devel.i386 0:1.1.9.1-0 set to be updated
---> Package lm_sensors.i386 0:2.10.7-4.el5 set to be updated
---> Package mISDN-devel.i686 0:1.1.9.1-0 set to be updated
---> Package php-xml.i386 0:5.1.6-23.2.el5_3 set to be updated
---> Package alsa-lib.i386 0:1.0.17-1.el5 set to be updated
---> Package dhcdbd.i386 0:2.2-2.el5 set to be updated
---> Package ntp.i386 0:4.2.2p1-9.el5.centos.2 set to be updated
---> Package libstdc++-devel.i386 0:4.1.2-44.el5 set to be updated
---> Package vixie-cron.i386 4:4.1-76.el5 set to be updated
---> Package libdhcp.i386 0:1.20-6.el5 set to be updated
---> Package centos-release-notes.i386 0:5.3-3 set to be updated
---> Package cups-libs.i386 1:1.3.7-8.el5_3.6 set to be updated
---> Package stunnel.i386 0:4.15-2.el5.1 set to be updated
---> Package mISDN.i686 0:1.1.9.1-0 set to be updated
---> Package libpri.i386 0:1.4.10-0 set to be updated
---> Package dmraid.i386 0:1.0.0.rc13-33.el5 set to be updated
---> Package glibc-devel.i386 0:2.5-34 set to be updated
---> Package libselinux-devel.i386 0:1.33.4-5.1.el5 set to be updated
---> Package mesa-libGL.i386 0:6.5.1-7.7.el5 set to be updated
---> Package kernel-module-rhino.i686 2:0.99.1-4_2.6.18_92.1.22.el5 set to be up                                                                                                                               dated
---> Package net-snmp-libs.i386 1:5.3.2.2-5.el5_3.1 set to be updated
---> Package openmotif.i386 0:2.3.1-2.el5 set to be updated
---> Package php-pdo.i386 0:5.1.6-23.2.el5_3 set to be updated
---> Package libgomp.i386 0:4.3.2-7.el5 set to be updated
---> Package freetype-devel.i386 0:2.2.1-21.el5_3 set to be updated
---> Package elastix-vtigercrm.noarch 0:5.0.3-6 set to be updated
---> Package php-odbc.i386 0:5.1.6-23.2.el5_3 set to be updated
---> Package spandsp-devel.i386 0:0.0.4-3 set to be updated
--> Processing Dependency: libtiff-devel for package: spandsp-devel
---> Package kernel-module-rhino-xen.i686 2:0.99.1-4_2.6.18_92.1.22.el5 set to b                                                                                                                               e updated
---> Package asterisk-addons.i386 1:1.4.8-1 set to be updated
---> Package php-mbstring.i386 0:5.1.6-23.2.el5_3 set to be updated
---> Package kernel-xen.i686 0:2.6.18-92.1.22.el5 set to be installed
---> Package e2fsprogs-libs.i386 0:1.39-20.el5 set to be updated
---> Package dhclient.i386 12:3.0.5-18.el5 set to be updated
---> Package pykickstart.noarch 0:0.43.3-1.el5 set to be updated
---> Package ghostscript.i386 0:8.15.2-9.4.el5_3.7 set to be updated
---> Package php-gd.i386 0:5.1.6-23.2.el5_3 set to be updated
---> Package php-mysql.i386 0:5.1.6-23.2.el5_3 set to be updated
---> Package quota.i386 1:3.13-1.2.5.el5 set to be updated
---> Package filesystem.i386 0:2.4.0-2.el5.centos set to be updated
---> Package libutempter.i386 0:1.1.4-4.el5 set to be updated
---> Package util-linux.i386 0:2.13-0.50.el5 set to be updated
---> Package hwdata.noarch 0:0.213.11-1.el5 set to be updated
---> Package elastix-asterisk-sounds.noarch 0:1.2.2-2 set to be updated
---> Package device-mapper-multipath.i386 0:0.4.7-23.el5_3.4 set to be updated
---> Package system-config-network-tui.noarch 0:1.3.99.12-1.el5 set to be update                                                                                                                               d
---> Package openssh-clients.i386 0:4.3p2-29.el5 set to be updated
---> Package asterisk-sounds-es.i386 2009020507:1.4.25.1-3 set to be updated
---> Package patch.i386 0:2.5.4-29.2.3.el5 set to be updated
---> Package libpng.i386 2:1.2.10-7.1.el5_3.2 set to be updated
---> Package php-cli.i386 0:5.1.6-23.2.el5_3 set to be updated
---> Package dahdi.i686 0:2.1.0.4-15 set to be updated
--> Processing Dependency: kernel-module-dahdi for package: dahdi
--> Processing Dependency: kernel-module-dahdi-xen for package: dahdi
---> Package libselinux.i386 0:1.33.4-5.1.el5 set to be updated
---> Package audit-libs-python.i386 0:1.7.7-6.el5_3.3 set to be updated
---> Package openmotif-devel.i386 0:2.3.1-2.el5 set to be updated
---> Package krb5-workstation.i386 0:1.6.1-31.el5_3.3 set to be updated
---> Package unzip.i386 0:5.52-3.el5 set to be updated
---> Package lvm2.i386 0:2.02.40-6.el5 set to be updated
---> Package openssl-devel.i386 0:0.9.8e-7.el5 set to be updated
---> Package e2fsprogs.i386 0:1.39-20.el5 set to be updated
---> Package rpm.i386 0:4.4.2.3-9.el5 set to be updated
---> Package httpd.i386 0:2.2.3-22.el5.centos.1 set to be updated
---> Package iaxmodem.i386 0:1.2.0-1.1 set to be updated
---> Package php.i386 0:5.1.6-23.2.el5_3 set to be updated
---> Package asterisk-sounds-fr.i386 2009020507:1.4.25.1-3 set to be updated
---> Package gsm.i386 0:1.0.12-4.el5 set to be updated
---> Package SysVinit.i386 0:2.86-15.el5 set to be updated
---> Package mlocate.i386 0:0.15-1.el5.1 set to be updated
---> Package perl-DBI.i386 0:1.52-2.el5 set to be updated
---> Package man-pages.noarch 0:2.39-12.el5 set to be updated
---> Package fxload.i386 0:2008_10_13-1 set to be updated
---> Package elfutils-libs.i386 0:0.137-3.el5 set to be updated
---> Package dbus-glib.i386 0:0.73-8.el5 set to be updated
---> Package mesa-libGL-devel.i386 0:6.5.1-7.7.el5 set to be updated
---> Package wpa_supplicant.i386 1:0.5.10-8.el5 set to be updated
---> Package nash.i386 0:5.1.19.6-44 set to be updated
---> Package mkinitrd.i386 0:5.1.19.6-44 set to be updated
---> Package php-common.i386 0:5.1.6-23.2.el5_3 set to be updated
---> Package traceroute.i386 3:2.0.1-5.el5 set to be updated
---> Package php-imap.i386 0:5.1.6-23.2.el5_3 set to be updated
---> Package prelink.i386 0:0.4.0-2.el5 set to be updated
---> Package pam.i386 0:0.99.6.2-4.el5 set to be updated
---> Package python-pyblock.i386 0:0.26-3.el5 set to be updated
---> Package ppp.i386 0:2.4.4-2.el5 set to be updated
---> Package net-snmp.i386 1:5.3.2.2-5.el5_3.1 set to be updated
--> Running transaction check
---> Package h323plus.i386 0:1.20.5-0.99.cvs20090515.2 set to be updated
---> Package ptlib.i386 0:2.4.2-2 set to be updated
---> Package libselinux-utils.i386 0:1.33.4-5.1.el5 set to be updated
---> Package kernel-module-dahdi-xen.i686 0:2.1.0.4-15_2.6.18_92.1.22.el5 set to                                                                                                                                be updated
---> Package libtiff-devel.i386 0:3.8.2-7.el5_2.2 set to be updated
---> Package dbus-libs.i386 0:1.1.2-12.el5 set to be updated
---> Package kernel-module-dahdi.i686 0:2.1.0.4-15_2.6.18_92.1.22.el5 set to be                                                                                                                                updated
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 229, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 145, in main
    (result, resultmsgs) = base.buildTransaction()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 647, in buildTra                                                                                                                               nsaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 704, in resolveD                                                                                                                               eps
    for po, dep in self._checkFileRequires():
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 939, in _checkFi                                                                                                                               leRequires
    if not self.tsInfo.getOldProvides(filename) and not self.tsInfo.getNewProvid                                                                                                                               es(filename):
  File "/usr/lib/python2.4/site-packages/yum/transactioninfo.py", line 414, in g                                                                                                                               etNewProvides
    for pkg, hits in self.pkgSack.getProvides(name, flag, version).iteritems():
  File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 300, in getPr                                                                                                                               ovides
    return self._computeAggregateDictResult("getProvides", name, flags, version)
  File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 470, in _comp                                                                                                                               uteAggregateDictResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 861, in getPro                                                                                                                               vides
    return self._search("provides", name, flags, version)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 43, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 837, in _searc                                                                                                                               h
    for pkg in self.searchFiles(name, strict=True):
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 43, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 586, in search                                                                                                                               Files
    self._sql_pkgKey2po(rep, cur, pkgs)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 470, in _sql_p                                                                                                                               kgKey2po
    pkg = self._packageByKey(repo, ob['pkgKey'])
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 413, in _packa                                                                                                                               geByKey
    po = self.pc(repo, cur.fetchone())
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 68, in __init_                                                                                                                               _
    self._read_db_obj(db_obj)
  File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 94, in _read_d                                                                                                                               b_obj
    setattr(self, item, _share_data(db_obj[item]))
TypeError: unsubscriptable object
 

DaveD

Joined
Nov 12, 2007
Messages
597
Likes
0
Points
16
#2
Try typing yum clean all
Then run yum -y update
 

mattrh

Joined
Jul 15, 2008
Messages
175
Likes
0
Points
0
#3
fixed it, thanks
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,915
Messages
130,920
Members
17,595
Latest member
feparra121
Top