X100P Not disconnecting/ redirecting call

newboy

Joined
Mar 11, 2009
Messages
60
Likes
0
Points
0
#1
I have installed 1 Authentic X100P card in elastix 2.0.3.

The card is receiving and answering the call but the issues i am facing are:

1. When it picks up the call the call remains active even after it has been disconnected by the other person. Sometimes it disconnects after few seconds and sometimes i have to take out the phone cable from the socket to disconnect the call.

2. It is not redirecting the call according to the incoming route defined. It goes to the default path which has been set in Any DID / Any CID route. I have added the DID in FreePBX -> Zap Channel DID's (used the actual line number as the DID). I have used this as DID in the Incoming route.

Here are the settings:

Zap Trunk:
Trunk Name: 1
Dial Rules:
X.
Zap Identifier: 1

Zap Channel:
Channel: 1
Description: XXXXXX
DID: 61390123456


Incoming Route:
DID: 61390123456
Destination: Extension 4000


Can anyone suggest what could be the problem here? Thanks
 

Bob

Joined
Nov 4, 2007
Messages
2,400
Likes
1
Points
36
#2
newboy said:
I have installed 1 Authentic X100P card in elastix 2.0.3.
Can anyone suggest what could be the problem here? Thanks
Yep, the X100P card. B)

It is not an ideal card, the X100P card is basically a software based modem, not a dedicated voice card (the word authentic doesn't mean much). Likewise it does not have the additional chipset (I believe) that allows you to accurately match the impedance for the country's PSTN Network via config files. I suspect you are in Australia (by the DID) and from playing with these cards five or six years ago, they are definitely not suited to the Australia PSTN system (this does not mean that they won't work, just not optimum (and a cause of Echo).

Now I have had a bit of a rant....

The issue with the Hangup detection, is to do with the above and matching it to the line and country setup. However, you may be able to achieve hangup, by using the Busydetect and Busycount options in /etc/asterisk/chan_dahdi.conf (usually commented out by default)....

This option listens for a repeating tone of equal length and distance between the tones that repeats for the number that you set in the Busycount. Normally busycount=3 will work and hang up in an acceptable time. However this method is useless in a warehouse environment where the sound of a forklift reversing is enough to sound like a hangup tone, so the poor warehouse manager who was talking on the phone gets disconnected as the system believes it is a hangup tone that it is hearing. Anyhow an option for you, if you havent tried it yet....

The next issue is your CID info. If you set the ZAP DID in Freepbx, you need to modify your /etc/asterisk/dahdi_channels.conf....You should have something similar, and you need to change the context from from=pstn to from-zaptel for it to work

; Span 1: WCTDM/4 "Wildcard TDM400P REV I Board 5" (MASTER)
;;; line="4 WCTDM/4/3 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-zaptel
channel => 4
callerid=
group=
context=default

Hope this gives you some guidance...

Regards

Bob
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,898
Messages
130,879
Members
17,560
Latest member
manuelc
Top