X100P (1 FXO) no incoming call from PSTN

mairaeva

Joined
Feb 13, 2011
Messages
8
Likes
0
Points
0
#1
First Elastix installation
I have read and followed instructions "Elastix without tears"

WORKING :
sip to sip call
sip to PSTN

NOT WORKING :
PSTN to sip (extension never ring)

CONFIGURATION :
- FreePBX : have defined a DID number to the channel 1
- Inbound route : have created 2 inbound routes
* one with BLANK DID and BLANK CID => extension 100
* one with DID number defined earlier and BLANK CID => extension 100


DEBUGGING (asterisk -vvvr) :
I see asterisk "activity" when I call outside but when I call from PSTN there is no activity
I tried to ovveride [from-pstn] context in extension.conf to ANSWER() then ECHO() but when I call from PSTN it keeps ringing and no answer at all


I m confused cause I ve tried everything so I m asking for help
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#2
system.conf??? chan_dahdi.conf??? any logs or files
 

mairaeva

Joined
Feb 13, 2011
Messages
8
Likes
0
Points
0
#3
I have no "system.conf" (I have last version of Elastix)
For debugging purpose I even tried to force answering calls with Echo() application but still nothing is happening

Here are my chan_dadhdi.conf, dahdi_channels.conf, and extensions.conf :

chan_dahdi.conf
; Auto-generated by /usr/sbin/hardware_detector
[trunkgroups]

[channels]
context=from-pstn
signalling=fxs_ks
rxwink=300 ; Atlas seems to use long (250ms) winks
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
canpark=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=no
faxdetect=incoming
echotraining=800
rxgain=0.0
txgain=0.0
callgroup=1
pickupgroup=1

;Uncomment these lines if you have problems with the disconection of your analog lines
;busydetect=yes
;busycount=3


immediate=no

#include dahdi-channels.conf
#include chan_dahdi_additional.conf

dahdi_channels.conf
; Span 1: WCFXO/0 "Wildcard X100P Board 1" (MASTER)
;;; line="1 WCFXO/0/0"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-pstn
channel => 1
callerid=
group=
context=default

extensions.conf
#include extensions_custom.conf

[from-trunk] ; just an alias
include => from-pstn

[from-pstn]
;exten => s,1,Answer() ;I have tried to force answering calls here
;exten => s,2,Echo()
include => from-pstn-custom
include => ext-did
include => ext-did-post-custom
include => from-did-direct
include => ext-did-catchall
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#4
configs are standard and ok systems cong BTW is in etc/dahdi
do u have created an inbound route in freepbx????
 

mairaeva

Joined
Feb 13, 2011
Messages
8
Likes
0
Points
0
#5
Thank you for your help

I have created 2 inboud routes in the ELASTIX GUI :
- one catchall with BLANK DID and BLANK CID
- one with the DID that I have created in FreePBX as stated in the "Elastix without tears" guide

I have found the system.conf thank you
BTW where can I find the inbound route that I have created from Elastix GUI ?

What surprises me is that NOTHING is happening when I call from PSTN.
No context is called at all
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#6
your lines have or use polarity reverse switching...?????? that could be a cause....
 

mairaeva

Joined
Feb 13, 2011
Messages
8
Likes
0
Points
0
#7
How can I check the polarity of my line ?
Should I invert the polarity myself ?
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#8
Hi all
In France, "Orange" operator can use this parameter but it's only for hangup.
If the opertator use this information, prefere to use it, else count busy tone. (3).
 

fmvillares

Joined
Sep 8, 2007
Messages
1,785
Likes
0
Points
0
#9
+1 franck my friend
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#10
No problem Fernando. :laugh:
I just drink a punch planter at swiming pool. :laugh: :) B)
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,566
Latest member
Fpino
Top