X-Lite Registration Error: 404 Not Found

Discussion in 'Elastix 2.x' started by sadzas, Aug 6, 2008.

  1. sadzas

    Joined:
    Aug 5, 2008
    Messages:
    12
    Likes Received:
    0
    Hola gente:

    Estoy testeando esta nueva distro (que al parecer es excelente) y ya tengo un inconveniente de entrada:

    El soft X-Lite no se registra. (El Zoiper tampoco, pero me interesa el X-Lite)
    Antes que nada les cuento que no soy de pedir ayuda sin antes haber recorrido medio Google. Con esto les digo que leí cuanto manual haya de Elastix y cuanta configuración hayan hecho los usuarios. Tambien les cuento que no soy novato en VoIP y que trabajo en redes informáticas, por lo cual no piensen que la respuesta debe estar en un mal numero o un user invalido.

    Lei Elastix Without Tears. EXCELENTE! muy bien explicado, paso a paso, para novatos y para avanzados.
    Leí el fucking Elastix User Manual... y recorrí medio google...

    El X-Lite me da el error: Registration Error: 404: Not Found

    Les paso a comentar las versiones:
    X-Lite: version 3.0 Build 47546
    Elastix: 1.1-7

    La configuración que intenté es muy sencilla:

    Elastix:
    User Extension: 3000
    Display Name: Prueba
    Secret: 3000
    (Y ya que esta deshabilite el fax - por supuesto probe con el fax habilitado tambien-)

    En el lado X-Lite:

    Display Name: Prueba
    User Name: 3000
    Password: 3000
    Authorization user name: 3000
    Domain: xxx.xxx.xxx.xxx (IP del Elastix)

    Register - Sent Outbound via Domain.
    (Tambien Filter for honor - como decia el manual-)

    Creo que no olvidé poner nada, pero créanme que probé TODO.
    Leí por ahí en un foro, personas que crearon la extensión y se olvidaron de darle OK en: Apply Configuration Changes Here.

    Bueno, también descarten eso porque lo hice.

    Les comento de paso, que antes en este mismo server tenía funcionando un Brekeke (SIP SERVER) y el X-Lite se registraba sin inconvenientes, por lo cual, descarto problemas de red y demas... a menos que el Elastix posea algun secreto de red...

    Alguna idea???

    Por supuesto les estoy agradecido de antemano por haber leido algo tan extenso.

    Muchas Gracias
    Martin
     
  2. GatoZero

    Joined:
    Jun 14, 2008
    Messages:
    103
    Likes Received:
    0
    entra a Asterisk CLI , por consola

    y dale el siguiente comando "sip show peer (numero de extensión)"

    silfide*CLI> sip show peer 4150
    silfide*CLI>

    * Name : 4150
    Secret : <Set>
    MD5Secret : <Not set>
    Context : from-internal
    Subscr.Cont. : <Not set>
    Language :
    AMA flags : Unknown
    Transfer mode: open
    CallingPres : Presentation Allowed, Not Screened
    Callgroup :
    Pickupgroup :
    Mailbox : 4150@device
    VM Extension : asterisk
    LastMsgsSent : 0/0
    Call limit : 50
    Dynamic : Yes
    Callerid : "device" <4150>
    MaxCallBR : 384 kbps
    Expire : 3600
    Insecure : no
    Nat : Always
    ACL : No
    T38 pt UDPTL : No
    CanReinvite : No
    PromiscRedir : No
    User=Phone : No
    Video Support: No
    Trust RPID : No
    Send RPID : No
    Subscriptions: Yes
    Overlap dial : Yes
    DTMFmode : rfc2833
    LastMsg : 0
    ToHost :
    Addr->IP : 172.16.6.172 Port 51786
    Defaddr->IP : 0.0.0.0 Port 5060
    Def. Username: 4150
    SIP Options : (none)
    Codecs : 0xc (ulaw|alaw)
    Codec Order : (ulaw:20,alaw:20)
    Auto-Framing: No
    Status : OK (35 ms)
    Useragent : X-Lite release 1011s stamp 41150
    Reg. Contact : sip:4150@172.16.6.172:51786;rinstance=28fb13d7fade3358


    si no te sale asi es que no la tienes registrada, revisa que este biien creada

    la ultima seria, que el servicio de asterisk no esta registrando las extensiones

    intenta reiniciando el servicio

    [root@silfide /]# /etc/init.d/asterisk restart


    para ver si es que esta pegado el servicio

    espero que te ayude
     
  3. sadzas

    Joined:
    Aug 5, 2008
    Messages:
    12
    Likes Received:
    0
    Gracias GatoZero por la rapida respuesta!!

    Si, como dijiste, Elastix no reconoce la extensión. Ya que me indicó Peer 3000 not found.

    El tema de reiniciar el servicio no es, ya que te imaginarás que reinicié el server unas 45 veces. De todos modos corrí el comando en la consola local.
    (Por lo menos me queda claro que el problema está en el Elastix, y no en el X-Lite, osea, ya reduje las posibilidades un 50%)


    Como se soluciona este inconveniente? Como puede ser que la extensión esté mal creada? Aviso que borré la extensión unas 10 veces creando nuevas con diferentes numeros y Nombres.. y sigo igual...

    Gracias.
     
  4. GatoZero

    Joined:
    Jun 14, 2008
    Messages:
    103
    Likes Received:
    0
    debe ser un Bug de Elastix

    intenta instalar otra version de Elastix, pòr ejemplo la 1.0.17, yo manejo un pequeño call center, me toco devolverme a la versión 0.7.3 para estabilizarme debido a que habia un problema con las colas.

    Estos Bugs son dificiles de detectar y menos de encontrar

    Espero que te ayude

    Gatozero
     
  5. sadzas

    Joined:
    Aug 5, 2008
    Messages:
    12
    Likes Received:
    0
    mmmmm...

    te agradezco por la atención.. pero es posible que a esta altura posea un BUG tan grande? y que nadie lo haya reportado?

    Lo creo difícil. Pero como nada es imposible...

    Bueno, empezaré mi propio desarrollo de Asterisk desde 0... esperemos que funcione bien en Ubuntu...


    Gracias por todo.
     
  6. jlara

    Joined:
    Nov 1, 2007
    Messages:
    236
    Likes Received:
    0
    Saludos si te fijas alguien despues de ti hizo la misma pregunta ya que su extension no se registaba con la ultima version, si vas a esa pregunta encotraras la respuesta al problema ya que lo postie en su pregunta, pero para resumirte la ultima version tiene un BUG con el freepbx, se soluciona bajando la ultima version de freepbx. pero busca el post que te dije que hay le puse la respuesta a tu problema.


    un cordial saludo.
     

Share This Page