Working with Vonage

Discussion in 'General' started by makobox, Feb 24, 2011.

  1. makobox

    Joined:
    Feb 24, 2011
    Messages:
    1
    Likes Received:
    0
    Hi, we are currently using an Elastix ELX3000, from the original country...Ecuador..jejeje..well we have setup a Vonage trunk with this info:


    Vonage

    auth=md5
    context=from-pstn
    dtmfmode=inband
    fromdomain=216.115.20.41
    fromuser=XXXXX(number)
    hidecallerid=yes
    host=216.115.20.41
    nat=yes
    port=5061&5060
    secret=XXX(PASSWORD)
    type=peer
    qualify=yes
    insecure=port,invite



    Vonage-in

    auth=md5
    canreinvite=no
    context=from-pstn
    dtmfmode=inband
    fromdomain=216.115.20.41
    fromuser=XXXXX(number)
    host=216.115.20.41
    insecure=port,invite
    nat=yes
    port=5060&5061
    secret=XXX(PASSWORD)
    type=friend
    username=17863755167
    qualify=yes


    and the register string:

    XXXXX(number):XXX(PASSWORD)@216.115.20.41

    Well, the incoming when the people call to my XXXXX(number) everything is great...the IVR popups and everything is cool, the problem is for the outgoing we have an outbound route for the vonage(866)

    when we dial 8667860000000 where 7860000000 is any number in USA, the elastix says..."todas las lineas estan ocupadas" is because is in Spanish...in Enlgish would be "all circuits are busy now"

    when i ssh

    asterisk -rv
    sip set debug peer vonage

    the message is:



    <--- SIP read from UDP:216.115.20.41:5060 --->
    SIP/2.0 407 Proxy Authentication Required
    Via: SIP/2.0/UDP 216.115.20.41:5060;branch=z9hG4bK15246302;rport
    From: "Unknown" <sip:Unknown@190.95.215.147>;tag=as309ea2ac
    To: <sip:216.115.20.41>;tag=88505388
    Call-ID: 0d9b99073eee7ce201a817a56f5a49e9@190.95.215.147
    CSeq: 102 OPTIONS
    Proxy-Authenticate: Digest realm="216.115.20.41", domain="216.115.20.41", nonce="509222372", algorithm=MD5
    Max-forwards: 70
    Content-Length: 0


    <------------->


    Any help would be great

    Regards

    Marco Paucar
     

Share This Page