Web Interface returns nothing on PBX Tab

PatriotBob

Joined
Apr 15, 2010
Messages
1
Likes
0
Points
0
#1
Ok, I'll try to explain as best as I can.

I've been running a 1.5.2 box for about 9 months with out issue. Ever. Until 2 days ago a nice fellow from Korea decided to access a vulnerability in RoundCube (which i hadn't ever used) to run script, spam email, spoof HSBC's website, and recompile my kernel.

So yesterday I lock down the box as best I can an make a back up of the box using the backup/restore module on the web gui. Figuring now is a good as a time as any to upgrade to Elastix 1.6 I put the 1.6 iso on the box and restore the backup.

At this point all extensions, IVRs, queues, etc... are back and working in 1 hours time. I have access to the PBX web tab and minus 2 custom recording that needed to be re-uploaded to the box everything is working fine. I go home after a 13 hour day.

Come in this morning and the PBX Tab returns nothing. (Odd because I accessed it last night to check everything over)
The only thing I can find reporting an error is this from the ssl_error_log (trying to access https://192.168.6.251/index.php?menu=pbxconfig):

[Thu Apr 15 12:55:27 2010] [error] [client 192.168.6.33] PHP Notice: Undefined variable: skip_astman in /var/www/html/admin/header.php on line 117, referer: https://192.168.6.251/index.php?menu=network

At this point I'm at the end of my ability to troubleshoot, and while the system is "working" I need to be able to setup new extensions, etc...

Thanks in advanced.
 

zorandimit

Joined
Feb 18, 2009
Messages
11
Likes
0
Points
0
#2
Hi Bob
I have a similar problem, so I'll join your post
I have installed my system in November 2009, with Elastix 1.6 version, upgraded it to the last version (Free PBX 2.6, "yum -y update"), and everything worked perfectly. In the meantime I was regularly upgrading all the FreePBX modules to their last version for FreePBX 2.6. And then, few days ago, I decided to apply the command "yum -y update" again. After that I haven't noticed some problem, but when I tried to access my system by it's web interface yesterday, I founded that I can open the Elastix screen, and all other tabs, but I cannot open the PBX tab (the most important one). System is working and I can access it by putty or winscp, but I cannot open the FreePBX tab. I have checked the grub file, and my system is booting using the non-xen kernel.
I need help to try to repair my system, and bring back its functionality as it was before the last upgrade
Thanks in advance
 

Patrick_elx

Joined
Dec 14, 2008
Messages
1,120
Likes
0
Points
0
#3
the problem with the yum update is that you will sometimes see an update to a FreePBX version that is older to the one that you already updated manually within freePBX.

You should add freePBX.noarch to all the exclude lines in /etc/yum.repos.d/elastix.repo

exclude=elastix-mysqldbdata,freePBX.noarch


Then you will be sure that the yum will not downgrade your FreePBX.

To repair your system you just need to update your freepbx again. Either manually (by copying the new files to /var/www/html/admin from a proper system.
Or by trying to access to the freepbx gui update page (if it is still accessible): /admin/config.php?type=setup&display=modules
 

dvolaric

Joined
May 20, 2007
Messages
3
Likes
0
Points
0
#4
Today I update to current version and like you Web Interface returns nothing on PBX Tab.

After some research I find that solution is to write in console as root "pear install DB"
 

loconut

Joined
Nov 12, 2008
Messages
7
Likes
0
Points
0
#5
par install DB did it for me! Teh Yay.

Honestly, that should be in the %post of the elastix rpms.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,565
Latest member
omarmenichetti
Top