Voicemail not sending emails anymore

DjBac

Joined
May 20, 2009
Messages
137
Likes
0
Points
0
#1
Suddenly today my voicemail stopped sending me emails!! Even if I go to voicemail inbox, select the message and then email it, nothing!!
What I've just noticed is that hylafax won't send me emails either!

The only thing that I've changed today is that I recorderd some announcements, created some announcements and created an IVR!!!

Any help please??? Where should I check and what?
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#2
I will try to help you.

You could try to connect with SSH (putty for example) on root account.
And use this cmd:

# mail to your@mail.com [enter]
Subject: test [enter]
your message[ctrl]+[d]
Cc: [enter]
#

If you receive this message, it's good (for the mail process)
 

DjBac

Joined
May 20, 2009
Messages
137
Likes
0
Points
0
#3
I think I've found the problem. In main.cf my smtp relay was missing! Don't know why!!
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#4
ha!? it's strange!
One day, the main.conf.php was missing, and impossible to connect on ARI.
 

RustBoy

Joined
Apr 13, 2011
Messages
97
Likes
0
Points
16
#5
Re: Re:Voicemail not sending emails anymore

danardf said:
I will try to help you.

You could try to connect with SSH (putty for example) on root account.
And use this cmd:

# mail to your@mail.com [enter]
Subject: test [enter]
your message[ctrl]+[d]
Cc: [enter]
#

If you receive this message, it's good (for the mail process)
When I tried to send a test email using these commands in the terminal it returned the following error:

send-mail: fatal: /etc/postfix/main.cf, line 30: missing '=' after attribute name: "/etc/postfix/main.cf???\???# Global Postfix configuration file. This file lists only a subset"
[root@pbx spool]#
Can you please tell me what this means and how I can fix this problem? Our system was sending emails just fine for several months and then one day it just stopped working.

Thanks.
 

pmurphy

Joined
Feb 2, 2012
Messages
890
Likes
0
Points
0
#6
be sure to look at mail logs and test using command line you should be able to connect to the server you are relaying through
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#7
Hi all.

And perhaps to check the content of main.cfg at the line 30!
maybe this file is corrupted.
However, you must be careful, because this file is very sensitive.
Make a copy before any change.

It's possible you have several main.cfg.* files like main.cfg.elastix
Check the difference.

Usually, the mail works without extra configuration if you don't use any remote mail server.

Regards
 

RustBoy

Joined
Apr 13, 2011
Messages
97
Likes
0
Points
16
#8
Thanks for the help. I found two errors that were preventing our voicemail emails from going out.

1.) The gmail account that we were using as the SMTP relay had it's password changed and no one at our company updated it in our Elastix settings.

2.) During the trouble shooting process a random word inadvertently got pasted into the first line of the main.cf file.
 

pmurphy

Joined
Feb 2, 2012
Messages
890
Likes
0
Points
0
#9
Yep it is the simple stuff that will get you. Usually always human or hardware failure. Sounds like those darn humans got you twice.

If you use this for much more than a simple test or alert of some type I would suggest getting your own individual domain hosted somewhere since it is so cheap to get a hosted domain with email these days for this or setup your own real mail server. As things grow on you a service mail server for your IT needs will become more of a real need with monitoring and such.
 

Members online

Latest posts

Forum statistics

Threads
30,915
Messages
130,920
Members
17,594
Latest member
knethardsolutions
Top