Voicemail not sending emails anymore

Discussion in 'General' started by DjBac, Sep 12, 2009.

  1. DjBac

    Joined:
    May 20, 2009
    Messages:
    137
    Likes Received:
    0
    Suddenly today my voicemail stopped sending me emails!! Even if I go to voicemail inbox, select the message and then email it, nothing!!
    What I've just noticed is that hylafax won't send me emails either!

    The only thing that I've changed today is that I recorderd some announcements, created some announcements and created an IVR!!!

    Any help please??? Where should I check and what?
     
  2. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    I will try to help you.

    You could try to connect with SSH (putty for example) on root account.
    And use this cmd:

    # mail to your@mail.com [enter]
    Subject: test [enter]
    your message[ctrl]+[d]
    Cc: [enter]
    #

    If you receive this message, it's good (for the mail process)
     
  3. DjBac

    Joined:
    May 20, 2009
    Messages:
    137
    Likes Received:
    0
    I think I've found the problem. In main.cf my smtp relay was missing! Don't know why!!
     
  4. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    ha!? it's strange!
    One day, the main.conf.php was missing, and impossible to connect on ARI.
     
  5. RustBoy

    Joined:
    Apr 13, 2011
    Messages:
    97
    Likes Received:
    0
    Re: Re:Voicemail not sending emails anymore

    When I tried to send a test email using these commands in the terminal it returned the following error:

    Can you please tell me what this means and how I can fix this problem? Our system was sending emails just fine for several months and then one day it just stopped working.

    Thanks.
     
  6. pmurphy

    Joined:
    Feb 2, 2012
    Messages:
    890
    Likes Received:
    0
    be sure to look at mail logs and test using command line you should be able to connect to the server you are relaying through
     
  7. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Hi all.

    And perhaps to check the content of main.cfg at the line 30!
    maybe this file is corrupted.
    However, you must be careful, because this file is very sensitive.
    Make a copy before any change.

    It's possible you have several main.cfg.* files like main.cfg.elastix
    Check the difference.

    Usually, the mail works without extra configuration if you don't use any remote mail server.

    Regards
     
  8. RustBoy

    Joined:
    Apr 13, 2011
    Messages:
    97
    Likes Received:
    0
    Thanks for the help. I found two errors that were preventing our voicemail emails from going out.

    1.) The gmail account that we were using as the SMTP relay had it's password changed and no one at our company updated it in our Elastix settings.

    2.) During the trouble shooting process a random word inadvertently got pasted into the first line of the main.cf file.
     
  9. pmurphy

    Joined:
    Feb 2, 2012
    Messages:
    890
    Likes Received:
    0
    Yep it is the simple stuff that will get you. Usually always human or hardware failure. Sounds like those darn humans got you twice.

    If you use this for much more than a simple test or alert of some type I would suggest getting your own individual domain hosted somewhere since it is so cheap to get a hosted domain with email these days for this or setup your own real mail server. As things grow on you a service mail server for your IT needs will become more of a real need with monitoring and such.
     

Share This Page