Video Support - Can't get it to work

JohnyBeGood

Joined
May 18, 2008
Messages
134
Likes
0
Points
0
#1

zeus

Joined
Oct 25, 2007
Messages
60
Likes
0
Points
0
#2
This sip.conf is in /etc/asterisk or @ /var/www/html/admin/modules/core/etc ?

For this to work you must change the sip.conf in the 2nd path.

Try it.
 

JohnyBeGood

Joined
May 18, 2008
Messages
134
Likes
0
Points
0
#3
Hi,

Yes, I've used sip.conf in /etc/asterisk
Do I add it just below [general] in /var/www/html/admin/modules/core/etc ?
 

zeus

Joined
Oct 25, 2007
Messages
60
Likes
0
Points
0
#4
JohnyBeGood said:
Hi,

Yes, I've used sip.conf in /etc/asterisk
Do I add it just below [general] in /var/www/html/admin/modules/core/etc ?
Yes ;)
 

JohnyBeGood

Joined
May 18, 2008
Messages
134
Likes
0
Points
0
#5
Ok, I've added bellow to the /var/www/html/admin/modules/core/etc/sip.conf file

; Note: If your SIP devices are behind a NAT and your Asterisk
; server isn't, try adding "nat=1" to each peer definition to
; solve translation problems.

[general]
; start of video support http://www.elastix.org/index.php?option ... eo_support
videosupport=yes
maxcallbitrate=384

allow=h261
allow=h263
allow=h263p
allow=h264


;end video support

#include sip_general_additional.conf

bindport = 5060 ; Port to bind to (SIP is 5060)
bindaddr = 0.0.0.0 ; Address to bind to (all addresses on machine)
disallow=all
allow=ulaw
allow=alaw
; If you need to answer unauthenticated calls, you should change this
; next line to 'from-trunk', rather than 'from-sip-external'.
; You'll know this is happening if when you call in you get a message
; saying "The number you have dialed is not in service. Please check the
; number and try again."
context = from-sip-external ; Send unknown SIP callers to this context
callerid = Unknown
tos=0x68

; Reported as required for Asterisk 1.4
notifyringing=yes
notifyhold=yes
limitonpeers=yes

; enable and force the sip jitterbuffer. If these settings are desired
; they should be set in the sip_general_custom.conf file as this file
; will get overwritten during reloads and upgrades.
;
; jbenable=yes
; jbforce=yes

; #, in this configuration file, is NOT A COMMENT. This is exactly
; how it should be.
#include sip_general_custom.conf
#include sip_nat.conf
#include sip_registrations_custom.conf
#include sip_registrations.conf
#include sip_custom.conf
#include sip_additional.conf
#include sip_custom_post.conf
It still says "could not start video" ?
 

zeus

Joined
Oct 25, 2007
Messages
60
Likes
0
Points
0
#6
Ok try this from my sip.conf

; do not edit this file, this is an auto-generated file by freepbx
; all modifications must be done from the web gui

[general]
;
; enable and force the sip jitterbuffer. If these settings are desired
; they should be set in the sip_general_custom.conf file as this file
; will get overwritten during reloads and upgrades.
;
disallow=all
videosupport=yes
maxcallbitrate=384

allow=h261
allow=h263
allow=h263p
allow=h264
allow=ulaw
allow=alaw
; jbenable=yes
; jbforce=yes
nat=yes
; These will all be included in the [general] context
;
#include sip_general_additional.conf
#include sip_general_custom.conf
#include sip_nat.conf
#include sip_registrations_custom.conf
#include sip_registrations.conf

; These should all be expected to come after the [general] context
;
#include sip_custom.conf
#include sip_additional.conf
#include sip_custom_post.conf

After save the file do an amportal restart and video support should work.
To see if the video support is on in the asterisk CLI type "sip show settings".
let me know.
 

JohnyBeGood

Joined
May 18, 2008
Messages
134
Likes
0
Points
0
#7
Still no joy :(

elastix*CLI> sip show settings
elastix*CLI>

Global Settings:
----------------
SIP Port: 5060
Bindaddress: 0.0.0.0
Videosupport: No
AutoCreatePeer: No
Allow unknown access: Yes
Allow subscriptions: Yes
Allow overlap dialing: Yes
Promsic. redir: No
SIP domain support: No
Call to non-local dom.: Yes
URI user is phone no: No
Our auth realm asterisk
Realm. auth: No
Always auth rejects: No
Call limit peers only: Yes
Direct RTP setup: No
User Agent: Asterisk PBX
MWI checking interval: 10 secs
Reg. context: (not set)
Caller ID: Unknown
From: Domain:
Record SIP history: Off
Call Events: Off
IP ToS SIP: AF31
IP ToS RTP audio: AF31
IP ToS RTP video: AF31
T38 fax pt UDPTL: No
RFC2833 Compensation: No
SIP realtime: Disabled

Global Signalling Settings:
---------------------------
Codecs: 0xc (ulaw|alaw)
Codec Order: ulaw:20,alaw:20
T1 minimum: 100
Relax DTMF: No
Compact SIP headers: No
RTP Keepalive: 0 (Disabled)
RTP Timeout: 0 (Disabled)
RTP Hold Timeout: 0 (Disabled)
MWI NOTIFY mime type: application/simple-message-summary
DNS SRV lookup: Yes
Pedantic SIP support: No
Reg. min duration 60 secs
Reg. max duration: 3600 secs
Reg. default duration: 120 secs
Outbound reg. timeout: 20 secs
Outbound reg. attempts: 0
Notify ringing state: Yes
Notify hold state: Yes
SIP Transfer mode: open
Max Call Bitrate: 384 kbps
Auto-Framing: No

Default Settings:
-----------------
Context: from-sip-external
Nat: RFC3581
DTMF: rfc2833
Qualify: 0
Use ClientCode: No
Progress inband: Never
Language: (Defaults to English)
MOH Interpret: default
MOH Suggest:
Voice Mail Extension: asterisk

----
elastix*CLI>
I copied your settings into my /var/www/html/admin/modules/core/etc/sip.conf file
 

zeus

Joined
Oct 25, 2007
Messages
60
Likes
0
Points
0
#8
There must be a problem with symlinks. Copy the same settings to /etc/asterisk/sip.conf.
Then make an amportal restart and check if video in on.
The logic says that it must work.
 

zeus

Joined
Oct 25, 2007
Messages
60
Likes
0
Points
0
#9
here is my sip show settings

SIP Port: 5060
Bindaddress: 0.0.0.0
Videosupport: Yes
AutoCreatePeer: No
Allow unknown access: Yes
Allow subscriptions: Yes
Allow overlap dialing: Yes
Promsic. redir: No
SIP domain support: No
Call to non-local dom.: Yes
URI user is phone no: No
Our auth realm asterisk
Realm. auth: No
Always auth rejects: No
Call limit peers only: Yes
Direct RTP setup: No
User Agent: Asterisk PBX
MWI checking interval: 10 secs
Reg. context: (not set)
Caller ID: Unknown
From: Domain: banasios.no-ip.biz
Record SIP history: Off
Call Events: Off
IP ToS SIP: CS3
IP ToS RTP audio: EF
IP ToS RTP video: AF41
T38 fax pt UDPTL: No
RFC2833 Compensation: No
SIP realtime: Disabled
ippbx*CLI>
Global Signalling Settings:
---------------------------
Codecs: 0xc (ulaw|alaw)
Codec Order: ulaw:20,alaw:20
T1 minimum: 100
Relax DTMF: No
Compact SIP headers: No
RTP Keepalive: 0 (Disabled)
RTP Timeout: 0 (Disabled)
RTP Hold Timeout: 0 (Disabled)
MWI NOTIFY mime type: application/simple-message-summary
DNS SRV lookup: Yes
Pedantic SIP support: No
Reg. min duration 60 secs
Reg. max duration: 3600 secs
Reg. default duration: 120 secs
Outbound reg. timeout: 20 secs
Outbound reg. attempts: 0
Notify ringing state: Yes
Notify hold state: Yes
SIP Transfer mode: open
Max Call Bitrate: 384 kbps
Auto-Framing: No

Default Settings:
-----------------
Context: from-sip-external
Nat: Always
DTMF: rfc2833
Qualify: 2000
Use ClientCode: No
Progress inband: Never
Language: el
MOH Interpret: default
MOH Suggest:
Voice Mail Extension: *97
 

JohnyBeGood

Joined
May 18, 2008
Messages
134
Likes
0
Points
0
#10
Finally got it working! ;)

I copied
videosupport=yes
maxcallbitrate=384

allow=h261
allow=h263
allow=h263p
allow=h264
after disallow=all statement in /etc/asterisk/sip.conf
Thanks for your help!
Now it shows that video is supported

elastix*CLI> sip show settings
elastix*CLI>

Global Settings:
----------------
SIP Port: 5060
Bindaddress: 0.0.0.0
Videosupport: Yes
AutoCreatePeer: No
Allow unknown access: Yes
Allow subscriptions: Yes
Allow overlap dialing: Yes
Promsic. redir: No
SIP domain support: No
Call to non-local dom.: Yes
URI user is phone no: No
Our auth realm asterisk
Realm. auth: No
Always auth rejects: No
Call limit peers only: Yes
Direct RTP setup: No
User Agent: Asterisk PBX
MWI checking interval: 10 secs
Reg. context: (not set)
Caller ID: Unknown
From: Domain:
Record SIP history: Off
Call Events: Off
IP ToS SIP: AF31
IP ToS RTP audio: AF31
IP ToS RTP video: AF31
T38 fax pt UDPTL: No
RFC2833 Compensation: No
SIP realtime: Disabled
elastix*CLI>
Global Signalling Settings:
---------------------------
Codecs: 0x3c000c (ulaw|alaw|h261|h263|h263p|h264)
Codec Order: ulaw:20,alaw:20
T1 minimum: 100
Relax DTMF: No
Compact SIP headers: No
RTP Keepalive: 0 (Disabled)
RTP Timeout: 0 (Disabled)
RTP Hold Timeout: 0 (Disabled)
MWI NOTIFY mime type: application/simple-message-summary
DNS SRV lookup: Yes
Pedantic SIP support: No
Reg. min duration 60 secs
Reg. max duration: 3600 secs
Reg. default duration: 120 secs
Outbound reg. timeout: 20 secs
Outbound reg. attempts: 0
Notify ringing state: Yes
Notify hold state: Yes
SIP Transfer mode: open
Max Call Bitrate: 384 kbps
Auto-Framing: No
elastix*CLI>
Default Settings:
-----------------
Context: from-sip-external
Nat: RFC3581
DTMF: rfc2833
Qualify: 0
Use ClientCode: No
Progress inband: Never
Language: (Defaults to English)
MOH Interpret: default
MOH Suggest:
Voice Mail Extension: asterisk
elastix*CLI>
 

cruzzmz

Joined
Aug 4, 2008
Messages
9
Likes
0
Points
0
#11
I have edit my sip.conf and put the above lines in it
[general]
disallow=all
videosupport=yes
maxcallbitrate=384

allow=h261
allow=h263
allow=h263p
allow=h264
then i do at
CLI>reload
then i do
CLI> sip show settings
i only get this at

Global Signalling Settings:
---------------------------
Codecs: 0xc (ulaw|alaw)
Codec Order: ulaw:20,alaw:20
T1 minimum: 100
Relax DTMF: No
Compact SIP headers: No
RTP Keepalive: 0 (Disabled)
RTP Timeout: 0 (Disabled)

anyone could help????
 

zeus

Joined
Oct 25, 2007
Messages
60
Likes
0
Points
0
#12
do an amportal restart. If this don't work read this post from the beginning and make the steps as described.
 

zeus

Joined
Oct 25, 2007
Messages
60
Likes
0
Points
0
#13
JohnyBeGood said:
Finally got it working! ;)
Good for you.
In the future maybe you may have some problems with freepbx updates because freepbx use /var/www/html/admin/modules/core/etc/ path.

Regards ;)
 

JohnyBeGood

Joined
May 18, 2008
Messages
134
Likes
0
Points
0
#14
zeus said:
JohnyBeGood said:
Finally got it working! ;)
Good for you.
In the future maybe you may have some problems with freepbx updates because freepbx use /var/www/html/admin/modules/core/etc/ path.

Regards ;)
Thanks for the tip!
 

JohnyBeGood

Joined
May 18, 2008
Messages
134
Likes
0
Points
0
#15
cruzzmz said:
I have edit my sip.conf and put the above lines in it
[general]
disallow=all
videosupport=yes
maxcallbitrate=384

allow=h261
allow=h263
allow=h263p
allow=h264
Did you made changes in /etc/asterisk/sip.conf ?
after changing that file I got it to work.
 

cruzzmz

Joined
Aug 4, 2008
Messages
9
Likes
0
Points
0
#16
here is the copy of my
etc/asterisk/sip.conf

; do not edit this file, this is an auto-generated file by freepbx
; all modifications must be done from the web gui

[general]
disallow=all
videosupport=yes
maxcallbitrate=384

allow=h261
allow=h263
allow=h263p
allow=h264
;
; enable and force the sip jitterbuffer. If these settings are desired
; they should be set in the sip_general_custom.conf file as this file
; will get overwritten during reloads and upgrades.
;

; jbenable=yes
; jbforce=yes
nat=yes
; These will all be included in the [general] context
;
#include sip_general_additional.conf
#include sip_general_custom.conf
#include sip_nat.conf
#include sip_registrations_custom.conf
#include sip_registrations.conf

; These should all be expected to come after the [general] context
;
#include sip_custom.conf
#include sip_additional.conf
#include sip_custom_post.conf
BTW how do i do a amportal restat?
 

zeus

Joined
Oct 25, 2007
Messages
60
Likes
0
Points
0
#17
From linux command line
#amportal restart
 

cruzzmz

Joined
Aug 4, 2008
Messages
9
Likes
0
Points
0
#18
in my sip show settings, it still show no support for video call :(

eventhough i have done amportal restart

Global Signalling Settings:
---------------------------
Codecs: 0xc (ulaw|alaw)
Codec Order: ulaw:20,alaw:20
T1 minimum: 100
Relax DTMF: No
Compact SIP headers: No
RTP Keepalive: 0 (Disabled)
RTP Timeout: 0 (Disabled)
RTP Hold Timeout: 0 (Disabled)
MWI NOTIFY mime type: application/simple-message-summary
DNS SRV lookup: Yes
Pedantic SIP support: No
Reg. min duration 60 secs
Reg. max duration: 3600 secs
Reg. default duration: 120 secs
Outbound reg. timeout: 20 secs
Outbound reg. attempts: 0
Notify ringing state: Yes
Notify hold state: Yes
SIP Transfer mode: open
Max Call Bitrate: 384 kbps
Auto-Framing: No
:S Help !!!!
 

cruzzmz

Joined
Aug 4, 2008
Messages
9
Likes
0
Points
0
#19
still no luck in making this possible .... anyone pls help
 

JohnyBeGood

Joined
May 18, 2008
Messages
134
Likes
0
Points
0
#20
Make a backup of your sip.conf and replace it with mine. Do a reload and amportal restart afterwards.


; Note: If your SIP devices are behind a NAT and your Asterisk
; server isn't, try adding "nat=1" to each peer definition to
; solve translation problems.

[general]
#include sip_general_additional.conf

bindport = 5060 ; Port to bind to (SIP is 5060)
bindaddr = 0.0.0.0 ; Address to bind to (all addresses on machine)
disallow=all
; Start of video support http://www.elastix.org/index.php?option ... eo_support

videosupport=yes
maxcallbitrate=384

allow=h261
allow=h263
allow=h263p
allow=h264

; End of video support
allow=ulaw
allow=alaw
; If you need to answer unauthenticated calls, you should change this
; next line to 'from-trunk', rather than 'from-sip-external'.
; You'll know this is happening if when you call in you get a message
; saying "The number you have dialed is not in service. Please check the
; number and try again."
context = from-sip-external ; Send unknown SIP callers to this context
callerid = Unknown
tos=0x68

; Reported as required for Asterisk 1.4
notifyringing=yes
notifyhold=yes
limitonpeers=yes

; enable and force the sip jitterbuffer. If these settings are desired
; they should be set in the sip_general_custom.conf file as this file
; will get overwritten during reloads and upgrades.
;
; jbenable=yes
; jbforce=yes

; #, in this configuration file, is NOT A COMMENT. This is exactly
; how it should be.
#include sip_general_custom.conf
#include sip_nat.conf
#include sip_registrations_custom.conf
#include sip_registrations.conf
#include sip_custom.conf
#include sip_additional.conf
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,565
Latest member
omarmenichetti
Top