Very poor voice quality

Discussion in 'General' started by Ashraf.jabali, Nov 18, 2009.

  1. Ashraf.jabali

    Joined:
    Nov 15, 2009
    Messages:
    22
    Likes Received:
    0
    Hi all

    I have problem with the voice quality in some call not all of them

    My elastix server has 12 Ap0012 with 12 FXO port conected to PSTN lines

    please note that i didn't change any thing in codec configration, or any configration i kept every thing as it is from intallation time till now

    more over the agent voice is clear, only the caller voice has bad quality voice


    can any one can help me with this problem or has any idea about this

    Regards
     
  2. powerline

    Joined:
    Sep 8, 2009
    Messages:
    12
    Likes Received:
    0
    I have the same problem with you.
    The pstn lines are ok, because they are good from provider and bring 60volts, if you meter them.
    In 2 FCT Mobile terminals I have this problem and I make rxgain=2 txgain=9 [ you can make tests with these 2 values] and now they can hear me .
    The location is \etc\asterisk\chan_dahdi.conf
     
  3. vasistsrinivas

    Joined:
    Oct 26, 2012
    Messages:
    14
    Likes Received:
    0
    Dear All,

    I am facing the Poor voice Quality in Elastix Server, the problem is Agents voice not audible to Customers & Vice Versa.

    I am using Ubuntu operating system for Agents (12.04)

    1.I check the LAN it is working fine without single packet drop.
    2.My PRI card & it configuration is working fine.
    3.I have modified the entry in \etc\asterisk\chan_dahdi.conf, the entry rxgain=2 txgain=9
    Previously it was 0.0
    4.I checked my headset is also working fine.

    Still I am facing the same problem, Please help in fixing this problem.

    Thanking you
    Regards,
    Vasistsrinivas
     
  4. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Hi...

    I'll try to help you.

    First, be careful with the rx/txgain values. It's explained in dB. So +2 and +9 dB it's too much.

    About the audio quality, try to add a QoS on your LAN, and try to calculate how many band width you need with your codec curently used. (Side LAN and VoIP of course, not side PCI Card).

    Next, try to make any Elastix update (Asterisk, Dahdi...Etc)
     

Share This Page