Version 1.0 FreePBX module error

CleveJ

Joined
Nov 12, 2007
Messages
100
Likes
0
Points
0
#1
Installation went well but when I went to FreePBX to update the modules I got this error

Downloading framework 2401706 of 2401706 (100%)
Untarring..Done.
error copying framework files:
'cp -rf' from src: '/var/www/html/admin/modules/frame­ work/htdocs/*' to dst: '/var/www/html'...details follow
cp: cannot create directory `/var/www/html/_asterisk': Permission denied
cp: cannot create directory `/var/www/html/recordings': Permission denied
Checking for upgrades..No upgrades found
framework installed successfully Looks like Freepbx is still showing 2.3 and not 2.4
 

CleveJ

Joined
Nov 12, 2007
Messages
100
Likes
0
Points
0
#2
As I have had no responce, I would gather my case migh be isolated. Here is what I did to resolve the issue.

1. I manually copied both the folders over to var/www/html
2. Changed permission to the 2 folders from "root" to "asterisk"
3. Updated Freepbx using this following
cd /usr/src/
wget http://mirror.freepbx.org/freepbx-2.4.0.tar.gz
tar zxvf freepbx-2.4.0.tar.gz
cd freepbx-2.4.0
./install_amp
4. Logged into Freepbx and updated all the modules.

Hope this helps someone
 

CleveJ

Joined
Nov 12, 2007
Messages
100
Likes
0
Points
0
#3
Deleted double post.<br><br>Post edited by: CleveJ, at: 2008/07/07 07:05
 

fabianus

Joined
Nov 8, 2007
Messages
106
Likes
0
Points
0
#4
Hello Stilllearning,

thanks a lot for this help !

Was very usefull to me.

Regards,
Fabianus
 

CleveJ

Joined
Nov 12, 2007
Messages
100
Likes
0
Points
0
#5

Members online

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,567
Latest member
achilont13
Top