User login has no FollowMe or CFW settings

Discussion in 'General' started by yesmat, Aug 28, 2009.

  1. yesmat

    Joined:
    Mar 16, 2009
    Messages:
    103
    Likes Received:
    0
    Hi All,

    I probably asked similar question before but got no where.

    I believe that Elastix has the best and cleanest Admin and User interface there is. But i have a simple question:

    Can users change and control their FollowMe and CFW settings from their own user portal? they sure can do alot of other stuff but I can't find anywhere where users can set these settings.

    Has anyone noticed that? is there another way that I am not aware of where users can control these settings (Other than the phone itself)?

    Really appreciate your feedback and response, we have a 40 user deployment next week and we are still not sure if we will be using Elastix or not depending on these features.

    Thanks
     
  2. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    You have to set a follow-me setting in FreePBX befor4e you get to see it in the ARI (if that portal is to which you refer
    https://<ipaddress>/recordings )
     
  3. yesmat

    Joined:
    Mar 16, 2009
    Messages:
    103
    Likes Received:
    0
    I understand but my problem is that ARI is not functioning propoerly and I am unable to access it, when i go <IP Address>/recordings i get the following message:

    ARI does not appear to have access to the Asterisk Manager. ()
    Check the ARI 'main.conf.php' configuration file to set the Asterisk Manager Account.
    Check /etc/asterisk/manager.conf for a proper Asterisk Manager Account
    make sure [general] enabled = yes and a 'permit=' line for localhost or the webserver.

    Here is a copy of my /etc/asterisk/manager.conf:

    ;
    ; Asterisk Call Management support
    ;
    [general]
    enabled = yes
    port = 5038
    bindaddr = 0.0.0.0

    [admin]
    secret = elastix456
    deny=0.0.0.0/0.0.0.0
    permit=127.0.0.1/255.255.255.0
    read = system,call,log,verbose,command,agent,user
    write = system,call,log,verbose,command,agent,user

    #include manager_additional.conf
    #include manager_custom.conf


    Is there anything missing there?

    Thanks
     
  4. yesmat

    Joined:
    Mar 16, 2009
    Messages:
    103
    Likes Received:
    0
    One more thing i discovered, there is no main.conf.php on the server at all. That must be the problem.

    Elastix has done a brilliant job in integrating all different components under single user login, why not this one too?
     
  5. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Your original post made no mention of the fact that ARI was not working "at all", however:

    You will definitely need that file: :)

    Code:
    cd /var/www/html/recordings/includes/
    wget http://www.freepbx.org/trac/browser/freepbx/trunk/amp_conf/htdocs/recordings/includes/main.conf.php
    chown asterisk:asterisk  main.conf.php
    chmod 664 main.conf.php
    
    (just 4 lines, brain-dead FireBoard software warning as ever)

    danardf has previously posted on this subject

    (I suggest you go join the Beta bunch and express your frustrations more closer to the source)

    [edit]
    edit the downloaded file to get rid of the html stuff after the wget, sorry too lazy to find the real file
     
  6. yesmat

    Joined:
    Mar 16, 2009
    Messages:
    103
    Likes Received:
    0
    Thanks Dicko - I have downloaded the file, changed owner and permissions ran amportal restart but now I am getting all sorts of goobly goo that looks like FreePBX website and at the bottom still the same error.

    Is that the right file? do I need to edit any of it?
     
  7. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    sorry don't speak goobly goo,

    restart httpd (or the whole shebang) and post a screen shot.
     
  8. yesmat

    Joined:
    Mar 16, 2009
    Messages:
    103
    Likes Received:
    0
    Got it thanks, its working now.

    The wget<> command that I used earlier downloaded the webpage itself where the file was displayed and not the file itself for some reason. so I had to copy it manualy and it is all cool now.

    It would be really good if we coul dintegrate that ARI interface under Elastix user login, maybe with release 2.0, but hey no complaints.

    thanks for your help.
     
  9. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Glad you got it working, it was probably my error in posting the wrong link,

    please reciprocate by posting your request to the the Beta List, where the real power is and functional changes can be committed .
     

Share This Page