urgent prudction problem

fabianus

Joined
Nov 8, 2007
Messages
106
Likes
0
Points
0
#1
Hello all !

Suddenly (I was doing some modification on FreePBX I get the following error when doing the application of the changes :

exit: 255Checking for PEAR DB..OK
Checking for PEAR Console::Getopt..OK
Checking for /etc/amportal.conf ..OK
Bootstrapping /etc/amportal.conf ..OK
Parsing /etc/amportal.conf ..OK
Parsing /etc/asterisk/asterisk.conf ..OK
Connecting to database..OK
Connecting to Asterisk manager interface..OK
Added to globals: ASTETCDIR = /etc/asterisk
Added to globals: ASTMODDIR = /usr/lib/asterisk/modules
Added to globals: ASTVARLIBDIR = /var/lib/asterisk
Added to globals: ASTAGIDIR = /var/lib/asterisk/agi-bin
Added to globals: ASTSPOOLDIR = /var/spool/asterisk
Added to globals: ASTRUNDIR = /var/run/asterisk
Added to globals: ASTLOGDIR = /var/log/asteriskAdded to globals: CWINUSEBUSY = true
Added to globals: AMPMGRUSER = admin
Added to globals: AMPMGRPASS = elastix456
PHP Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 39 bytes) in /var/www/html/admin/extensions.class.php on line 63
1 error(s) occured, you should view the notification log on the dashboard or main screen to check for more details

I do not remember which change caused this problem. Could you help me to understand where I have to correct things?

Thanks you very much for any quick help as this is a production server and none of my changes are taken into account ...

Regards,
Fabianus

PS Here is what I find on the dashboard :
Reload failed because retrieve_conf encountered an error: 255<br><br>Post edited by: fabianus, at: 2008/07/23 22:27
 

Bob

Joined
Nov 4, 2007
Messages
2,400
Likes
1
Points
36
#2
Fabianus,

Have not seen this issue before, and probably needs some more investigation. While the answer I give may help you (and I state may!!) to solve the immediate issue, the fact that it ran out of memory, is an issue and points to a mainstream issue that needs to be resolved.

The file /etc/php.ini maintains the settings for PHP. You should change this to allocate more memory for PHP changing the memory_limit to 32Mb from the original 16Mb. e.g.


;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;

max_execution_time = 30 ; Maximum execution time of each script, in seconds
max_input_time = 60 ; Maximum amount of time each script may spend parsing $
memory_limit = 32M ; Maximum amount of memory a script may consume.

just remember to reboot the system after the changes...

Hope it helps somehow...

Regards

Bob
 

fabianus

Joined
Nov 8, 2007
Messages
106
Likes
0
Points
0
#3
Dear Bob !

This was the reason of my problem. Excuse-me for not having noted it before, because I already found the solution some hours ago. I am almost sure that I posted it here, but I do not find it anymore ... :-(

Excuse-me for having taken your time and thank you nevertheless for your kind support - your suggestions are always solutions :)

Best regards,
Fabianus

PS - I have a tricky one here :
http://www.freepbx.org/forum/freepbx/us ... -extension

Perhaps you have some more minutes ;-)
 

Bob

Joined
Nov 4, 2007
Messages
2,400
Likes
1
Points
36
#4
Fabianus,

Thanks for the confirmation that it did fix your problem, even though you found it earlier.

I have no problems with the time taken as others are surely going to come across this sort of issue, and a thread that is properly ended (e.g. a solution) is always going to be of use for others.

Regards

Bob
 

Bob

Joined
Nov 4, 2007
Messages
2,400
Likes
1
Points
36
#5
Will look at your other question a little later. Have just woken up and need some caffeine . I tried reading your question and it was doing my head in a little.:pinch:

Instead of saying the question needs to be more clear, I thought I would wake up first, in case it is me.:cheer:

Regards

Bob
 

fabianus

Joined
Nov 8, 2007
Messages
106
Likes
0
Points
0
#6
:laugh:
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,981
Messages
131,060
Members
17,704
Latest member
Pahntom
Top