urgent !Plzzz [ERROR] SAVING RECORDING:

Discussion in 'General' started by farrukhndm, May 25, 2010.

  1. farrukhndm

    Joined:
    May 24, 2010
    Messages:
    32
    Likes Received:
    0
    [ERROR] SAVING RECORDING:
    "cp: cannot create regular file `/var/lib/asterisk/sounds/custom/IVR123.wav': Permission denied
    Make sure you have entered a proper name "

    While when i checked custom dir permissions it shows
    #ls -ltr /var/lib/asterisk/sounds/ | grep custom
    drwxr-xr-x 2 root root 4096 May 24 16:27 custom

    Then i changed it to
    #chown asterisk:asterisk /var/lib/asterisk/sounds/custom
    #chmod 777 /var/lib/asterisk/sounds/custom

    After Changing Permission
    #ls -ltr /var/lib/asterisk/sounds/ | grep custom
    drwxrwxrwx 2 asterisk asterisk 4096 May 24 16:27 custom


    But Still Having same problem When Uploading System Recording for My Compnay IVR.Help me please,its my production server and its IVR is Disable from Last 15 Hours.
     
  2. farrukhndm

    Joined:
    May 24, 2010
    Messages:
    32
    Likes Received:
    0
    Solved! urgent !Plzzz [ERROR] SAVING RECORDING:

    Resolved!

    Cat /etc/asterisk/asterisk.conf
    [directories]
    astetcdir => /etc/asterisk
    astmoddir => /usr/lib/asterisk/modules
    astvarlibdir => /var/lib/asterisk
    astagidir => /var/lib/asterisk/agi-bin
    astspooldir => /var/spool/asterisk
    astrundir => /var/run/asterisk
    astlogdir => /var/log/asterisk
    astdatadir => /var/lib/asterisk

    [options]
    transmit_silence_during_record = yes
    languageprefix=yes
    execincludes=yes


    ### The Empty line should be remove to fix System Recording issue in Elastix-1.6.0-i386-bin-29Oct2009
    astdatadir => /var/lib/asterisk

    [options]


    For further Help go to
    www.elastix.org/component/option,com_fi ... ,en/#53274
     
  3. eiger3970

    Joined:
    Apr 29, 2009
    Messages:
    112
    Likes Received:
    0
    Hi, I just tried this fix for the same 'system recording' error of 'Permission denied. Make sure you have entered a proper name'.

    I removed the blank line in asterisk.conf. While the above error stopped, I now receive another error: 'Failed to create /var/lib/asterisk/sounds/custom'

    I also have now replaced the space line in the asterisk.conf file and this does not create the same original error as first encountered.
    Now I receive the error: 'Failed to create /var/lib/asterisk/sounds/custom' rather than 'Permission denied. Make sure you have entered a proper name'.

    Please assist if anyone knows?
     
  4. memed

    Joined:
    Jun 27, 2010
    Messages:
    2
    Likes Received:
    0
    I got the same problem on the lastest 64 bit version. I solved the problem by doing a chmod 777 /var/lib/asterisk/sounds/custom and removing the empty line.
     
  5. eiger3970

    Joined:
    Apr 29, 2009
    Messages:
    112
    Likes Received:
    0
    Thanks. I have double checked the File Editor asterisk.conf and the space is removed on the lines. The file shows like this now:

    [directories]
    astetcdir => /etc/asterisk
    astmoddir => /usr/lib/asterisk/modules
    astvarlibdir => /var/lib/asterisk
    astagidir => /var/lib/asterisk/agi-bin
    astspooldir => /var/spool/asterisk
    astrundir => /var/run/asterisk
    astlogdir => /var/log/asterisk
    astdatadir => /var/lib/asterisk
    [options]
    transmit_silence_during_record = yes
    languageprefix=yes
    execincludes=yes


    I have run the Unix change mode to read write and execute with the putty command chmod 777 /var/lib/asterisk/sounds/custom, however this seems to not change any mode? See putty below:

    [root@xxxxxxxxxxxx ~]# chmod 777 /var/lib/asterisk/sounds/custom
    [root@xxxxxxxxxxxx ~]#


    I have tested saving the 'System recordings' again, however the same error comes up in the Elastix gui:

    Failed to create /var/lib/asterisk/sounds/custom.
     
  6. memed

    Joined:
    Jun 27, 2010
    Messages:
    2
    Likes Received:
    0
    what does ll /var/lib/asterisk/sounds/ | grep cus give?
     
  7. eiger3970

    Joined:
    Apr 29, 2009
    Messages:
    112
    Likes Received:
    0
    Hi memed,
    here are the results:

    [root@xxxxxxxxxxxx ~]# ll /var/lib/asterisk/sounds | grep cus
    -rw-r--r-- 1 asterisk asterisk 2970 Dec 27 2009 at-customers-request.gsm
    drwxrwxrwx 2 asterisk asterisk 4096 May 30 21:39 custom
    -rw-r--r-- 1 asterisk asterisk 1980 Dec 27 2009 customer-accounts.gsm
    -rw-r--r-- 1 asterisk asterisk 2244 Dec 27 2009 customer-relations.gsm
    -rw-r--r-- 1 asterisk asterisk 2046 Dec 27 2009 customer-service.gsm
    -rw-r--r-- 1 asterisk asterisk 4620 Dec 27 2009 lines-complaining-customers.gsm
    -rw-r--r-- 1 asterisk asterisk 3168 Dec 27 2009 there-is-no-customer-support.gsm
     
  8. mikeborschow

    Joined:
    Jun 9, 2010
    Messages:
    2
    Likes Received:
    0
    This worked for me

     
  9. emash

    Joined:
    Jul 12, 2010
    Messages:
    8
    Likes Received:
    0
    Hi, all

    I to am having this problem and have tried all the above suggestions with no luck.

    I modded the asterisk.config to remove space
    changed owner
    changed premissions

    still get error
    Failed to create /var/lib/asterisk /sounds/custom

    running E2 RC3

    Thanks
     
  10. eiger3970

    Joined:
    Apr 29, 2009
    Messages:
    112
    Likes Received:
    0
    I find this amazing that a simple 'saving recording' cannot be fixed? Thanks for the chown suggestion, but the same errors occur. How can this not work as it's one of the later versions of Elastix?
     
  11. eiger3970

    Joined:
    Apr 29, 2009
    Messages:
    112
    Likes Received:
    0

Share This Page