Upgrading

Discussion in 'General' started by Dorella, Jul 23, 2007.

  1. Dorella

    Joined:
    Jul 23, 2007
    Messages:
    4
    Likes Received:
    0
    Hi,

    I've got some boring issues due to Asterisk and FreePBX bugs. I wanna upgrade since some of the issues are solved with new versions, but this is what happens when I try to do so using yum:

    [root@asterisk ~]# yum update
    Loading "installonlyn" plugin
    Setting up Update Process
    Setting up repositories
    Reading repository metadata in from local files
    Excluding Packages from CentOS-5 - Extras
    Finished
    Excluding Packages from CentOS-5 - Updates
    Finished
    Excluding Packages from CentOS-5 - Base
    Finished
    Excluding Packages from CentOS-5 - Addons
    Finished
    Excluding Packages from Elastix RPM Repository for CentOS
    Finished
    Resolving Dependencies
    --> Populating transaction set with selected packages. Please wait.
    ---> Downloading header for tzdata to pack into transaction set.
    tzdata-2007f-1.el5.noarch 100% |=========================| 182 kB 00:00
    ---> Package tzdata.noarch 0:2007f-1.el5 set to be updated
    ---> Package asterisk-sounds-fr.i386 1:1.4.8-2 set to be updated
    ---> Package asterisk.i386 1:1.4.8-2 set to be updated
    ---> Package asterisk-sounds-es.i386 1:1.4.8-2 set to be updated
    ---> Package freePBX.noarch 0:2.2.3-10 set to be updated
    --> Running transaction check
    --> Processing Dependency: elastix >= 0.8-5 for package: freePBX
    --> Finished Dependency Resolution
    Error: Missing Dependency: elastix >= 0.8-5 is needed by package freePBX


    Would you please tell me what to do or if I just need to wait? If wait is the answer, any idea on how long?



    Regards,
    Dario
     
  2. cowboy47

    Joined:
    Jun 14, 2007
    Messages:
    276
    Likes Received:
    0
    I have more of less the same question. 0.8.5-alpha is out but only in ISO, is there an upgrade?

    C
     
  3. Dorella

    Joined:
    Jul 23, 2007
    Messages:
    4
    Likes Received:
    0
    So, will there be any upgrade procedure available once 8.5 is out?
     
  4. cowboy47

    Joined:
    Jun 14, 2007
    Messages:
    276
    Likes Received:
    0
    You can manually do a yum install of each package that is pending, except for the 0.8.5 stuff and I am not sure on the freepbx.

    My biggest reservation on the 0.8.5 version is that freepbx 2.2.3 is embedded into the interface, consequently I do not know what the possibilities are of upgrading that to freepbx 2.3.0 which is in the second beta now. I like the beta interface of freepbx and it offers some really cool options.
     
  5. Dorella

    Joined:
    Jul 23, 2007
    Messages:
    4
    Likes Received:
    0
    Thanks for your comments.

    I don't feel safe, since this elastix box makes my company running, forcing packages installation, possibily overriding dependencies.

    I found workarounds for the most annoying bugs thus we're not in a hurry for upgrading. I'll quietly wait for 8.5 to come out, hope it'll include a smooth upgrading path from previous version.


    Thanks,
    Dario
     
  6. vaporjet

    Joined:
    Aug 7, 2007
    Messages:
    8
    Likes Received:
    0
    I have FreePBX2.3.0 beta installed on my elastix 0.8.4 server<br><br>Post edited by: vaporjet, at: 2007/08/08 08:28
     
  7. cowboy47

    Joined:
    Jun 14, 2007
    Messages:
    276
    Likes Received:
    0
    I did too. However, in 0.8.5 alpha, the freepbx is embedded, so I am not sure how you can upgrade or install 2.3
     
  8. cowboy47

    Joined:
    Jun 14, 2007
    Messages:
    276
    Likes Received:
    0
    I did too. However, in 0.8.5 alpha, the freepbx is embedded, so I am not sure how you can upgrade or install 2.3
     
  9. keith_sudbury

    Joined:
    Jul 12, 2007
    Messages:
    5
    Likes Received:
    0
    What do you mean its embedded do you have a screen shot?
     
  10. vaporjet

    Joined:
    Aug 7, 2007
    Messages:
    8
    Likes Received:
    0
    Is this screenshot of 0.8.5 alpha?

    [​IMG]
     
  11. cowboy47

    Joined:
    Jun 14, 2007
    Messages:
    276
    Likes Received:
    0
    Well, if you read the docs, they are embedding the freepbx directly into the Elastix web interface, consequently, with 0.8.4 when you go to PBX admin, it calls freepbx into a frame. If it is embedded, it is my understanding that anything different or new in freepbx may not appear. In the 0.8.5alpha, as an example, the tools section of freepbx was omited so you cannot get to module admin through the interface, until it is fixed.

    C
     
  12. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    Try with
    yum update --exclude=freePBX
     

Share This Page