upgrading openfire to the latest with elastix

areid

Joined
Apr 11, 2008
Messages
117
Likes
0
Points
0
#1
I've upgrade elastix to 1.1-8 and noticed openfire is still 3.5.1. The latest for openfire is 3.6.0. How can I upgrade openfire to the latest without breaking anything?
 

cmrahman

Joined
Jul 21, 2008
Messages
47
Likes
0
Points
0
#2
You can download the rpm and upgrade to the latest version of openfire. But in return you lose the elastix tabs. Anybody know how to put the tabs back after the upgrade? Thanks a bunch.

CM ;)
 

danardf

Joined
Dec 3, 2007
Messages
8,069
Likes
10
Points
88
#3
It's funny.. :blink:

The new release Elastix don't have the new version's OpenFire!

Don't work on 1.2.1 and 1.3.... (with update , yes).

Why not include the last version openfire, yet you know that openfire 3.5.1 don't works? :silly:
 

areid

Joined
Apr 11, 2008
Messages
117
Likes
0
Points
0
#4
When will elastix have the latest openfire? I would like to upgrade without breaking elastix GUI.
 

Bryant

Joined
Oct 22, 2008
Messages
9
Likes
0
Points
0
#5
^ ditto
 

garcia.ronald.d

Joined
Sep 24, 2008
Messages
134
Likes
0
Points
0
#6
I installed the plugin Asterisk IM, but I dont know how to put to work, anybody can help me?

Also installed sip phone plugin (sip.jar) but doesnt appear in the web interface, that meant that was not compatible with the version of OenFire?

Thanks a lot
 

Kalama Sutra

Joined
Apr 15, 2009
Messages
95
Likes
0
Points
0
#7
:blush:

I'm going to add my "Vote" to this issue of upgrading "OpenFire" and the lose of the tab ....

¿ Question to the Elastix programing staff is this; where do I find the controlling ini or cnf file that sets the tabbing response within the Elastix interface ?

I'm not real comfortable in pure *nix command line usage; but, working with a Mac and using Cyberduck & its integration with TextWrangler, I'm able to get to those particular files and do secure adjustments.

Thanks in advance for your reply.
 

shezzski

Joined
Jun 17, 2008
Messages
4
Likes
0
Points
0
#8
Seriously I have just upgraded to ver 1.6 after some time away from the Elastix community and I am in awe that Openfire is stuck on ver 3.5.1 :S
 

shezzski

Joined
Jun 17, 2008
Messages
4
Likes
0
Points
0
#9
Elastix 2.0 still has Openfire 3.5.1!!!!! :angry:
 

williamfay

Joined
Sep 12, 2010
Messages
13
Likes
0
Points
0
#10
You can upgrade the Openfire server on Elastix. I'm on Elastix 2.0 running Openfire 3.6.4 It will break the ability to use it from the tab inside Elastix's Control Panel. You'll have to go straight to Openfires url http://yourserversname:9090/ But it works great!!!
 

epritchett

Joined
Aug 13, 2010
Messages
3
Likes
0
Points
0
#11
williamfay said:
You can upgrade the Openfire server on Elastix. I'm on Elastix 2.0 running Openfire 3.6.4 It will break the ability to use it from the tab inside Elastix's Control Panel. You'll have to go straight to Openfires url http://yourserversname:9090/ But it works great!!!
When you say break do you mean the IM tab is gone completely or it just doesn't link correctly. If it doesn't link correctly is this something we could manually change somewhere to point to the http://yourserversname:9090 address?
 

williamfay

Joined
Sep 12, 2010
Messages
13
Likes
0
Points
0
#12
No the tab is still there and it points to the right address. From what I can tell the openfire people have made their code so it breaks out of frames. If your familiar with html at all you know that it's possible to make your page break out of a frame and take up the whole window so people can't embed your site on theirs. I'm thinking that's what is happening. I haven't looked at the code to see cause it's not really a big deal to add the openfire admin page to my browsers bookmarks.
 

shezzski

Joined
Jun 17, 2008
Messages
4
Likes
0
Points
0
#13
Its not really a big deal, but it would be great to have everything appear integrated rather than just an add-on. This is why Elastix is doing so well, most things look good and the GUI is simple and nice...... Just my thoughts
 

williamfay

Joined
Sep 12, 2010
Messages
13
Likes
0
Points
0
#14
I'm working on locating the code that is forcing Openfire to break out of the frame. Once I figure it out I'll post a fix here.
 

williamfay

Joined
Sep 12, 2010
Messages
13
Likes
0
Points
0

svoi

Joined
Oct 21, 2010
Messages
1
Likes
0
Points
0
#16
?????? ??? ??? ????????, ?? ???? ?? ???? ?????????? - ????? ??????????? ???????? ?????? java.lang.NoSuchMethodError: org.jivesoftware.util.StringUtils.removeXSSCharacters(Ljava/lang/String;)Ljava/lang/String; ? ?.?. ??? ???? ???????? ??????? ??????????? ????? jre/bin ?? openfire 3.5.1 ?????????? ? elastix. ?? ?????? ????? ??????? ???????????? ?????????? ???????.
???? ??? ?? ????? ????? ?????? ? ???? ???????? - ? ????????????? ??????????? ? ????? ???????? ??????? ???????. :woohoo:
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,915
Messages
130,920
Members
17,591
Latest member
dalibor66
Top