upgrade from 1.1-8 to 1.2

Discussion in 'General' started by thephantom, Sep 6, 2008.

  1. thephantom

    Joined:
    Aug 2, 2008
    Messages:
    7
    Likes Received:
    0
    ok thats nice, yust installed the elastix system for the 10th time,, now on hyper-v in an windows 2008 server (works good for now :)) but now there is an new version ..... is there an way to simpel upgrade the system without problems?? i don't want to install everithing again......

    thnx :)
     
  2. lek

    lek Guest

    This Tuesday we'll update the yum repository.
     
  3. kawa636r

    Joined:
    Oct 25, 2007
    Messages:
    36
    Likes Received:
    0
    From tuesday do :


    yum -y update


    And everything will be updated :-D
     
  4. kawa636r

    Joined:
    Oct 25, 2007
    Messages:
    36
    Likes Received:
    0
    And call center module will work again! :-D
     
  5. Lou1z

    Joined:
    Aug 20, 2008
    Messages:
    57
    Likes Received:
    0
    lol.....
    i haven't done a yum upgrade since i initially installed elastix 1.1. i've done numerous upgrades of freepbx up to 2.5rc3.
    i'd advise people to wait until the repos's are updated as when i did mine, i was surprised to see freepbx 2.4 going in.
    naturally, this broke freepbx and it took numerous fixes to get it back to where it was. but hey ho, waiting to next tuesday lol!
     
  6. wiseoldowl

    Joined:
    Aug 19, 2008
    Messages:
    251
    Likes Received:
    0
    Hmmm, it's Wednesday and I did a yum -y update and while it appeared to update a whole bunch of CentOS stuff, it didn't appear to update Elastix. Did you mean yesterday, or six days from now (or did things just get delayed a bit)? Or am I not doing something correctly?
     
  7. DaveD

    Joined:
    Nov 12, 2007
    Messages:
    597
    Likes Received:
    0
    Sometimes it can get delayed but it will come
    To check what updates are available, at the console type yum check-update
    It will show you what is there to update
     
  8. rafael

    Joined:
    May 14, 2007
    Messages:
    1,454
    Likes Received:
    1
    The repo is not up yet, hopefully it would be up on the next hours. Please be tune to this thread and I would report when the repos are ready.

    Regards,

    Rafael
     
  9. wiseoldowl

    Joined:
    Aug 19, 2008
    Messages:
    251
    Likes Received:
    0
    The problem with yum check-update is that it comes back with this:

    Code:
    http://repo.elastix.org/centos/5/updates/RPMS/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
    Trying other mirror.
    Error: Cannot retrieve repository metadata (repomd.xml) for repository: elastix. Please verify its path and try again
    It finds all the other repositories (for CentOS, etc.) okay, just doesn't find the Elastix one. What am I doing wrong?
     
  10. DaveD

    Joined:
    Nov 12, 2007
    Messages:
    597
    Likes Received:
    0
    Not doing anything wrong I am having the same issue at the moment, not seeing path
     
  11. rafael

    Joined:
    May 14, 2007
    Messages:
    1,454
    Likes Received:
    1
    The repos are up now, you can update.

    Regards,

    Rafael
     
  12. mattrh

    Joined:
    Jul 15, 2008
    Messages:
    175
    Likes Received:
    0
    when i run yum update i get this error Error: Missing Dependency: zaptel = 1.4.10.1-2 is needed by package wanpipe-modules-2.6.18-53.1.19.el5

    any help?
     
  13. Lou1z

    Joined:
    Aug 20, 2008
    Messages:
    57
    Likes Received:
    0
    our's went in no problem and i have to say i'm impressed. elastix goes from strength to strength with each release. much appreciated.
     
  14. wiseoldowl

    Joined:
    Aug 19, 2008
    Messages:
    251
    Likes Received:
    0
    The upgrade went in fine, the only issue I've noticed is that Openfire is acting up again. I don't remember now where I changed the memory settings and wonder if that might have got overwritten. I sure wish the Openfire people would fix their damn memory leak, otherwise all is working great!
     
  15. mihpel

    Joined:
    May 8, 2007
    Messages:
    87
    Likes Received:
    0
    You have installed the beta 3.3.10 wanpipe rpm drivers manually. You need to get them of the system before updating but you will have to set them up from source once you have updated to 1.2 due to zaptel beeing updated to 1.4.11-5.

    A quick description on how you setup can from source can be found here.

    ps: Dev's please note that 1.2 release is currying the same symlink bug from previous release (both fresh and updated)
     
  16. jandir

    Joined:
    Aug 24, 2008
    Messages:
    65
    Likes Received:
    0
    Do we need to upgrade Free PBX or does the yum update handle that too?

    If yes, how?

    Sorry, noob here.

    Thanks
     
  17. mattrh

    Joined:
    Jul 15, 2008
    Messages:
    175
    Likes Received:
    0
    thank you, i will try it out.
     
  18. mattrh

    Joined:
    Jul 15, 2008
    Messages:
    175
    Likes Received:
    0
    what i have been doing is run yum update and grabing the latest files then going to the "/admin" strait to freePBX and doing module updates direct. let me know if that helps you.
     

Share This Page