upgrade 1.3 to 1.5 IVR gives database error

Discussion in 'General' started by cmrahman, Aug 31, 2009.

  1. cmrahman

    Joined:
    Jul 21, 2008
    Messages:
    47
    Likes Received:
    0
    After upgrading from 1.3 to 1.5, when ever I tried to add IVR,

    I get this error, any idea about this?

    FATAL ERROR
    INSERT INTO ivr (displayname, enable_directory, enable_directdial, timeout, alt_timeout, alt_invalid, `loops`, `retvm`) values('Unnamed', 'CHECKED', 'CHECKED', 10, '', '', 2, '') [nativecode=1054 ** Unknown column 'retvm' in 'field list']SQL -
    INSERT INTO ivr (displayname, enable_directory, enable_directdial, timeout, alt_timeout, alt_invalid, `loops`, `retvm`) values('Unnamed', 'CHECKED', 'CHECKED', 10, '', '', 2, ''):blink:
     
  2. rafael

    Joined:
    May 14, 2007
    Messages:
    1,454
    Likes Received:
    1
    Please create a bug in http://bugs.elastix.org so developers can give you a hint on this and we can fix this issue.

    Does non embebed freepbx work?

    regards,

    Rafael
     
  3. PHBarry

    Joined:
    Apr 21, 2009
    Messages:
    57
    Likes Received:
    0
    I am having the same issue but I am using 1.5.2-2.3 did you ever find a fix to this?
     
  4. cmrahman

    Joined:
    Jul 21, 2008
    Messages:
    47
    Likes Received:
    0
    Yes, I just droped the IVR table and recreated with the new table. that fixed it.

    Thanks :laugh:
     
  5. PHBarry

    Joined:
    Apr 21, 2009
    Messages:
    57
    Likes Received:
    0
    You just added a new table with same name after you deleted it?
     
  6. PHBarry

    Joined:
    Apr 21, 2009
    Messages:
    57
    Likes Received:
    0
    Thank you!

    I fixed it thanks to YOU!

    I moved the two ivr tables to a different name. Then went to a fresh install of elastix and exported the same two tables. Next I imported them into the server with a problem and bam no more errors...
     

Share This Page