Update Freepbx 2.4.1 to 2.5?

Discussion in 'General' started by danardf, Aug 14, 2008.

  1. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Hi.

    The new freepbx version is up.

    I want to try to making a update Freepbx 2.4.1 t 2.5.

    It's possible?
    What's the risk?
     
  2. samix4u

    Joined:
    Mar 31, 2008
    Messages:
    20
    Likes Received:
    0
    not compatible with elastrix GUI. now have to format and install.
     
  3. DaveD

    Joined:
    Nov 12, 2007
    Messages:
    597
    Likes Received:
    0
    I have just upgraded the freepbx to 2.5 and so far have not come across any errors
    The update took around 5 mins, had to do it in 3 passes
    1.goto your unembedded freepbx and open
    2.select admin modules and check modules on line
    3.you will see freepbx 2.5 upgade tool, select it then submit
    4.when it has done check module updates on line and do core freepbx only and click red bar when done
    5. now go back into modules online and select all you wish to update ( you might need to do this several times )
    6.DO NOT CLICK RED BAR go back in again and make sure all modules are updated,if they are then click red bar
    7.Done enjoy
     
  4. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    ok thanks :)
     
  5. cmrahman

    Joined:
    Jul 21, 2008
    Messages:
    47
    Likes Received:
    0
    I tested this. It doesn't work with elastix. The database changed. Now the extention is messed up. Anybody had any luck? What ever it is, it is not ready for production as it seems. Only way you can get it working is if you use freepbx admin tool.

    Thanks
     
  6. Newcopia

    Joined:
    Apr 3, 2008
    Messages:
    14
    Likes Received:
    0
    I am trying to upgrade from 2.3. to 3.4 or higher and i get this message
    error copying framework files:
    'cp -rf' from src: '/var/www/html/admin/modules/framework/htdocs/*' to dst: '/var/www/html'...details follow
    cp: cannot create directory `/var/www/html/_asterisk': Permission denied
    cp: cannot create directory `/var/www/html/recordings': Permission denied

    Am I doing something wrong?
     
  7. lek

    lek Guest

    We'll release fpbx 2.5 in Elastix 1.3.

    Has anyone else made a successful update?
     
  8. chocho

    Joined:
    Nov 7, 2007
    Messages:
    74
    Likes Received:
    0
    I update to freePBX 2.5 normally. The freePBX in itself working fine.
    But in embeded freePBX on extension options all fields are empty.
     
  9. Guiloui0875

    Joined:
    Sep 8, 2008
    Messages:
    2
    Likes Received:
    0
    Same issue here, every thing works fine but the extensions on elastix; they are blanked out. also the FPO Legends got messed up. I was able to fix the FPO issue by editing the op_buttons.cfg and commenting/ the legend setting.

    Any idea on how to fix the Extensions on elastix? Any one? I'm forced to use the Freepbx until I find a fix to this issue :(
     
  10. dalybrian

    Joined:
    Dec 20, 2007
    Messages:
    9
    Likes Received:
    0
    Any update on this as yet?
     
  11. luetzz

    Joined:
    Mar 1, 2008
    Messages:
    21
    Likes Received:
    0
    Well, after being using Elastix in a production machine for 2 months now, I made the great mistake: upgraded FreePBX from 2.4 to 2.5, and as duscussed in this post some things messed up.
    Maily the extensions being emptied in Elastix.
    FreePBX goes nice.

    Recently I´ve upgraded to Elastix 1.3-2 end all FreePBX 2.4 modules. After that I made the big error, upgrading FreePBX before reading the posts.

    Is there any Elastix update to address this issue?

    Help, Rafael, Cleve, anyone ....
     
  12. Phoneeman

    Joined:
    Oct 22, 2008
    Messages:
    9
    Likes Received:
    0
    I am doing a fresh install of Elastix v1.3. I noticed it installs FreePBX 2.4. Is there going to be a release in the near future that will include FreePBX v2.5? Would it be worth waiting for? I am running FreePBX v2.4 already however from what I've seen the Elastix product looks very interesting. I just don't want to install 2.4 if 2.5 is right around the corner.

    Thank You

    Phoneeman
     
  13. dalybrian

    Joined:
    Dec 20, 2007
    Messages:
    9
    Likes Received:
    0
    Still no update on this issue. I really didn't want to re-install Elastix :-(
     
  14. Chilling_Silence

    Joined:
    Sep 23, 2008
    Messages:
    488
    Likes Received:
    0
  15. saleh

    Joined:
    Apr 18, 2007
    Messages:
    249
    Likes Received:
    0
  16. VoIPDoug

    Joined:
    Mar 1, 2009
    Messages:
    28
    Likes Received:
    0
    I'm affraid it's also affecting Device registrations adversely too. I too installed the 2.5 UG using unembedded FPBX admin and now My aastra phones or any for that matter do not stay registered for more than 2.5 min. Not so nice for inbound calls.

    And it is true, even though I've installed the extensions on the 2.5 ver, the embedded FPBX gui shows no configured Extensions.

    Very Strange.
     

Share This Page