Unable to delete Music On Hold

Discussion in 'General' started by hightekhosting, Oct 19, 2008.

  1. hightekhosting

    Joined:
    Oct 19, 2008
    Messages:
    22
    Likes Received:
    0
    Hi all,

    We added a couple of MP3's to our MOH configuration, however they seem to have issues and we wish to remove them.

    When we select on the file/song to be removed, an error similar to the one below appears and the file does not delete:

    Error Deleting orig_Cat!

    or Error Deleting orig_Basshunter!

    Cat and basshunter being the file titles.

    Could anyone explain why this is occurring and how we can remove these manually?

    Regards,

    Dale Evans
    Manager
     
  2. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    what version of elastix you are using+
     
  3. hightekhosting

    Joined:
    Oct 19, 2008
    Messages:
    22
    Likes Received:
    0
    Elastix 1.3-2 however FreePBX is fully updated with all modules up to date.

    Everything is working, and we're probably silly for upgrading all FreePBX modules, but if this issue could be resolved one way or another, it would be great.

    Regards,

    Dale
     
  4. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    you may delete your mp3s from:
    /var/lib/asterisk/mohmp3/your_category
     
  5. vtofa

    Joined:
    Oct 21, 2008
    Messages:
    67
    Likes Received:
    0
    I'm having a similar problem. I have deleted all of the default MOH files using FreePBX web interface, and also deleted any remaining files from /var/lib/asterisk/mohmp3 and from /var/lib/asterisk/moh, but the default on-hold music still plays. I restarted asterisk and that didn't make it stop. What else could I do? Thanks!
     
  6. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    mmm... ok, If you have already deleted the files, then go into any part of the web interface and click a submit button, then click on the red "Apply change bar" that appears on the top of the page, and check it if still plays the default audio files.

    If that doesn´t work, you may do the following:
    1. go to /etc/asterisk/sip_general_custom.conf and put the following parameter:
    mohsuggest=none
    2. go to /etc/asterisk/iax_general_custom.conf and put the following parameter:
    mohsuggest=none
    3. on the shell type the following command:
    asterisk -rx "reload"

    By the way, why are you using unembedded freepbx interface? Have you updated freepbx and now you don´t have info under the elastix interface?
     

Share This Page