Un concejo para conectarse remotamente

Discussion in 'Elastix 2.x' started by PecoChecho, Jul 3, 2008.

  1. PecoChecho

    Joined:
    Dec 14, 2007
    Messages:
    10
    Likes Received:
    0
    Hola espero esto te ayude, a mi si me dio resultado.
    Primero que nada tienes que tener un ip externa estatica, o saber que ip en internet tiene tu servidor Elastix en el momento que quieres conectarte a el. Aclaro ip externa es la que te da tu proveedor de internet.

    Ademas en sip.conf tener algo parecido a esto:

    [general]
    bindport=5060 ; Purto UDP para bind ( puerto UDP que escuchara tu Elastix)
    bindaddr=0.0.0.0 ; Direccion IP que escuchara (0.0.0.0 o asi para escuchar todas)
    disallow=all
    allow=ulaw
    allow=alaw
    allow=gsm
    allow=ilbc
    allow=g723
    allow=g729
    externip = home.mydomain.com ;ees tu dominio o tu ip externa
    localnet = 192.168.1.0 ;la ip de red local
    nat=yes
    -----------------------------------------------------

    Y otra cosa muy importante, es que si tienes router, donde esta el Elastix, es que abras los puertos. Aca te muestro un ejemplo del los que usa Asterisk o Elastix

    -----------------------------------------------------
    Name Port Type

    SIP 5060 UDP / TCP

    IAX2 4569 UDP

    IAX 5036 UDP

    WEB 80 TCP

    MGCP 5036 UDP

    RTP 10000
     
  2. pcastanedardz

    Joined:
    Aug 13, 2008
    Messages:
    29
    Likes Received:
    0
    Hola a todos, necesito de su ayuda, e estado viendo este asunto pero no puedo hacer que al contestar una llamada en el softphone uso el X-lite pueda escuchar nada, si marca pero a la hora de contestar la llamada no escucho el sip.conf lo tengo de la siguiente manera
    ; do not edit this file, this is an auto-generated file by freepbx
    ; all modifications must be done from the web gui

    [general]
    language=es
    videosupport = yes

    bindport=5060
    bindaddr=0.0.0.0

    disallow=all
    allow=ulaw
    allow=gsm
    allow=g729
    allow=h261
    allow=h264
    allow=h263
    allow=h263p

    allow=alaw
    allow=ilbc
    allow=g723
    allow=g729
    externip = bcm.dyndns.org ;ees tu dominio o tu ip externa
    localnet = 192.168.200.0 ;la ip de red local
    nat=yes


    ;
    ; enable and force the sip jitterbuffer. If these settings are desired
    ; they should be set in the sip_general_custom.conf file as this file
    ; will get overwritten during reloads and upgrades.
    ;
    ; jbenable=yes
    ; jbforce=yes

    ; These will all be included in the [general] context
    ;
    #include sip_general_additional.conf
    #include sip_general_custom.conf
    #include sip_nat.conf
    #include sip_registrations_custom.conf
    #include sip_registrations.conf

    ; These should all be expected to come after the [general] context
    ;
    #include sip_custom.conf
    #include sip_additional.conf
    #include sip_custom_post.conf


    maxcallbitrate=384

    espero me puedan ayudar, de antemano mil gracias.
     
  3. pcastanedardz

    Joined:
    Aug 13, 2008
    Messages:
    29
    Likes Received:
    0
    Asunto resuelto, les comento que instale la versión 1.1.8, antes tenía la 1.1.7 actualice todos y agregue las líneas que PecoChecho indico y asunto arreglado.
     
  4. pcastanedardz

    Joined:
    Aug 13, 2008
    Messages:
    29
    Likes Received:
    0
    Buenas tardes a todos, de nuevo con este rema , instale la versión 1.2-4 y no funcionaron mis enlaces remotos, lo extraño de esto es que en la versión más abajo que tenia instalada si funciona, alguno de ustedes ya probo esto en la versión 1.2 o en la 1.3??, de antemano les agradezco sus comentarios.
     

Share This Page