the number you have dialed is not in service ...

Joined
Nov 8, 2007
Messages
106
Points
0
Hello all !

I upgraded to Elastix 0.9.0 and had to redo my config (forgot to backup). I created a trunc, an extension and an inbound route. Now when I call non the trunk's number I get a female voice saying :

the number you have dialed is not in service please check the number and try again later

I can see on the control panel that the call is coming in, but it's not attributed to the extension (my inbound route is "any DID / any CID".

Thanks a lot for any kind support!

Regards,
Fabianus
 
Joined
Nov 16, 2007
Messages
42
Points
0
Re:the number you have dialed is not in service ..

SIP Trunk? Make your sip.conf context = from-trunk (not from external)
 
Joined
Nov 16, 2007
Messages
42
Points
0
Re:the number you have dialed is not in service ..

Fabianus said:
Yes it's a sip-trunk and thanks a lot for your advice, this solved my problem !

Now I have anotherone :)
I have the same problem for outgoing calls - the configuration of the outbound route worked fine before the upgrade, now it doesn't. Do you have any idea where this could come from?

Thanks a lot for any further advice!

Regards,
Fabianus


Delete what you've got and start over. There are a few places you need to keep in mind especially if you're SIP trunking like myself.

- Add SIP Trunk under "trunks"
- Leave everything defaulted
- Enter your ITSP settings mine are under "Peer Details" as such:

host=ip-or-dns-name-here.com
type=peer


You might need to add auth or proxy if your ITSP requires it. I don't need it.

- Submit/Save
- Create Outbound route
- Leave at defaults and decide how you want extensions to dial out, use the dialplan wizard.
- Use the SIP trunk you've just built for "Trunk Sequence"
- Save/Submit


That works for me but like I said you might need to add additional settings for the trunk itself which is totally ITSP dependent. It's a good idea you backup these files or take note once you've got it working the way you intended it to.
 
Joined
Nov 8, 2007
Messages
106
Points
0
Re:the number you have dialed is not in service ..

"decide how you want extensions to dial out"

Silly me, I forgot the "." after the "0" in the Dial patterns (thus "0.") ...

Thanks a lot for your concern about my difficulty Eham !


Best regards,
Fabianus
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,987
Messages
131,100
Members
17,716
Latest member
Orbit114
Top