tdm410p incomming calls problems

Discussion in 'General' started by maxmv, Feb 17, 2010.

  1. maxmv

    Joined:
    Feb 15, 2010
    Messages:
    2
    Likes Received:
    0
    hi all first
    sorry my inglish is not my native lenguage

    ok firt
    GenuineIntel Intel(R) Pentium(R) 4 CPU 3.00GHz
    1 gig of ram
    i install Elastix 1.6-12
    whit a tdm410 whit 2 fx and 2 fxo
    i chek whit comands and is well install the drivers
    i use linksys spa921
    i am new to asterisk and elastix

    any extencion i dial is ok they work
    i make extencion calls whit no problems
    from the analog extencion to my linksys whit no problem

    ok this is my story of the problems
    1. i config for incoming calls rute and all group call and direct extencion and i get the same msg
    "the number you just dial is out of service" i get respond from the server i know :p my phone company is in spanish :p
    i get respond when i dial the number from outside
    i have the ptsn lines in chanel 1 and 2

    3 and 4 is analog extencions

    i make calls y pres 99XXXXXXXX for line 1 is ok i make calls 89XXXXXXXX line 2 ok make calls no problems

    and when i make a call to any of my 2 channels to test the server i get "the numer you just dial is out of server"

    i read elastix_without_tears pdf

    i make the step bye step and get the same MSG from the server
    i live in mexico sow if i dial a wrong numer i get a spanish lady
    sow i know is the server is in inglish :p

    i hope you can helpme is a little proyect i am doing for my dad office 4 extenccions
    and i whant to learn more

    tnx from advance


    live log

    -- Starting simple switch on 'DAHDI/1-1'
    -- Executing [s@from-pstn:1] NoOp("DAHDI/1-1", "No DID or CID Match") in new stack
    -- Executing [s@from-pstn:2] Answer("DAHDI/1-1", "") in new stack
    -- Executing [s@from-pstn:3] Wait("DAHDI/1-1", "2") in new stack
    -- Executing [s@from-pstn:4] Playback("DAHDI/1-1", "ss-noservice") in new stack
    -- <DAHDI/1-1> Playing 'ss-noservice' (language 'en')
    -- Executing [s@from-pstn:5] SayAlpha("DAHDI/1-1", "") in new stack
    -- Executing [s@from-pstn:6] Hangup("DAHDI/1-1", "") in new stack
    == Spawn extension (from-pstn, s, 6) exited non-zero on 'DAHDI/1-1'
    -- Executing [h@from-pstn:1] Hangup("DAHDI/1-1", "") in new stack
    == Spawn extension (from-pstn, h, 1) exited non-zero on 'DAHDI/1-1'
     
  2. ashir24

    Joined:
    Sep 1, 2009
    Messages:
    75
    Likes Received:
    0
    it seems you have given DID in your incoming route.
    first, try by removing the DID from your incoming route.
    The message "service not available" says normally if DID does not match or BLACKLISTED. in your case it looks the DID.
    if that works and you want to use the DID then go to freePBX and add "zap channel DID".
    and then go to /etc/asterisk and edit chan_dahdi.conf, replace context=from-pstn to context=from-zaptel.
    then edit dahdi-channels.conf replace same for your FXO channels.
    after that stop dahdi and restart asterisk service. and then start dahdi service.

    this should solve your problem.
     

Share This Page