TDM410 FXO always "in use" help! wctdm24xxp+ card

Discussion in 'Gateways' started by windswept321, Dec 13, 2009.

  1. windswept321

    Joined:
    Dec 13, 2009
    Messages:
    2
    Likes Received:
    0
    I have a TDM410 card, showing up as wctdm24xxp+ with a single FXO fitted which always shows as "in use" in the hardware detection screen and won't dial out.
    I also have another of these cards with a different fxo which does the same.
    The card has been setup in elastix and the various configuration files as per "elastix without tears" but with UK settings.


    My problem seems to be the same as, or similar to http://www.elastix.org/component/option ... ,en/#38246
    The card is the same too.

    I notice that running dahdi_cfg -vv comes up with "FXS Kewlstart" not sure if this should be FXO.



    dahdi_cfg


    DAHDI Tools Version - 2.2.0

    DAHDI Version: 2.2.0.2
    Echo Canceller(s): OSLEC
    Configuration
    ======================


    Channel map:

    Channel 01: FXS Kewlstart (Default) (Echo Canceler: oslec) (Slaves: 01)

    1 channels to configure.

    Setting echocan for channel 1 to oslec



    dahdi_scan

    [1]
    active=yes
    alarms=OK This is with the cable unplugged, believe it should say RED
    description=Wildcard TDM410P Board 1
    name=WCTDM/0
    manufacturer=Digium
    devicetype=Wildcard TDM410P
    location=PCI Bus 00 Slot 21
    basechan=1
    totchans=4
    irq=10
    type=analog
    port=1,FXO
    port=2,none
    port=3,none
    port=4,none



    /etc/dahdi/system.conf

    # Autogenerated by /usr/sbin/dahdi_genconf on Sun Dec 13 15:44:01 2009
    # If you edit this file and execute /usr/sbin/dahdi_genconf again,
    # your manual changes will be LOST.
    # Dahdi Configuration File
    #
    # This file is parsed by the Dahdi Configurator, dahdi_cfg
    #
    # Span 1: WCTDM/0 "Wildcard TDM410P Board 1" (MASTER)
    fxsks=1
    echocanceller=oslec,1
    # channel 2, WCTDM/0/1, no module.
    # channel 3, WCTDM/0/2, no module.
    # channel 4, WCTDM/0/3, no module.

    # Global data

    loadzone = uk
    defaultzone = uk
     
  2. windswept321

    Joined:
    Dec 13, 2009
    Messages:
    2
    Likes Received:
    0
    Problem solved, caused by a faulty phone cable.
     

Share This Page