TC400b

Discussion in 'Elastix 2.x' started by security, Dec 30, 2007.

  1. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    Hola, he instalado la tarjeta TC400B, para codec, pero asterisk no la reconoce, y estoy probando con la ultima version, la 0.92.

    Esto es lo que me muestra con el comando lspci, lo que indica que la esta recociendo.

    01:02.0 Ethernet controller: Digium, Inc. Wildcard TC400P transcoder base card (rev 11)

    Y con el comando dmesg, me dice esto.

    TC400B: firmware zaptel-fw-tc400m.bin not available from userspace
    wctc4xxp: probe of 0000:01:02.0 failed with error -1

    Por lo que entiendo que hay que actulizar el zaptel-fw-tc400m.bin.:( :( :( :(

    Alguien la tiene funcionando:unsure: :unsure: :unsure:
     
  2. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    Con la version Zaptel 1.4.8, me reconoece la tarjeta de codec sin problemas, creo que deberia arreglar el paquete zaptel, para que se actulice y corrija el problema de la tarjeta de codec:whistle: :whistle: :whistle:
     
  3. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    Bueno, he vuelto ha realizar prueba con la tajeta de codec, y realmenete me funciona, pero ademas con la nueva actulizacion, ya me aparecen 120 licencias (antes tenia 92), asi que porfa actulixemos el paquete zapatel.
    B) B) B) B)
     
  4. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    Bueno haciendo pruebas con la version 1.0-rc de elastix, la tarjeta tc400 no me la levanta.

    Esto es lo que me aparece con el comando dmesg

    Zaptel Transcoder support loaded
    ACPI: PCI Interrupt 0000:01:02.0[A] -> GSI 17 (level, low) -> IRQ 209
    TC400M: firmware zaptel-fw-tc400m.bin not available from userspace
    wctc4xxp: probe of 0000:01:02.0 failed with error -5
    ACPI: PCI Interrupt 0000:00:1f.5 -> GSI 17 (level, low) -> IRQ 209
    PCI: Setting latency timer of device 0000:00:1f.5 to 64

    y esto es lo que se ve con el comando lspci

    01:02.0 Ethernet controller: Digium, Inc. Wildcard TC400P transcoder base card (rev 11)

    :blush: :blush: :blush: :blush:

    quien la tiene configurada
     
  5. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    He instalado la ultima version (1.0), imaginando que ya podia trabajar con mi tarjeta de codec, pero desafortunadamente no la puede leer, esto es lo que me aparece con el comando dmesg

    Found a Wildcard TDM: Wildcard TDM400P REV I (4 modules)
    Zaptel Transcoder support loaded
    ACPI: PCI Interrupt 0000:01:02.0[A] -> GSI 17 (level, low) -> IRQ 201
    TC400M: firmware zaptel-fw-tc400m.bin not available from userspace
    wctc4xxp: probe of 0000:01:02.0 failed with error -5
    ACPI: PCI Interrupt 0000:00:1f.5 -> GSI 17 (level, low) -> IRQ 201
    PCI: Setting latency timer of device 0000:00:1f.5 to 64

    y esto es lo que me da con el comando lspci

    Ethernet controller: Digium, Inc. Wildcard TC400P transcoder base card (rev 11)

    si miramos, tenemos los mismo que la version 1.0rc.

    que podemos hacer ante esto:blink: :S :sick: :( :unsure: :blush:
     
  6. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    :angry: :angry: :angry: :angry:
    Nada que me reconoce la tarjeta
     
  7. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    :dry: :dry: :dry: :dry: Bueno mirando de nuevo este tema, con la ultima version, 1.1, nada de nada, no reconoce la tarjeta!!!!, que podemos hacer:blush: :blush: :blush: :blush:
     
  8. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    :blush: :blush: :blush: Señores que nos pasa, seguimos con el mismo problema, acabo de revisar la ultima version, parchandola, y no me reconoce la tarjeta TC400B, pero si bajo la ultima version de zaptel, y lo compilo, si me funciona, como podemos arreglar ese problema, para que con los paquetes que ya estan trabaje sin problemas:blink: :blink: :blink: :blink:
     
  9. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    Bueno seguimos

    He probado con la version 1.3 de elastix y la tarjeta de codec tc400b, no la reconoce, pero si bajo el zaptel de los repositorios y ejecuto a mano la instalacion de zaptel, la reconoce de esta manera:

    Registered codec translator 'DTE Encoder' with 92 transcoders (srcs=0000000c, dsts=00000101)
    Registered codec translator 'DTE Decoder' with 92 transcoders (srcs=00000101, dsts=0000000c)
    Zaptel DTE (G.729a / G.723.1) Transcoder support LOADED (firm ver = 6.12)
    Found and successfully installed a Wildcard TC: Wildcard TC400P+TC400M

    pero cuando entro al cli

    voip*CLI> show translation
    Translation times between formats (in milliseconds) for one second of data
    Source Format (Rows) Destination Format (Columns)

    g723 gsm ulaw alaw g726aal2 adpcm slin lpc10 g729 speex ilbc g726 g722
    g723 - - - - - - - - - - - - -
    gsm - - 2 2 2 2 1 2 - 9 - 2 -
    ulaw - 2 - 1 2 2 1 2 - 9 - 2 -
    alaw - 2 1 - 2 2 1 2 - 9 - 2 -
    g726aal2 - 2 2 2 - 2 1 2 - 9 - 1 -
    adpcm - 2 2 2 2 - 1 2 - 9 - 2 -
    slin - 1 1 1 1 1 - 1 - 8 - 1 -
    lpc10 - 2 2 2 2 2 1 - - 9 - 2 -
    g729 - - - - - - - - - - - - -
    speex - 2 2 2 2 2 1 2 - - - 2 -
    ilbc - - - - - - - - - - - - -
    g726 - 2 2 2 1 2 1 2 - 9 - - -
    g722 - - - - - - - - - - - - -
    voip*CLI>

    no la reconoce :blush: :blush: :blush: :blush: :blush: :blush: :blush: alguna idea???
     
  10. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    bueno no me meustra los codec, pero si estan trabajando, cundo le digo a los telefonos que trabajen con el codec g729 solamente, si se conectan :p :p :p :p :p :p

    Solo que no me nuestra por consola cuantos codec tenemos:angry: :angry: :angry: :angry: :angry:
     
  11. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    como puedo actulizar el zaptel-fw-tc400m-MR6.12, sin volver a compilar el zaptel:eek:hmy: :eek:hmy: :eek:hmy: :eek:hmy: :eek:hmy: :eek:hmy: :eek:hmy:
     
  12. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    Tu perseverancia me ha gustado, si señor.
    Y la falta de ayuda por parte de la gente debe haberte descorazonado.
    Me temo que tendrás que recompilar...
     
  13. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    bueno y no hay manera que en la nueva version este de una vez listo eso, de manera que no rengamos que compilar de nuevo, aunque no es dificil, pero no tendria sentido, para eso debemos ir solucionando todos problemitas a medida que vamos madurando en esta distribucion, ya que si queremos seguir siendo los mejores y estar en punta, creo que debemos de tener en cuenta estos caso......creoooo......:unsure: :unsure: :unsure: :unsure: :unsure: :unsure: :unsure:
     
  14. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    bueno demen herramientas y soluciono esto para las nuevas versiones, donde consigo los codigos fuentes de las betas que tenemos???..... para mirar de que manera solucionamos este tema....cerremos casos que tengamos :blink: :blink: :blink: :blink: :blink: :blink:
     
  15. rgaibor

    Joined:
    Apr 24, 2008
    Messages:
    13
    Likes Received:
    0
    Mira que has trabajado largo en este tema, y no te cansaste de documentar tus logros para la comunidad. Muchas gracias por tu esfuerzo.

    Te recomiendo suscribirte a la lista de Beta-testers: http://lists.elastix.org/mailman/listinfo/beta-testers

    Anoche se subió iso del RC1 de Elastix 1.5 que ahora soporta Dahdi en lugar de zaptel. Tus pruebas serían muy útiles para que Elastix 1.5 soporte tu tarjeta de manera nativa.

    Muchas gracias por tu ayuda y por compartir tu experiencia con todos.
     
  16. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    Bueno me acaba de llegar una nueva tarjeta de codec, y la he probado en la version 1.5rc1, y vaya que si la reconoce sin problema, de una vez me amostrado los codec, los felicito por este paso que se ha dado:p :p :p :p :p :p :p

    dahdi_transcode: Loaded.
    wctc4xxp: tc400b0: Attached to device at 0000:01:00.0.
    ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 21 (level, low) -> IRQ 217
    wctc4xxp: tc400b0: (G.729a / G.723.1) Transcoder support LOADED (firm ver = 6.12)
    wctc4xxp: tc400b0: Installed a Wildcard TC: Wildcard TC400P+TC400M
    dahdi_transcode: Registered codec translator 'DTE Encoder' with 92 transcoders (srcs=0000000c, dsts=00000101)
    dahdi_transcode: Registered codec translator 'DTE Decoder' with 92 transcoders (srcs=00000101, dsts=0000000c)


    como vemos me ha reconocido 92 transcoder.....he diran que jodo...pero no heran 120????:blink: :blink: :blink: :blink:
     
  17. security

    Joined:
    May 14, 2007
    Messages:
    299
    Likes Received:
    0
    Bueno aca vamos de nuevo y esta vez con la solucion de la tarjeta de codec TC400, como la version 1.3 de elastix no la reconoce entre comillas, por que el zaptel si la reconece, pero no trae el firmware actulizado en el directorio /lib/firmware, entonces, para que nos reconosco definitivamente la tarejta y los codec debemos de bajar los archivos http://downloads.digium.com/pub/telepho ... .12.tar.gz y desconprimirlos en ese directorio, o copiar el contenido de lo que esta empaquetado en el directorio anterios (/lib/firmware), le damos los permisos de root ( chown root:root zaptel-fw-tc400m.bin), reiniciamo el servidor, y listo ya tenemos el problema resuelto, no necesitamos compliar de nuevo el zaptel, por que ya esta listo.:woohoo: :woohoo: :woohoo: :woohoo: :woohoo: :woohoo: :woohoo: :woohoo: :woohoo: :woohoo:

    haa bueno es cierto que no se ve con el comando show translation, pero alli estan los codec:blink: :blink: :blink: :blink: :blink: :blink:


    NOTA: para que nos tome la cancelacion de eco es mejor bajar los otros paquetes http://downloads.digium.com/pub/telepho ... .07.tar.gz, y http://downloads.digium.com/pub/telepho ... .01.tar.gz, este ultimo no he visto bien para que es, asi que una ayuda no me cae mal....:blush: :blush: :blush: :blush: :blush:

    Disculpen la molestia causada jejejejejje:lol: :lol: :lol: :lol: :lol: :lol:
     
  18. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    ¿O sea que el problema en la 1.3 era sólo porque faltaba el firmware?
    ¡¡Me alegro que por fin hayas triunfado!!
    ¡¡Bien hecho!!
     

Share This Page