Talkoff with elastix 1.3-2

Discussion in 'General' started by johnme, Apr 18, 2009.

  1. johnme

    Joined:
    Nov 28, 2008
    Messages:
    148
    Likes Received:
    0
    Hi all
    I have an elastix server 1.3-2 with an hfc isdn 1port card, 2 sip registrations wih voip providers, a gsm gateway portech, and 5 extentions (grandstream 2010,spa942,spa3000).

    I have some talkoff issues and i dont know how can i solve this problem.

    I try to put info as the dtmf setting on extentions, inband on gsm, dtmfthreshold=125 on mISDN.conf, relaxdtmf=yes on zapata.conf and sip_general_custom.conf, but no luck.It's better but i still have the problem.

    Do you have any suggestions?

    I also know that asterisk recognise dtmf during conversations. Mabe if we can turn it off then we should solve the problem.

    Please help
    John
     
  2. johnme

    Joined:
    Nov 28, 2008
    Messages:
    148
    Likes Received:
    0
    Hello again

    I must give some explanations... when i say talkoff i mean that during the conversation you and the other party hear dtmf tones, just like if you press a button but you don't.
    This is my problem and i should find a way to fix it.

    Thanks for your time.
    John
     
  3. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    and that happens when you talk through a sip trunk? isdn port? or between extensions?
     
  4. johnme

    Joined:
    Nov 28, 2008
    Messages:
    148
    Likes Received:
    0
    Hi
    Thanks for the question, that happens when i talk from sip trunk, isdn port, and gsm gateway.
    It don't happen when i make an internal call, or talk with someone that use asterisk.

    It happens when me or the other party is too loud i believe, and the other think i notice is that happens when a woman or a child voice is on the phone.

    I believe that asterisk recognize as dtmf the voice and try to reproduce the dtmf tone correct.
    If that's the point then how can we close the dtmf recognition during the conversation?

    Thank's
    John
     
  5. johnme

    Joined:
    Nov 28, 2008
    Messages:
    148
    Likes Received:
    0
    Hi again

    I thing i know what is wrong but dont have the solution.

    I have setup the folowing:

    1) copy paste to /etc/asterisk/features_general_custom.conf

    pickupexten => *0
    featuredigittimeout = 1500 ; Max time (ms) between digits for feature activation (default is 500 ms)
    atxfernoanswertimeout = 15 ; Timeout for answer on attended transfer default is 15 seconds.
    transferdigittimeout = 3 ; Number of seconds to wait between digits when transferring a call

    2) In general settings of free pbx i have:
    Asterisk Dial command options:tTr
    Asterisk Outbound Dial command options:Tt

    3) And in Feature Codes i have:
    In-Call Asterisk Attended Transfer = **
    In-Call Asterisk Blind Transfer = ##

    With this config i call make attended or blind transfer, and pickup a ringing phone from another.

    But i believe that this configuration makes asterisk to produse the dtmf tones (talkoff) during the conversations.

    Please tell me if my config is ok or if not, what is the best config for make transfers or pickup?
     
  6. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
  7. johnme

    Joined:
    Nov 28, 2008
    Messages:
    148
    Likes Received:
    0
    Hi

    I know that link, but it dont help much.
    When i set relaxdtmf=yes thinks are better but not ok.

    Can you give your opinion and not a link?

    Thank you
    John
     
  8. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    I was thinking about the the usage of compression codecs and the dtmf options, have you tried a cobination of codecs with the various dtmf options?

    I have used ulaw, gsm and rfc2833 and I haven't had any talkoff issues
     
  9. johnme

    Joined:
    Nov 28, 2008
    Messages:
    148
    Likes Received:
    0
    Hi

    I'm using ulaw&alaw with rfc2833
    and g729 and rfc2833 in some cases, and i have talkoff.

    Can you please put these settings ang tell me if something strange happens?
    I must find wich settings are responsible for the talkoff.


    --In general settings of free pbx put:
    Asterisk Dial command options:tTr
    Asterisk Outbound Dial command options:Tt

    Thanks
     
  10. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    If your connections (trunks and extensions) are limited to dtmfmode=rfc2833 then theoretically inband DTMF detection shouldn't be a problem as asterisk shouldn't watch the audio streams for DTMF, hence no talkoff, however in my experience this can break your IVR's etc. depending on your VOIP provider (including your gsm gateway) if they don't transcode DTMF adequately (traditional analog trunks (including ISDN) can't do this of course, so relaxeddtmf=off is your best bet on these trunks, setting it to =on will ALWAYS increase your chance of talkoff) .

    (Just my 2cents)
     
  11. johnme

    Joined:
    Nov 28, 2008
    Messages:
    148
    Likes Received:
    0
    Hi

    Yes my connections (trunks and extensions) are limited to dtmfmode=rfc2833 but I have talkoff.

    The question now is
     
  12. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    both.

    I notice you previously posted that you use inband from the gsm, does it support rfc2833? are there any gain adjustments for the audio on that device?. Sorry haven't any experience with mISDN.
     
  13. johnme

    Joined:
    Nov 28, 2008
    Messages:
    148
    Likes Received:
    0
    Hi

    In gsm I have rfc2833, inband, and dtmf sip info.
    There are several gain and volume level.I have attached an image.
    The best results for talkoff are when I use inband. If I use rfc2833 then I can
     
  14. johnme

    Joined:
    Nov 28, 2008
    Messages:
    148
    Likes Received:
    0
    Hi all


    Some good news.
    The solution for dtmf talkoff on mISDN
    Is to put in etc/asterisk/mISDN.conf
    after senddtmf=yes the command astdtmf=yes
    and the problem is gone.!!!!

    Im still have problems with my gsm gateway mv370.

    I'm using rfc2833, everythink works fine but i have some talkoff issues.

    If you know something about that please inform me.

    Thanks
    John
     

Share This Page