T1R1 rhino-linux-0.99.3-beta2 dahdi 2.3+ problem

deniq

Joined
Jun 20, 2010
Messages
2
Likes
0
Points
0
#1
I'm having a problem with the following combination of drivers (Elastix 2.0.24)

rhino-linux-0.99.3-beta2
dahdi 2.3.0.1

When booting the following is displayed in messages log:

Jun 20 11:29:14 pbx kernel: dahdi: Version: 2.3.0.1
Jun 20 11:29:14 pbx kernel: r1t1: no version for "dahdi_alarm_notify" found: kernel tainted.
Jun 20 11:29:15 pbx kernel: ACPI: PCI Interrupt 0000:00:06.0[A] -> GSI 21 (level, low) -> IRQ 193
Jun 20 11:29:15 pbx kernel: R1T1: 0 configured as T1
Jun 20 11:29:15 pbx kernel: R1T1: pciaddr = f6fc0000
Jun 20 11:29:15 pbx kernel: R1T1: claimed R1T1 PCI space
Jun 20 11:29:15 pbx kernel: R1T1: mapped R1T1 PCI space to f8e0c000
Jun 20 11:29:15 pbx kernel: R1T1: Version 37
Jun 20 11:29:15 pbx kernel: BUG: warning at /usr/src/dahdi-linux-complete/linux/drivers/dahdi/dahdi-base.c:5866/dahdi_register() (Tainted: GF )
Jun 20 11:29:15 pbx kernel: [<f8ecf43d>] dahdi_register+0x43/0x297 [dahdi]
Jun 20 11:29:15 pbx kernel: [<c04eff8b>] sprintf+0x1d/0x20
Jun 20 11:29:15 pbx kernel: [<f8e5d503>] r1t1_init_one+0x633/0x680 [r1t1]
Jun 20 11:29:15 pbx kernel: [<c055e31e>] __driver_attach+0x0/0x6b
Jun 20 11:29:15 pbx kernel: [<c04f9d25>] pci_device_probe+0x36/0x57
Jun 20 11:29:15 pbx kernel: [<c055e271>] driver_probe_device+0x42/0x92
Jun 20 11:29:15 pbx kernel: [<c055e362>] __driver_attach+0x44/0x6b
Jun 20 11:29:15 pbx kernel: [<c055dc4f>] bus_for_each_dev+0x37/0x59
Jun 20 11:29:15 pbx kernel: [<c055e1bc>] driver_attach+0x11/0x13
Jun 20 11:29:15 pbx kernel: [<c055e31e>] __driver_attach+0x0/0x6b
Jun 20 11:29:15 pbx kernel: [<c055d927>] bus_add_driver+0x64/0xfd
Jun 20 11:29:15 pbx kernel: [<c043c8e5>] __link_module+0x0/0x10
Jun 20 11:29:15 pbx kernel: [<c04f9f83>] __pci_register_driver+0x42/0x8c
Jun 20 11:29:15 pbx kernel: [<c043ebf1>] sys_init_module+0x1aed/0x1caa
Jun 20 11:29:15 pbx kernel: [<c042a948>] __request_region+0x0/0xb0
Jun 20 11:29:15 pbx kernel: [<c044be26>] audit_syscall_entry+0x15a/0x18c
Jun 20 11:29:15 pbx kernel: [<c0404f17>] syscall_call+0x7/0xb
Jun 20 11:29:15 pbx kernel: =======================

Also, I tried to compile drivers from the source but the follwing warnings occur:
WARNING: could not find /usr/src/rhino-linux/drivers/rhino/r1t1/.GpakDsp.o.cmd for /usr/src/rhino-linux/drivers/rhino/r1t1/GpakDsp.o
WARNING: could not find /usr/src/rhino-linux/drivers/rhino/rcbfx/.DspLoader.o.cmd for /usr/src/rhino-linux/drivers/rhino/rcbfx/DspLoader.o
WARNING: could not find /usr/src/rhino-linux/drivers/rhino/rxt1/.GpakDsp.o.cmd for /usr/src/rhino-linux/drivers/rhino/rxt1/GpakDsp.o
WARNING: "dahdi_rbsbits" [/usr/src/rhino-linux/drivers/rhino/rxt1/rxt1.ko] undefined!
WARNING: "dahdi_hdlc_finish" [/usr/src/rhino-linux/drivers/rhino/rxt1/rxt1.ko] undefined!
WARNING: "dahdi_unregister" [/usr/src/rhino-linux/drivers/rhino/rxt1/rxt1.ko] undefined!
WARNING: "dahdi_ec_span" [/usr/src/rhino-linux/drivers/rhino/rxt1/rxt1.ko] undefined!
WARNING: "dahdi_receive" [/usr/src/rhino-linux/drivers/rhino/rxt1/rxt1.ko] undefined!
WARNING: "dahdi_hdlc_abort" [/usr/src/rhino-linux/drivers/rhino/rxt1/rxt1.ko] undefined!
WARNING: "dahdi_register" [/usr/src/rhino-linux/drivers/rhino/rxt1/rxt1.ko] undefined!
WARNING: "dahdi_transmit" [/usr/src/rhino-linux/drivers/rhino/rxt1/rxt1.ko] undefined!
WARNING: "dahdi_hdlc_getbuf" [/usr/src/rhino-linux/drivers/rhino/rxt1/rxt1.ko] undefined!
WARNING: "dahdi_alarm_notify" [/usr/src/rhino-linux/drivers/rhino/rxt1/rxt1.ko] undefined!
WARNING: "dahdi_hdlc_putbuf" [/usr/src/rhino-linux/drivers/rhino/rxt1/rxt1.ko] undefined!
WARNING: "dahdi_rbsbits" [/usr/src/rhino-linux/drivers/rhino/rcbfx/rcbfx.ko] undefined!
WARNING: "dahdi_unregister" [/usr/src/rhino-linux/drivers/rhino/rcbfx/rcbfx.ko] undefined!
WARNING: "dahdi_ec_span" [/usr/src/rhino-linux/drivers/rhino/rcbfx/rcbfx.ko] undefined!
WARNING: "dahdi_receive" [/usr/src/rhino-linux/drivers/rhino/rcbfx/rcbfx.ko] undefined!
WARNING: "dahdi_register" [/usr/src/rhino-linux/drivers/rhino/rcbfx/rcbfx.ko] undefined!
WARNING: "dahdi_transmit" [/usr/src/rhino-linux/drivers/rhino/rcbfx/rcbfx.ko] undefined!
WARNING: "dahdi_rbsbits" [/usr/src/rhino-linux/drivers/rhino/r1t1/r1t1.ko] undefined!
WARNING: "dahdi_unregister" [/usr/src/rhino-linux/drivers/rhino/r1t1/r1t1.ko] undefined!
WARNING: "dahdi_ec_span" [/usr/src/rhino-linux/drivers/rhino/r1t1/r1t1.ko] undefined!
WARNING: "dahdi_receive" [/usr/src/rhino-linux/drivers/rhino/r1t1/r1t1.ko] undefined!
WARNING: "dahdi_register" [/usr/src/rhino-linux/drivers/rhino/r1t1/r1t1.ko] undefined!
WARNING: "dahdi_transmit" [/usr/src/rhino-linux/drivers/rhino/r1t1/r1t1.ko] undefined!
WARNING: "dahdi_alarm_notify" [/usr/src/rhino-linux/drivers/rhino/r1t1/r1t1.ko] undefined

Please advise what can be done.
Thanks
 

rollinsolo

Joined
Feb 11, 2009
Messages
279
Likes
0
Points
0
#2
What PBX platform are you using that utilizes Dahdi 2.3.0 ? It does not come with any of the older or latest flavors of Elastix ?
 

deniq

Joined
Jun 20, 2010
Messages
2
Likes
0
Points
0
#3
It's an Elastix 2.0 branch, version 2.0.24 based on * 1.6.2
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,887
Members
17,565
Latest member
omarmenichetti
Top