T1 issue, help please.

Discussion in 'General' started by fcorona, Apr 4, 2011.

  1. fcorona

    Joined:
    Feb 10, 2011
    Messages:
    6
    Likes Received:
    0
    Hi, i have a problem setting up a T1 line, no matter what i do i can't get my calls out. i had plain asterisk and now i have elastix latest version and i did a yum update.

    it recognizes the card but i have to setup the right parameters, this is how it looks after a dahdi_genconf.

    ### Span 1: WCT1/0 "Wildcard TE122 Card 0" (MASTER) B8ZS/ESF REDClockSource
    1 PRI Clear (In use) (SWEC: OSLEC) RED
    2 PRI Clear (In use) (SWEC: OSLEC) RED
    3 PRI Clear (In use) (SWEC: OSLEC) RED
    4 PRI Clear (In use) (SWEC: OSLEC) RED
    5 PRI Clear (In use) (SWEC: OSLEC) RED
    6 PRI Clear (In use) (SWEC: OSLEC) RED
    7 PRI Clear (In use) (SWEC: OSLEC) RED
    8 PRI Clear (In use) (SWEC: OSLEC) RED
    9 PRI Clear (In use) (SWEC: OSLEC) RED
    10 PRI Clear (In use) (SWEC: OSLEC) RED
    11 PRI Clear (In use) (SWEC: OSLEC) RED
    12 PRI Clear (In use) (SWEC: OSLEC) RED
    13 PRI Clear (In use) (SWEC: OSLEC) RED
    14 PRI Clear (In use) (SWEC: OSLEC) RED
    15 PRI Clear (In use) (SWEC: OSLEC) RED
    16 PRI Clear (In use) (SWEC: OSLEC) RED
    17 PRI Clear (In use) (SWEC: OSLEC) RED
    18 PRI Clear (In use) (SWEC: OSLEC) RED
    19 PRI Clear (In use) (SWEC: OSLEC) RED
    20 PRI Clear (In use) (SWEC: OSLEC) RED
    21 PRI Clear (In use) (SWEC: OSLEC) RED
    22 PRI Clear (In use) (SWEC: OSLEC) RED
    23 PRI Clear (In use) (SWEC: OSLEC) RED
    24 PRI HDLCFCS (In use) RED

    after i setup d4/ami then the T1 goes up but with every channel in use, from there i have another issue.

    Then my next step i modify /etc/asterisk/dahdi-channels.conf and i change singnalling as em_w and it stops using every channel but now asterisk does not recognize dahdi commands.
    [root@]# lsdahdi
    ### Span 1: WCT1/0 "Wildcard TE122 Card 0" (MASTER) AMI/D4 ClockSource
    1 PRI Clear (In use) (SWEC: OSLEC)
    2 PRI Clear (In use) (SWEC: OSLEC)
    3 PRI Clear (In use) (SWEC: OSLEC)
    4 PRI Clear (In use) (SWEC: OSLEC)
    5 PRI Clear (In use) (SWEC: OSLEC)
    6 PRI Clear (In use) (SWEC: OSLEC)
    7 PRI Clear (In use) (SWEC: OSLEC)
    8 PRI Clear (In use) (SWEC: OSLEC)
    9 PRI Clear (In use) (SWEC: OSLEC)
    10 PRI Clear (In use) (SWEC: OSLEC)
    11 PRI Clear (In use) (SWEC: OSLEC)
    12 PRI Clear (In use) (SWEC: OSLEC)
    13 PRI Clear (In use) (SWEC: OSLEC)
    14 PRI Clear (In use) (SWEC: OSLEC)
    15 PRI Clear (In use) (SWEC: OSLEC)
    16 PRI Clear (In use) (SWEC: OSLEC)
    17 PRI Clear (In use) (SWEC: OSLEC)
    18 PRI Clear (In use) (SWEC: OSLEC)
    19 PRI Clear (In use) (SWEC: OSLEC)
    20 PRI Clear (In use) (SWEC: OSLEC)
    21 PRI Clear (In use) (SWEC: OSLEC)
    22 PRI Clear (In use) (SWEC: OSLEC)
    23 PRI Clear (In use) (SWEC: OSLEC)
    24 PRI HDLCFCS (In use)

    Every other file is just as default, i created a trunk, but nothing seems to get this working, and it was from plain asterisk and zaptel.

    PLEASE........any ideas??????
     
  2. Megabyte

    Joined:
    Mar 28, 2009
    Messages:
    327
    Likes Received:
    0
    Hi, you wrote about D4,ami, are you from Dominican Republic?, if so or not, can you please tell me your provider?


    Maybe i can help you, but you have to know the signalling and the configuration that this provider are sending to you.
     
  3. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    When you execute:
    service dahdi restart
    What do you get?
     
  4. fcorona

    Joined:
    Feb 10, 2011
    Messages:
    6
    Likes Received:
    0
    rcbfx: DAHDI Tools Version - 2.3.0

    DAHDI Version: 2.3.0.1
    Echo Canceller(s): OSLEC
    Configuration
    ======================

    SPAN 1: D4/ AMI Build-out: 0 db (CSU)/0-133 feet (DSX-1)

    Channel map:

    Channel 01: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 01)
    Channel 02: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 02)
    Channel 03: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 03)
    Channel 04: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 04)
    Channel 05: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 05)
    Channel 06: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 06)
    Channel 07: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 07)
    Channel 08: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 08)
    Channel 09: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 09)
    Channel 10: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 10)
    Channel 11: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 11)
    Channel 12: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 12)
    Channel 13: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 13)
    Channel 14: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 14)
    Channel 15: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 15)
    Channel 16: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 16)
    Channel 17: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 17)
    Channel 18: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 18)
    Channel 19: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 19)
    Channel 20: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 20)
    Channel 21: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 21)
    Channel 22: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 22)
    Channel 23: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 23)
    Channel 24: D-channel (Default) (Echo Canceler: none) (Slaves: 24)

    24 channels to configure.

    Setting echocan for channel 1 to oslec
    Setting echocan for channel 2 to oslec
    Setting echocan for channel 3 to oslec
    Setting echocan for channel 4 to oslec
    Setting echocan for channel 5 to oslec
    Setting echocan for channel 6 to oslec
    Setting echocan for channel 7 to oslec
    Setting echocan for channel 8 to oslec
    Setting echocan for channel 9 to oslec
    Setting echocan for channel 10 to oslec
    Setting echocan for channel 11 to oslec
    Setting echocan for channel 12 to oslec
    Setting echocan for channel 13 to oslec
    Setting echocan for channel 14 to oslec
    Setting echocan for channel 15 to oslec
    Setting echocan for channel 16 to oslec
    Setting echocan for channel 17 to oslec
    Setting echocan for channel 18 to oslec
    Setting echocan for channel 19 to oslec
    Setting echocan for channel 20 to oslec
    Setting echocan for channel 21 to oslec
    Setting echocan for channel 22 to oslec
    Setting echocan for channel 23 to oslec
    Setting echocan for channel 24 to none
    [ OK ]

    Running dahdi_cfg: [ OK ]
    That's the output for service dahdi restart.

    Alfio, yes, i'm from Dominican Republic, my provider is Codetel and that's why it is d4/ami, signalling should be e&m but.......if i modify dahdi-channels.conf then asterisk can't run any dahdi commands(for the record, every channel goes clear but no asterisk detect dahdi).

    Regards,

    FC
     
  5. Megabyte

    Joined:
    Mar 28, 2009
    Messages:
    327
    Likes Received:
    0
    Pues paisano podias comenzar por ahi, en el system.conf coloca

    span=1,1,0,d4,ami
    e&m=1-24
    echocanceller=oslec,1-24
    loadzone = us
    defaultzone = us

    en el chan_dahdi.conf
    [trunkgroups]

    [channels]
    context=from-pstn
    signalling=em_w
    rxwink=300 ; Atlas seems to use long (250ms) winks
    usecallerid=yes
    hidecallerid=no
    callwaiting=yes
    usecallingpres=yes
    callwaitingcallerid=yes
    threewaycalling=yes
    transfer=yes
    canpark=yes
    cancallforward=yes
    callreturn=yes
    echocancel=yes
    echocancelwhenbridged=no
    faxdetect=incoming
    echotraining=800
    rxgain=0.0
    txgain=0.0
    callgroup=1
    pickupgroup=1

    ;Uncomment these lines if you have problems with the disconection of your analog lines
    ;busydetect=yes
    ;busycount=3


    immediate=no

    #include dahdi-channels.conf
    #include chan_dahdi_additional.conf



    en el dahdi-channels.conf

    group=0,11
    context=from-pstn
    channel => 1-24
    context = default
    group = 63

    Bueno me avisas.
     
  6. fcorona

    Joined:
    Feb 10, 2011
    Messages:
    6
    Likes Received:
    0
    Alfio, ahora mismo ya me esta funcionando, no probe tu configuracion todavia, tendre que hacerlo fuera de horario laborable, todavia tengo un inconveniente, aun ahora que me salen las llamadas, la tarjeta dice que esta usando todos los canales.
     
  7. fcorona

    Joined:
    Feb 10, 2011
    Messages:
    6
    Likes Received:
    0
    My T1 is working but, now i have another issue, my calls sometimes go trough and some don't, dialing the same number.........any ideas.
     

Share This Page