System voice prompts

Discussion in 'General' started by Rolf, Nov 12, 2007.

  1. Rolf

    Joined:
    Nov 9, 2007
    Messages:
    19
    Likes Received:
    0
    Hi, ALL!!!
    Can you say me, how i can change system voice prompts in Elastix?
     
  2. rikolen

    Joined:
    Oct 24, 2007
    Messages:
    25
    Likes Received:
    0
    You have to edit the file /etc/asterisk/asterisk.conf and put:

    [option]
    languageprefix=yes

    and include your prefer language in the files zaptel.conf, sip.conf for example

    in /etc/asterisk/sip.conf
    [general]
    language=es
     
  3. Rolf

    Joined:
    Nov 9, 2007
    Messages:
    19
    Likes Received:
    0
    Ok, if i set language=ru, system voice prompts will change to russian? Is it necessary to add russian voice package to Elastix?

    You see, I would like, that prompts as "You have 1 new message. Press 1 to listen to it" will be in russian.
     
  4. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    You have to download the russian prompts (search the internet, I don't know where to download them), and put them in: /var/lib/asterisk/sounds/ru
    and
    /var/lib/asterisk/sounds/digits/ru
    And if you do all the above mentioned, you should get russian propts.
     
  5. techieg

    Joined:
    Oct 8, 2007
    Messages:
    81
    Likes Received:
    0
    I am unsure anyone can tell you if there is Russian language in there if they have not used it before, I know I can't. Unless you try it, you will never know if there is Russian language in there. And if you find out there is none, at least you will then know your next step is to buy the Russian language pack if there is one or make yours if there isn't.
     
  6. ccccp

    Joined:
    Jan 18, 2011
    Messages:
    29
    Likes Received:
    0
  7. scdzaak

    Joined:
    Apr 12, 2013
    Messages:
    5
    Likes Received:
    0
    Dear Forum users,

    In elastix you can use the language options.
    In my case I have used the language=NL (dutch language)
    everything seems te be fine, but I have only one misser:

    When I use the voicemail prompts (select 1 for listen to new message ) after the text 'at' the line drops ..
    The at.gsm file is in the language directories, but is not known by the dutch selction.

    When I rename the 'en' folder to 'en_old' and give the 'nl' folder the name 'en'
    I can hear the voice in english language that says 'at' and the voice messages can listen. (between the dutch text )

    Is their anyone who know what this error will be ?

    Regards,

    Eric
     

Share This Page