SPA509G BLF

micropat

Joined
Apr 28, 2010
Messages
19
Likes
0
Points
0
#1
I have Elastix 1.6 running with several Yealink D28P phones deployed. The BLF's on those phones are a little buggy, so I've deployed a Cisco SPA509G as a test. It's up to date on its firmware and it registers fine and tests ok except for the BLF function. here is my setup within the phone tab of the SPA509G:

Extension:Disabled
Share Call Appearance:private
Extended Function:fnc=blf+sd;sub=401@$PROXY;ext=401@$PROXY


the speed dial works ok, but the LED stays orange no matter what is happening with the extension I wish to monitor (401).

Any help would be appreciated.
 

micropat

Joined
Apr 28, 2010
Messages
19
Likes
0
Points
0
#2
and without the added smileys:

Extension- Disabled
Share Call Appearance- Private
Extended Function:fnc- blf+sd;sub=401@$PROXY;ext=401@$PROXY
 

baldhead

Joined
Aug 30, 2009
Messages
30
Likes
0
Points
0
#3
In order to have the BLF working with linksys / cisco SB you need to choose the asterisk mode.

For the SPA 962 or the SPA 509G, your need to go in the web configuration utility of the phone.
Then you go to the tab attendant console (932 for the SPA 962),
and for the "server type", you juste choose 'astersik'.

Sylvain
 

eNoisy

Joined
Jul 24, 2010
Messages
59
Likes
0
Points
0
#4
Good day!

Micropat, could you solve the issue? If yes, how?

I have the very same problem with some SPA962. The LED remains orange and the speed dial works fine.

I did the firmware upgrade + configuration on the phone tab + selected asterisk as the server type. It still doesn't work. Could there be anything extra missing on the asterisk config files?

FYI I followed this guide:
http://www.greenwireit.com/tag/blf-sla-spa962/

Oh and by the way, the phones are connecting remotely to the PBX. I'm pretty sure this should not affect but just thought it would be worth mentioning.
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,886
Members
17,563
Latest member
dineshr
Top