Sonnerie permanente sur IAX

Discussion in 'Elastix 2.x' started by fredo69, Jan 1, 2009.

  1. fredo69

    Joined:
    Nov 7, 2008
    Messages:
    13
    Likes Received:
    0
    Bonjour,
    j'ai remarqué en utilisant Zoiper (compte IAX) ou un tél ip IAX, si je fais sonner le IAX une fois ou plus et je coupe, le tél continu à sonner (il s'arrêtera au bout de 30 sec environs)
    si je fais le même essai avec un compte SIP pas de prob, le tél SIP cesse de sonner dès que j'ai raccroché le tél appelant.

    résumé :
    avec un compte sip ou iax, j'appelle un iax et je coupe : continue de sonner
    avec un compte sip ou iax, j'appelle un sip et je coupe : la sonnerie cesse.

    sachant que sur zapata.conf , j'ai bien
    busydetect=yes
    busycount=6
    non commentés.

    une idée ?

    merci
     
  2. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Je ne voie pas pourquoi le zapata.conf serait en cause.
    Regardes plutôt le iax.conf.

    peut-être qu'il y manque quelques choses!

    Est-ce que ton problème se passe aussi pour les problème internes?
    • iax -> iax
      Sip -> iax.


    Qu'as-tu remarqué en mode Debug?

    Je vais essayé çà entre temps si j'ai le même problème.
     
  3. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    de SIP à IAX ça marche.
     
  4. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    D'un appel entrant
    Freebox (RTC) -> SPA3102 (SIP) -> Elastix -> IAX2.
    La sonnerie tient sans problème.

    Essayes de mettre Call Waitting à enable sur le compte IAX2

    Je n'arrive pas à reproduire ton phénomène. :huh:
     
  5. fredo69

    Joined:
    Nov 7, 2008
    Messages:
    13
    Likes Received:
    0
    Oui, ça le fait bien en interne :
    Sip -> iax
    Iax -> iax
    dans le iax, j'ai pas de ligne avec busydetect
    c koi le mode debug : asterisk -r c ça ?
     
  6. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    mode debug, c'est:
    #Astterisk -rvvvvvvvvvvvvvv
    CLI>sip set debug peer Extension
    ou
    CLI>sip set debug

    pour dévalider le mode debug:

    CLI>sip set debug off
    CLI>exit ou [CTRL]+[C]

    (et quand c'est de IAX2)

    CLI>IAX2 set debug
    CLI>IAX2 set debug off

    Si ça le fait bien en interne alors ça ne vient pas de la conf zapata.
    ça vient plutôt de la conf IAX2.

    Essayes de ne pas valider de mevo sur les comptes IAX2 et de mettre Call Waitting à enable.

    Regardes ce qu'il se passe et dis moi.
     

Share This Page