[SOLVED] Voicemail password problem

Discussion in 'General' started by jhunholz, Nov 11, 2009.

  1. jhunholz

    Joined:
    Oct 6, 2009
    Messages:
    13
    Likes Received:
    0
    I would like to set Elastix so that it doesn't prompt for a voicemail password when the person is calling from their own phone. For example, when calling voicemail from extension 2111, it should just go to my messages and not ask for my password. Is there any way to change that? Thanks.
     
  2. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    Re:Voicemail password problem

    Yes, it can be done

    You will need to write a context on /etc/asterisk/extensions_custom.conf

    1. Locate the context [from-internal-custom]
    add the following line
    include => vm-nopassw

    2. At the end of the file write the following context
    [vm-nopassw]
    exten => *96,1,Answer
    exten => *96,n,VoiceMailMain(${CALLERID(num)},s)
    exten => *96,n,Hangup

    3. Save and exit the file

    4. Execute from the shell
    asterisk -rx "reload"

    5. From any phone dial *96, and you should enter directly to check your messages
     
  3. strongbow242

    Joined:
    Apr 25, 2009
    Messages:
    65
    Likes Received:
    0
    Re:Voicemail password problem

    That's a bit complicated. When I set up my extension, I just left the password blank. A popup asks if you really want to do this, press the OK button, hit the orange bar and you're good to go. This is on Elastix 1.6 stable.
     
  4. jhunholz

    Joined:
    Oct 6, 2009
    Messages:
    13
    Likes Received:
    0
    Re:Voicemail password problem

    Thanks for the tips. I ended up doing something similar to what was suggested. Here's what I came up with:

    [vm-nopassw]
    exten => 100,1,Answer
    exten => 100,n,Macro(user-callerid,)
    exten => 100,n,Macro(get-vmcontext,${AMPUSER})
    exten => 100,n,VoiceMailMain(s${AMPUSER}@${VMCONTEXT})
    exten => 100,n,Hangup

    The reason we had to change it is because users in our system can have multiple devices assigned to them (Desk phone + a Softphone + occasionally another Desk phone at home). Posting this back here in case anyone else has a problem with it.
     

Share This Page