[solved]multiple iax errors in log every 60seconds

Discussion in 'General' started by Zanthius, Mar 3, 2011.

  1. Zanthius

    Joined:
    Mar 3, 2011
    Messages:
    3
    Likes Received:
    0
    Hi all,

    First post, so please excuse me if I break any forum etiquette.

    I have just installed elastix on my virtual server, configured my trunks and extensions all fine (working great so far), i'm trying to setup a virtual fax. It is working OK sending and receiving, but I get the following errors in the log every 60 seconds:

    [2011-03-04 01:10:36] NOTICE[24387] chan_iax2.c: Restricting registration for peer '1011' to 60 seconds (requested 300)
    [2011-03-04 01:11:31] NOTICE[24390] chan_iax2.c: Restricting registration for peer '1011' to 60 seconds (requested 300)
    [2011-03-04 01:12:26] NOTICE[24394] chan_iax2.c: Restricting registration for peer '1011' to 60 seconds (requested 300)
    [2011-03-04 01:13:21] NOTICE[24389] chan_iax2.c: Restricting registration for peer '1011' to 60 seconds (requested 300)
    [2011-03-04 01:14:16] NOTICE[24386] chan_iax2.c: Restricting registration for peer '1011' to 60 seconds (requested 300)

    I have read elsewhere that I have to change the refresh from 300 to 60. I found this in /etc/iaxmodem/iaxmodem-cfg.ttyIAX1

    I changed it to refresh 60 and saved the file. I wasn't sure how to reload so it would take the changes, so I made a small change in my trunk to trigger an update, but I still get the error. I also found the command line: voip*CLI> iax2 reload
    Which gave the result:
    == Parsing '/etc/asterisk/iax.conf': == Found
    == Parsing '/etc/asterisk/iax_general_additional.conf': == Found
    == Parsing '/etc/asterisk/iax_general_custom.conf': == Found
    == Parsing '/etc/asterisk/iax_registrations_custom.conf': == Found
    == Parsing '/etc/asterisk/iax_registrations.conf': == Found
    == Parsing '/etc/asterisk/iax_custom.conf': == Found
    == Parsing '/etc/asterisk/iax_additional.conf': == Found
    == Parsing '/etc/asterisk/iax_custom_post.conf': == Found
    == Parsing '/etc/asterisk/users.conf': == Found
    -- Seeding '1011' at 127.0.0.1:40000 for 60

    But i'm still getting the error in the log. Finally I tried a #service asterisk restart, but still the same thing.

    It all seems to work OK, but I would just like to stop this error bloating out my log files.

    Thanks for any help.
     
  2. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    Re: multiple iax errors in log every 60 seconds

    you need to reload iaxmodem then hylafax then asterisk
     
  3. Zanthius

    Joined:
    Mar 3, 2011
    Messages:
    3
    Likes Received:
    0
    Re: multiple iax errors in log every 60 seconds

    Thanks very much for your response. I'm not able to find the command to restart hylafax i'm afraid. Are you able to advise?

    Thanks again.
     
  4. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    Re: multiple iax errors in log every 60 seconds

    grrr searh ...jeje dont be lazy service iaxmodem restart, service hylafax restart, asterisk -rx "reload"
     
  5. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    Re: multiple iax errors in log every 60 seconds

    grrr searh ...jeje dont be lazy service iaxmodem restart, service hylafax restart, asterisk -rx "reload"
     
  6. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    Re: multiple iax errors in log every 60 seconds

    grrr searh ...jeje dont be lazy service iaxmodem restart, service hylafax restart, asterisk -rx "reload"
     
  7. Zanthius

    Joined:
    Mar 3, 2011
    Messages:
    3
    Likes Received:
    0
    Re: multiple iax errors in log every 60 seconds

    As, sorry. I was looking all through the asterisk CLI interface for it, didn't know it was a service all it's self.

    Thanks very much, looks like it worked.
     
  8. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    Re: multiple iax errors in log every 60 seconds

    if its working and solved your issue change the status of the question as solved and always vote positive in karma to all people who helps you!
     
  9. dicko

    Joined:
    Oct 24, 2008
    Messages:
    4,099
    Likes Received:
    0
    Re: multiple iax errors in log every 60 seconds

    sed -i s'/^refresh.*/refresh\t\t60/g' /etc/iaxmodem/*cfg.tty*; service iaxmodem restart;rasterisk -x reload
     
  10. fmvillares

    Joined:
    Sep 8, 2007
    Messages:
    1,785
    Likes Received:
    0
    Re: multiple iax errors in log every 60 seconds

    excellent script line dick!!!!
     
  11. Yourname

    Joined:
    Dec 13, 2011
    Messages:
    71
    Likes Received:
    0

Share This Page