small problem

Discussion in 'General' started by Shreif, Jun 20, 2009.

  1. Shreif

    Joined:
    Jun 15, 2009
    Messages:
    6
    Likes Received:
    0
    i have my elastix on e server inside my local network and i got it worked successfully when using 2 different PCs using softphones, but the problem appeared when trying to use a SIP mobile phone i entered the data as follow:

    Registrar Server: sip:192.168.1.100
    Realm: 192.168.1.100
    User Name: 2012
    Password: ****
    Transport Type: Auto (TCP/UDP)
    Port: 5060

    the problem is the phone cant register it's a registration failed message
    i think the problem is the realm and the registrar server because i entered the server's local IP over the internal network while the phone doesn't work internally
    so what do you think am i thinking the right way and if so what do you suggest to solve that issue
    Thanks in advance
     
  2. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    Yes, that is correct, if your mobile is not on your lan, then if you put the local ip of your elastix, it wont work... In that case, you should put the public ip of your elastix, if your server doesn't have one, then you must forward port 5060, and 10000-20000 from your public ip into your elastix (that must be done on your firewall/router)
     
  3. Shreif

    Joined:
    Jun 15, 2009
    Messages:
    6
    Likes Received:
    0
    Thanks for your reply, i replaced the registerar IP and the realm by my public ip and forwarded the ports as you said but still can't have my mobile phone registered and here is a pic for the forwarded ports on my 3com router and please if i didn't forward the ports the right way tell me as i didn't do anything except adding them to the virtual servers.
    thanks again:cheer:
     

Share This Page