Skype for Asterisk - one way audio

Discussion in 'General' started by peterz, Feb 5, 2010.

  1. peterz

    Joined:
    Feb 1, 2010
    Messages:
    9
    Likes Received:
    0
    Hi,

    We have linux box with 2 nics

    1 - public
    2 - private

    All works like charm for SIP phones.

    I installed Skype for asterisk following this tutorial http://blogs.elastix.org/en/2009/11/sky ... -asterisk/.

    All works great except:

    1. Skype cals our asterisk --> works great like charm
    2. Extensions located in the LAN calls Skype outside.

    Skype: hears and talks
    Sipo phone(extension): can not hear one way audio.

    Server is NOT behind nat or anything - it is just multihomed machine and skype contacts are configured as extensions.

    I tried plenty of stuff, but nothing works. chan_skype is basically stock one - just user/pass changed...

    Thanks :)
     
  2. peterz

    Joined:
    Feb 1, 2010
    Messages:
    9
    Likes Received:
    0
    Issue Solved.

    In case someone needs to fix thsi in the future:

    Install g.729 codec(included in your SFA license)

    Disable other codes in chan_skype.com and allow onlt g729

    This solves the problem.
     
  3. adrem78

    Joined:
    Jun 28, 2010
    Messages:
    1
    Likes Received:
    0
    Hi peterz.
    Can you tell me how install g729 licence ?

    When I run register digium utility, set g729 codec and
    insert my skype for asterisk licence key
    I get server error "invalid prefix, shoul be G729"

    Thanks
     
  4. yesmat

    Joined:
    Mar 16, 2009
    Messages:
    103
    Likes Received:
    0
    I had the same problem. I had skype4Asterisk working perfectly for some time and it started giving one way audio after I started tinkering with it and changing CODEC configs.

    What i did was adding allow=g729 in addition to the already existing allow=alaw. I guess not having g729 installed in my box has caused a confusion. So by removing the allow=g729 statement problem fixed.

    Hope that helps someone.
     

Share This Page