SIP phones are not registering with Elastix

Discussion in 'General' started by Kranti, Oct 3, 2008.

  1. Kranti

    Joined:
    Oct 3, 2008
    Messages:
    28
    Likes Received:
    0
    Hi all,

    I have purchased software from elastix 2 weeks ago
    After installtion of Elastix Pbx, my Sip phones are not registering with Elastix. I tried with X-lite soft phone.
    Can somebody please help

    Thanks,
    Kranti
     
  2. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    What's your LAN configuration and what's your FreePBX configuration for all extension?
     
  3. Kranti

    Joined:
    Oct 3, 2008
    Messages:
    28
    Likes Received:
    0
    We configured extensions 222, 500, and 501 with same secret as user name. We didn't change any settings in the free pbx. But if we change Sip.conf file it is working fine.
     
  4. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    What do you change into the sip.conf file?
     
  5. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Only think.
    After creating the extension, there isn't codec enabled into your extension.
    By default, it's the file's parameters are enabled.

    So, you must do include some default parameters into sip.conf if you want that your extensions works!
    But there isn't registration problem!
     
  6. Kranti

    Joined:
    Oct 3, 2008
    Messages:
    28
    Likes Received:
    0
    Attached is my sip.conf which I am using. I am not able to locate which param i need to modify to make my softphone work. Please assist in modifying this config file.
     
  7. Kranti

    Joined:
    Oct 3, 2008
    Messages:
    28
    Likes Received:
    0
  8. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    I don't know why you have this big sip.conf file!

    You must use Freepbx configurateur!

    Me, i use freepbx and there's no problem.
    You, can sea my sip.conf it's not same!!

    >more sip.conf :

    Code:
    ; do not edit this file, this is an auto-generated file by freepbx
    ; all modifications must be done from the web gui
    
    [general]
    disallow=all
    allow=alaw
    allow=speex
    canreinvite=no
    nat=yes
    defaultexpirey=1800
    dtmfmode=auto
    qualify=yes
    ;
    ; enable and force the sip jitterbuffer. If these settings are desired
    ; they should be set in the sip_general_custom.conf file as this file
    ; will get overwritten during reloads and upgrades.
    ;
    ; jbenable=yes
    ; jbforce=yes
    
    ; These will all be included in the [general] context
    ;
    #include sip_general_additional.conf
    #include sip_general_custom.conf
    #include sip_nat.conf
    #include sip_registrations_custom.conf
    #include sip_registrations.conf
    
    ; These should all be expected to come after the [general] context
    ;
    #include sip_custom.conf
    #include sip_additional.conf
    #include sip_custom_post.conf
    Remake your install completly. Normally, you have not done a lot of changes on the file sip.conf. Use simply PBX configuration. Else, try my parameters sip.conf if you want.


    Reply me
     
  9. Kranti

    Joined:
    Oct 3, 2008
    Messages:
    28
    Likes Received:
    0
    Well. with your config file, softphones are registering but communication is not happening. Getting message "Call Failed: Not Found".
    My config file is shipped with the latest release of Elastix v1.1.7. This latest config has video support and are looking for this new feature. But seems like, for me, basic feature itself is not working.
     
  10. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    The lastest Elastix version is 1.3.2.
    Some prolbem are with the 1.1.7

    Ok, if i read your post, and that your extensions are registred, it's so possible that you are a config problem.

    Look at sip_additional.conf now, and see if your extensions is here with what parameters!
     
  11. Kranti

    Joined:
    Oct 3, 2008
    Messages:
    28
    Likes Received:
    0
    [222]
    type=friend
    secret=222
    record_out=Adhoc
    record_in=Adhoc
    qualify=yes
    port=5060
    pickupgroup=
    nat=yes
    mailbox=222@device
    host=dynamic
    dtmfmode=rfc2833
    disallow=
    dial=SIP/222
    context=from-internal
    canreinvite=no
    callgroup=
    callerid=device <222>
    call-limit=4
    allow=
    accountcode=
    call-limit=50

    That is the content of my config file for particular device. As you mentioned, there are couple of issues with v1.1.7 and one of the major issue with registration process itself. Now, that I have 1.1.7, how can i upgrade to 1.3.2? Y'day I did "yum -y update" and it updated almost 176 packages. Anything specific to be done to upgrade to latest version?
    Thanks in advance.
     
  12. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    You don't select all.
    go to System / update / installor and select only : Elastix RPM Repository for CentOS.
    and remake yum update.

    For the 1.3.2, should be on line only this Monday for the updates.!

    For all goods informations and tuto: These links.
    Wiki
    Elastix Without Tears
     
  13. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Oups...
    In my sip.conf file, change allow=alaw by allow=ulaw.
    It isn't the same codecs.
    alaw= G711a (European)
    ulaw= G711µ (UK, US, an other).
    I'm in Europe so i use alaw! ;)

    the more important is that you must have the same codec between your extensions and Elastix (Asterisk).
     
  14. Kranti

    Joined:
    Oct 3, 2008
    Messages:
    28
    Likes Received:
    0
    Thanks Danard for your help on this subject. I will update my version and will post it in this group. Many thanks again!
     
  15. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Ok ...Thanks.

    Reply me. ;)
     
  16. Chilling_Silence

    Joined:
    Sep 23, 2008
    Messages:
    488
    Likes Received:
    0
    Its worth noting that with a stock standard sip.conf file, all you need to do is add the following to enable Video Calling:
    videosupport=yes
    maxcallbitrate=384
    allow=h261
    allow=h263
    allow=h263p
    allow=h264

    Everything else should already be set, with Elastix-1.2
     
  17. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Why do you want to add video codecs? :blink:

    For the instant, these extension do not works! Wait...
    After, he can add codecs. (h264 don't enabled with Xlite free).

    In my file, i deleted my video configuration and some lines, for not to disturb.
     
  18. Kranti

    Joined:
    Oct 3, 2008
    Messages:
    28
    Likes Received:
    0
    Hi danard,

    We are unable to upgrade from Elastix 1.1.7 to 1.3.2.
    We followed the same instructions as you mentiones in the last posting.

    Please help us in upgrading to 1.3.2
     
  19. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Ok!

    Into Web GUI Elastix, SYSTEM / UpDate / Isntallator
    Select Elastix RPM Only.
    You must have a web access from your Elastix server.

    And, with SSH console, login root, and make a :
    >yum update.

    You must have all RPM with the news versions.

    Type Y for Yes

    Give me the result please.
     
  20. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Otherwise, make a fresh complet install.

    Download Elastix 1.3.2 version
    Put your CD into the CDROM reader
    Reboot your station.
    Follow the instructions.
     

Share This Page