SIP Phone no audio at the receiving end

Discussion in 'General' started by ericng, May 19, 2009.

  1. ericng

    Joined:
    May 14, 2008
    Messages:
    78
    Likes Received:
    0
    I am having elastix behind a firewall with nat and I have done the necessary sip nat. Firewall was opened with UDP ports from 4000 to 30000. I having weird problems on certain sip extension which cannot hear each others but some can. Appreciate if someone can shed some lights in resolving this.


    Thanks

    Eric
     
  2. asepulveda

    Joined:
    Jun 23, 2008
    Messages:
    400
    Likes Received:
    0
    Did you specify your codecs in each extension?
     
  3. ericng

    Joined:
    May 14, 2008
    Messages:
    78
    Likes Received:
    0
    No codec has been specified in each of the extension. Do I need to do this? If yes, what codec to be entered?
     
  4. asepulveda

    Joined:
    Jun 23, 2008
    Messages:
    400
    Likes Received:
    0
    if you are using free pbx is the better thing to do , enter to your extensions , and in disallow put all , allow , try with ulaw
     
  5. ericng

    Joined:
    May 14, 2008
    Messages:
    78
    Likes Received:
    0
    Hi asepulveda,

    I have tried to put in ulaw as codec in the extensions but still end up with some extensions cannot hear each others (for extensions outside of local LAN to communicate with the local LAN extensions). Furthermore, any attempts to call the outside number using extensions outside the local LAN will end up with no audio at the receiving end.

    Hope someone can be of further assistance.


    Thanks


    Eric
     
  6. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    I assume that you have sip remote extensions, try the following:
    Edit /etc/asterisk/sip_nat.conf (you may have this file empty)
    and put the following info:
    nat=yes
    externip=xx.xx.xx.xx (in the case that you have a public static ip)
    localnet=192.168.1.0/255.255.255.0 (the network in which your elastix is located)
    externhost=mydomain.com (in the case that you have a dynamic ip and you have dydns service)

    then execute from the shell:
    asterisk -rx "reload"
     
  7. asepulveda

    Joined:
    Jun 23, 2008
    Messages:
    400
    Likes Received:
    0
    If you are using remote extensions , the solution from jgutierrez must solve your problems, because the ports you open in your router are god enough.
     
  8. ericng

    Joined:
    May 14, 2008
    Messages:
    78
    Likes Received:
    0
    The sip_nat.conf has been updated with the nat details that required. But the weird things, not all the remote sip extensions having the problem. Some remote sip extensions do work with good quality of sound. But when come to outgoing calls, all the receiving end of the remote sip extensions not able to hear the sound.
     
  9. asepulveda

    Joined:
    Jun 23, 2008
    Messages:
    400
    Likes Received:
    0
    Your remote extensions are IP phones or softphones? if they are IP phones try to configure nat enable to yes and a stun server , for softphones try to put a stun server.
     
  10. ericng

    Joined:
    May 14, 2008
    Messages:
    78
    Likes Received:
    0
    How do we enable a stun server in Elastix? I read through "Elastix without tears" and the PBX configuration menu but I do not seem to know how to get the stun server installed or enabled.

    Hope to receive further guidance
     
  11. asepulveda

    Joined:
    Jun 23, 2008
    Messages:
    400
    Likes Received:
    0
    The stunt server must be configure in softhphones not in elastix.
     
  12. ericng

    Joined:
    May 14, 2008
    Messages:
    78
    Likes Received:
    0
    Problem solved as I found out at the remote site, the router is blocking the SIP UDP traffic. Open up and sip phone works perfectly
     

Share This Page