SIP issue, no matching peer found elastix_1.1-8

Discussion in 'General' started by Romi, Sep 3, 2008.

  1. Romi

    Joined:
    Sep 2, 2008
    Messages:
    3
    Likes Received:
    0
    I am building a new system for testing and I have stumbled on this issue
    that seems quite simple but I have wasted a lot of time trying to debug without results.
    Maybe I am not seeing something, anyway I would appreciate you assistance

    I successfully installed elastix 1.1-8 and afterwards I have installed 1.2-rc2,
    same problem on both

    So after install I successfully define IP environment on elastix server, I login via web to freePBX and I add extension (2711) and secret.
    On SIP client, on my lap I put under SIP proxy IP of elastix , for login I put in extension and for password I put in secret.
    My Elastix and lap(SIP client) are on same network, same switch
    Elastix: 192.168.0.6
    Lap: 192.168.0.11

    CLIENT DOES NOT REGISTER

    ------------
    tail -f /var/log/asterisk/full

    error:
    [Sep 2 21:10:40] NOTICE[2606] chan_sip.c: Registration from '<sip:2711@192.168.0.6>' failed for '192.168.0.11' - No matching peer found
    -------------
    -------------
    asterisk -rvvvvvvvv

    <--- SIP read from 192.168.0.11:3772 --->
    REGISTER sip:192.168.0.6 SIP/2.0
    Via: SIP/2.0/UDP 192.168.0.11:10470
    Max-Forwards: 70
    From: <sip:2711@192.168.0.6>;tag=ccc262f9ac08461ba3ce5f866dcaab05;epid=947ac56ca9
    To: <sip:2711@192.168.0.6>
    Call-ID: a944723421cc490dab2d03f871326a75@192.168.0.11
    CSeq: 1 REGISTER
    Contact: <sip:192.168.0.11:10470>;methods="INVITE, MESSAGE, INFO, SUBSCRIBE, OPTIONS, BYE, CANCEL, NOTIFY, ACK, REFER"
    User-Agent: RTC/1.2.4949
    Event: registration
    Allow-Events: presence
    Content-Length: 0


    <------------->
    --- (12 headers 0 lines) ---
    Using latest REGISTER request as basis request
    Sending to 192.168.0.11 : 10470 (no NAT)

    <--- Transmitting (no NAT) to 192.168.0.11:10470 --->
    SIP/2.0 404 Not found
    Via: SIP/2.0/UDP 192.168.0.11:10470;received=192.168.0.11
    From: <sip:2711@192.168.0.6>;tag=ccc262f9ac08461ba3ce5f866dcaab05;epid=947ac56ca9
    To: <sip:2711@192.168.0.6>;tag=as095d804e
    Call-ID: a944723421cc490dab2d03f871326a75@192.168.0.11
    CSeq: 1 REGISTER
    User-Agent: Asterisk PBX
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
    Supported: replaces
    Content-Length: 0


    <------------>
    -----------------------------

    DO YOU HAVE ANY IDEAS, what am I missing here?! B)
     
  2. Romi

    Joined:
    Sep 2, 2008
    Messages:
    3
    Likes Received:
    0
    PROBLEM RESOLVED ... THANKS!!!!!!!
     
  3. rafael

    Joined:
    May 14, 2007
    Messages:
    1,454
    Likes Received:
    1
    What was it?

    Regards,

    Rafael
     
  4. ramoncio

    Joined:
    May 12, 2010
    Messages:
    1,663
    Likes Received:
    0
    I also had problems with sip registrations with outside providers in one of my boxes, and I solved them installing and configuring bind as dns server. I noticed that when I tried to register with the server name it didn't work, but with the ip address everything worked fine.
    But your problem looks different.
    I'm glad you solved it.
     
  5. Romi

    Joined:
    Sep 2, 2008
    Messages:
    3
    Likes Received:
    0
    I was looking what freePBX is doing with extensions you are putting in, and I have realized that they have not been written to database. And then I realised that I DID NOT apply changes when I have put in extensions through freePBX, I have applied changes and all started working... as I was suspecting, very stupid error
     
  6. edd

    edd

    Joined:
    Oct 22, 2008
    Messages:
    3
    Likes Received:
    0
    Romi,
    Solution for this problem?
     

Share This Page