Sip Extension To Sip Extension

sharabig

Joined
Jun 25, 2010
Messages
15
Likes
0
Points
0
#1
Hi,
I need to know is there any way to config the elastix that the two extension will be able to talk to each other without the intervention of the system(Voip to Voip like point to point).I mean the RTP protocol between the extensions and the SIP protocol Still remain between the extension to the system. As the example in the attached file
:unsure:
 

sharabig

Joined
Jun 25, 2010
Messages
15
Likes
0
Points
0
#2
sharabig said:
Hi,
I need to know is there any way to config the elastix that the two extension will be able to talk to each other without the intervention of the system(Voip to Voip like point to point).I mean the RTP protocol between the extensions and the SIP protocol Still remain between the extension to the system. As the example below
:unsure:
 

andyshawn

Joined
Apr 3, 2009
Messages
113
Likes
0
Points
0
#3
If i understand you correctly, you want the extension communication(rtp) to be direct and not go through the server, once the session is established.
If this is what you want, then set "canreinvite=yes" in the settings for both extensions.
 

sharabig

Joined
Jun 25, 2010
Messages
15
Likes
0
Points
0
#4
Thanks for the reply,
I tried it but it does'nt work I tested it by wireshark.
Even in FREEPBX: Asterisk Sip Setting- Reinvinte Behavior I defined in YES.
 

Bob

Joined
Nov 4, 2007
Messages
2,400
Likes
1
Points
36
#5
Sharabig,

Its been a while since I played with it (e.g. Asterisk 1.4)....but there are a number of conditions that need to be met and for good reason. I suspect you may have found this article

http://www.voip-info.org/wiki/view/Aste ... anreinvite

You need to read it fully, and understand it....

dialplan prefixes - important
DTMF mode - Important
NAT thought through - Important
Codecs thought through - Important
as well as the reinvite setting....

On the whole, unless your reasons are absolutely necessary, it is not worth the trouble...

I have not tried this on Asterisk 1.6 (Elastix 2.0)....but from what I have read...all the above is still important...

Regards

Bob
 

jcasaravilla

Joined
Aug 4, 2008
Messages
55
Likes
0
Points
0
#6
Im trying in a 2.0 enviroment and the feature canreinvite "yes" doesnt work !
The extensions are in the same LAN , same codec , same dtmf mode , etc .

regards
 

sharabig

Joined
Jun 25, 2010
Messages
15
Likes
0
Points
0
#7
Hello everyone
First of all I want to thank BOB for the reply and link (it helped a lot).
Right now I'm looking into it, one conclusion I have: 1.
in the General setting you need to remove the "t" from Asterisk Dial command options
2.In the extension settings canreinvite = yes
But now my problem is the WAN because of the NAT
 

jcasaravilla

Joined
Aug 4, 2008
Messages
55
Likes
0
Points
0
#8
Works ! in dtmf mode "info" , in rfc2833 not work

regards
 

sharabig

Joined
Jun 25, 2010
Messages
15
Likes
0
Points
0
#9
jcasaravilla,
Conversation between extension to extension in the LAN : 1.canreinvite = yes ,is enough.
2. Conversation between LAN extension to external extension (WAN),You should configure the external extension dtmfmode= info.
3. A call between two external extensions, does not help any setting, no audio.
Correct me if I'm wrong
 

jcasaravilla

Joined
Aug 4, 2008
Messages
55
Likes
0
Points
0
#10
In my enviroment of elastix 2.0 testing , canreinvite:yes with dtmf rfc2833 dont work in the same lan , canreinvite:yes with dtmf info work perfect.

When 2 extensions are outside the lan , they can send rtp media in peer to peer mode too , you must configure nat in boths sides ( or not if they are direct to internet ) and nat in your instalation ( if your astrisk is behind nat )

regards
 

sharabig

Joined
Jun 25, 2010
Messages
15
Likes
0
Points
0
#11
Dear jcasaravilla
I also use Elastix 2, can you explain me how to set up the system:
1.Two External extensions(WAN):Extension 100(for example)
dtmfmode-rfc2833/info
canreinvite-yes/no/nonat
nat-yes/no
2.General Settings: Asterisk Dial command options- rt or r only
3.IN FreePBX: Asrerisk SIP Setting: NAT-yes/no/never/route
Reinvite Behavior-yes/no/nonat/update
** My system behind a router(NAT).
Note: If you use "info" you can't dial DTMF in SIP, which means you can't enter voice mail password and IVR calls.

Regards

sharabig
 

sharabig

Joined
Jun 25, 2010
Messages
15
Likes
0
Points
0
#12
Hello everyone
After many attempts ,these are the settings:
1.Two External extensions(WAN):Extension 100(for example)
dtmfmode-info
canreinvite-yes
nat-yes
2.General Settings: Asterisk Dial command options- r only
3.IN FreePBX: Asrerisk SIP Setting: NAT-yes
Reinvite Behavior-yes
** My system behind a router(NAT).
Note: If you use "info" you can't dial DTMF in SIP, which means you can't enter voice mail password and IVR calls.
Very important
X-Lite (Softphone) don't works with INFO only RFC2833, YEALINK (T28) Auto+Sip INFO
Two External Softphone (X-lite)need to set in the Account Setting in the Presence tab
Mode:Disabled ,no Peer-to-Peer (Still possible to work with rfc2833)
:cheer:
 

Bob

Joined
Nov 4, 2007
Messages
2,400
Likes
1
Points
36
#13
Sharabig,

A big thank you for posting your settings. Not that I have a use for it personally at the moment, but for anyone else looking to do the same thing, it will be invaluable.

There are too many dead end posts, where the question is asked, they resolve the question without posting the answer...so again thanks for your post(s)

Regards

Bob
 

rednectar

Joined
Nov 2, 2009
Messages
1
Likes
0
Points
0
#14
Thanks to all who contributed - you need to know that you have helped me greatly
 

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,902
Messages
130,886
Members
17,563
Latest member
dineshr
Top