Setup always recording at extensions

Discussion in 'General' started by tonywang, May 20, 2009.

  1. tonywang

    Joined:
    May 14, 2009
    Messages:
    15
    Likes Received:
    0
    Dear all, I had setup always recording at extension & queue. The call answer from queue can be recorded but the call from extension is not.
    I set PABX-general setting-extension recording override to "disabled", set extension-recording incoming & outgoing is "Always". Set Queue-queue options-call recording to "wav". The call pick up from queue are been recorded but the call from internal extension is not. What's point I missing? Thanks!
     
  2. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
  3. tonywang

    Joined:
    May 14, 2009
    Messages:
    15
    Likes Received:
    0
    Million thanks for your prompt reply.
    But it looks like I did not have authority to open new case in Mantis. Can you help that?
    How can I resoved this issue tempory?
    I had checked the Asterisk console when I pick up call from Queue & see the MixMoniter function was called in dialplan. I am wondering if you can tell which .conf I should add MixMonitor fuction to slve the issue?
     
  4. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    That is odd, have you created an account ("Signup for a new account")??

    Yes I have thoug right now of a work-around, this will work for Elastix 1.3-2:
    1. Edit /etc/asterisk/extensions.conf
    2. Find the section:
    Code:
    [macro-record-enable]
    exten => s,1,GotoIf($[${LEN(${BLINDTRANSFER})} > 0]?2:4)
    exten => s,2,ResetCDR(w)
    exten => s,3,StopMonitor()
    exten => s,4,AGI(recordingcheck,${STRFTIME(${EPOCH},,%Y%m%d-%H%M%S)},${UNIQUEID})
    exten => s,5,Noop(No recording needed)
    exten => s,999,MixMonitor(${CALLFILENAME}.wav)
    
    and leave it like:

    Code:
    [macro-record-enable]
    exten => s,1,GotoIf($[${LEN(${BLINDTRANSFER})} > 0]?2:4)
    exten => s,2,ResetCDR(w)
    exten => s,3,StopMonitor()
    exten => s,4,AGI(recordingcheck,${STRFTIME(${EPOCH},,%Y%m%d-%H%M%S)},${UNIQUEID})
    exten => s,5,Noop(Recorded forced by Jorge...)
    exten => s,6,Set(CALLFILENAME=OUT-${CALLERID(number)}-${UNIQUEID})
    exten => s,7,Goto(999)
    exten => s,999,MixMonitor(${CALLFILENAME}.wav)
    
    3. Execute from the shell:
    asterisk -rx "reload"

    That context will force to record all outgoing calls, as I know, all incoming calls are recoded, but not outgoing calls between extensions...
     
  5. tonywang

    Joined:
    May 14, 2009
    Messages:
    15
    Likes Received:
    0
    Thanks! I tried but it still not work. What I am wondering is I use internal extension A dial to another internal extension B & try to have recording for the conversion. Is it right? Or system only record the dialogue between external PSTN & internal extension?
     
  6. tonywang

    Joined:
    May 14, 2009
    Messages:
    15
    Likes Received:
    0
    I had corrected this problem. Please some expert advise me if it is ok.
    1. I did not found [macro-record-enable]in "extensions.conf" but in "extension_additional.conf".
    2. I found bellow statements in the [macro-record-enable]contect of extensions_aditional.conf
    incoude => macro-record-enable-custom
    exten => s,1,MacroExit()
    3. I included the code which provided in the extensions_custom.conf. [macro-record-enable-custom] context
    4. Add #include extensions_custom in front of extensions_additional.conf. Build the include of extensions_additional.conf & extensions_custom.conf. Alloa [macro-record-enable] include macro-record-enable-custom
    5. marked exten => s,1,MacroExit()in the extensions_aditional.conf
    , [macro-record-enable]
    6. No matter the inbound / outbound call can be record.
    7. the code I add in extensions_custom.conf. [macro-record-enable-custom] context
    *********************
    [macro-record-enable]
    exten => s,1,GotoIf($[${LEN(${BLINDTRANSFER})} > 0]?2:4)
    exten => s,2,ResetCDR(w)
    exten => s,3,StopMonitor()
    exten => s,4,AGI(recordingcheck,${STRFTIME(${EPOCH},,%Y%m%d-%H%M%S)},${UNIQUEID})
    exten => s,5,Noop(Recorded forced by Jorge...)
    exten => s,6,Set(CALLFILENAME=OUT-${CALLERID(number)}-${UNIQUEID})
    exten => s,7,Goto(999)
    exten => s,999,MixMonitor(${CALLFILENAME}.wav)
     
  7. jgutierrez

    Joined:
    Feb 28, 2008
    Messages:
    5,737
    Likes Received:
    0
    tonywang,
    If you didn't found the macro on extension.conf, then you aren't using Elastix 1.3-2, you are using Elastix 1.5, and as you said, it is located on extensions_addiotional.conf, so you should follow another procedure....

    I don't understand what you have done on extensions_additional and in extensions_custom, be more specific and provide an example, I would like to see if your solution won't be erased after any modification on the web interface, if it does, I can provide you a new procedure, after that confimr that calls are being recorded (the bug is between internal extensions, since calls to pstn are recorded without any trouble)
     
  8. tonywang

    Joined:
    May 14, 2009
    Messages:
    15
    Likes Received:
    0
    Thanks! Please privide me your new procedure. I will test it on my lab system. I believe my way is tempory alternative but always erased by web GUI modification.
     
  9. akola

    Joined:
    Mar 28, 2011
    Messages:
    6
    Likes Received:
    0
    i have same issue
    after you make a changes on web, in exstension_additional.conf file you allways get a

    [macro-record-enable]c
    incoude => macro-record-enable-custom
    exten => s,1,MacroExit()


    i don't know how but it allways overwrite the context you are writing :( if possible to find where to edit this it will be nice :)
     

Share This Page