Serveur SSH ne demarre pas

Discussion in 'Elastix 2.x' started by mickael95370, Oct 7, 2010.

  1. mickael95370

    Joined:
    Oct 28, 2009
    Messages:
    63
    Likes Received:
    0
    Bonsoir à tous

    Le serveur ssh ne demare plus depuis ce soir.

    Avez vous une solution ??

    Bonne soirée
     
  2. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Salut.

    Donc plus de connexion avec putty?
    As-tu le process sshd qui tourne sur ton serveur?
    Code:
    # service sshd status
    sshd (pid 11310 2470) en cours d'exécution...
    Sinon, essayes de lancer ssh à la main.
    # service sshd start ou
    # service sshd restart
     
  3. mickael95370

    Joined:
    Oct 28, 2009
    Messages:
    63
    Likes Received:
    0
    alut.

    Oui j'ai plus de connection par putty

    --------------------------------------------------------------------------------
    # service sshd status :

    openssh-daemon est arrête

    --------------------------------------------------------------------------------

    Sinon, essayes de lancer ssh à la main.
    # service sshd start ou
    # service sshd restart

    Démarrage de sshd : /var/empty/sshd must be owned by root and not group or world-writable

    ECHOUE

    ------------------------------------------------------------------------------


    Merci de votre aide +++
     
  4. mickael95370

    Joined:
    Oct 28, 2009
    Messages:
    63
    Likes Received:
    0
    depuis webmin

    je n'arrive pas a relance j'ai les mm message d'erreur que sur la console

    J'ai l'impression de ne plus avoir tt les droits sur les dossiers

    +++
     
  5. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Tu ne m'as pas dit si tu avais le process sshd de monté ou non!
    Vérifies la config de ssh dans ce fichier:
    /etc/ssh/ssh_config :
    Code:
    #       $OpenBSD: ssh_config,v 1.21 2005/12/06 22:38:27 reyk Exp $
    
    # This is the ssh client system-wide configuration file.  See
    # ssh_config(5) for more information.  This file provides defaults for
    # users, and the values can be changed in per-user configuration files
    # or on the command line.
    
    # Configuration data is parsed as follows:
    #  1. command line options
    #  2. user-specific file
    #  3. system-wide file
    # Any configuration value is only changed the first time it is set.
    # Thus, host-specific definitions should be at the beginning of the
    # configuration file, and defaults at the end.
    
    # Site-wide defaults for some commonly used options.  For a comprehensive
    # list of available options, their meanings and defaults, please see the
    # ssh_config(5) man page.
    
    # Host *
       ForwardAgent yes
    #   ForwardX11 no
    #   RhostsRSAAuthentication no
    #   RSAAuthentication yes
    #   PasswordAuthentication yes
    #   HostbasedAuthentication no
    #   BatchMode no
    #   CheckHostIP yes
    #   AddressFamily any
    #   ConnectTimeout 0
    #   StrictHostKeyChecking ask
    #   IdentityFile ~/.ssh/identity
    #   IdentityFile ~/.ssh/id_rsa
    #   IdentityFile ~/.ssh/id_dsa
    #   Port 22
    #   Protocol 2,1
    #   Cipher 3des
    #   Ciphers aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc
    #   EscapeChar ~
       Tunnel yes
       TunnelDevice any:any
    #   PermitLocalCommand no
    Host *
            GSSAPIAuthentication yes
    # If this option is set to yes then remote X11 clients will have full access
    # to the original X11 display. As virtually no X11 client supports the untrusted
    # mode correctly we set this to yes.
            ForwardX11Trusted yes
    # Send locale-related environment variables
            SendEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES
            SendEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT
            SendEnv LC_IDENTIFICATION LC_ALL
    et /etc/ssh/sshd_config :
    Code:
    #       $OpenBSD: sshd_config,v 1.73 2005/12/06 22:38:28 reyk Exp $
    
    # This is the sshd server system-wide configuration file.  See
    # sshd_config(5) for more information.
    
    # This sshd was compiled with PATH=/usr/local/bin:/bin:/usr/bin
    
    # The strategy used for options in the default sshd_config shipped with
    # OpenSSH is to specify options with their default value where
    # possible, but leave them commented.  Uncommented options change a
    # default value.
    
    #Port 22
    #Protocol 2,1
    Protocol 2
    #AddressFamily any
    #ListenAddress 0.0.0.0
    #ListenAddress ::
    
    # HostKey for protocol version 1
    #HostKey /etc/ssh/ssh_host_key
    # HostKeys for protocol version 2
    #HostKey /etc/ssh/ssh_host_rsa_key
    #HostKey /etc/ssh/ssh_host_dsa_key
    
    # Lifetime and size of ephemeral version 1 server key
    #KeyRegenerationInterval 1h
    #ServerKeyBits 768
    
    # Logging
    # obsoletes QuietMode and FascistLogging
    #SyslogFacility AUTH
    SyslogFacility AUTHPRIV
    #LogLevel INFO
    
    # Authentication:
    
    #LoginGraceTime 2m
    #PermitRootLogin yes
    #StrictModes yes
    #MaxAuthTries 6
    
    #RSAAuthentication yes
    #PubkeyAuthentication yes
    #AuthorizedKeysFile     .ssh/authorized_keys
    
    # For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
    #RhostsRSAAuthentication no
    # similar for protocol version 2
    #HostbasedAuthentication no
    # Change to yes if you don't trust ~/.ssh/known_hosts for
    # RhostsRSAAuthentication and HostbasedAuthentication
    #IgnoreUserKnownHosts no
    # Don't read the user's ~/.rhosts and ~/.shosts files
    #IgnoreRhosts yes
    
    # To disable tunneled clear text passwords, change to no here!
    #PasswordAuthentication yes
    #PermitEmptyPasswords no
    PasswordAuthentication yes
    
    # Change to no to disable s/key passwords
    #ChallengeResponseAuthentication yes
    ChallengeResponseAuthentication no
    
    # Kerberos options
    #KerberosAuthentication no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes
    #KerberosGetAFSToken no
    
    # GSSAPI options
    #GSSAPIAuthentication no
    GSSAPIAuthentication yes
    #GSSAPICleanupCredentials yes
    GSSAPICleanupCredentials yes
    
    # Set this to 'yes' to enable PAM authentication, account processing,
    # and session processing. If this is enabled, PAM authentication will
    # be allowed through the ChallengeResponseAuthentication mechanism.
    # Depending on your PAM configuration, this may bypass the setting of
    # PasswordAuthentication, PermitEmptyPasswords, and
    # "PermitRootLogin without-password". If you just want the PAM account and
    # session checks to run without PAM authentication, then enable this but set
    # ChallengeResponseAuthentication=no
    #UsePAM no
    UsePAM yes
    
    # Accept locale-related environment variables
    AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES
    AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT
    AcceptEnv LC_IDENTIFICATION LC_ALL
    #AllowTcpForwarding yes
    #GatewayPorts no
    #X11Forwarding no
    X11Forwarding yes
    #X11DisplayOffset 10
    #X11UseLocalhost yes
    #PrintMotd yes
    #PrintLastLog yes
    #TCPKeepAlive yes
    #UseLogin no
    #UsePrivilegeSeparation yes
    #PermitUserEnvironment no
    #Compression delayed
    #ClientAliveInterval 0
    #ClientAliveCountMax 3
    #ShowPatchLevel no
    #UseDNS yes
    #PidFile /var/run/sshd.pid
    #MaxStartups 10
    #PermitTunnel no
    
    # no default banner path
    #Banner /some/path
    
    # override default of no subsystems
    Subsystem       sftp    /usr/libexec/openssh/sftp-server
    
    S'il y a une différence, remplaces les fichiers et relance le service.
     
  6. mickael95370

    Joined:
    Oct 28, 2009
    Messages:
    63
    Likes Received:
    0
    Comment je fais pour ouvrir les fichier si j'ai pas ssh
     
  7. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Ben sur ton serveur (Clavier + UC + Ecran), tu te logues. Point. :blink:
    Au lieu de te connecter via IP tu te connectes directement sur la console.
     
  8. mickael95370

    Joined:
    Oct 28, 2009
    Messages:
    63
    Likes Received:
    0
    j'ai modifié les fichiers avec se que tu m'as di

    Voila le message :

    Impossible de démarrer le serveur SSH :
    Démarrage de sshd :/etc/ssh/sshd_config: line 21: Bad configuration option: ForwardAgent
    /etc/ssh/sshd_config: line 40: Bad configuration option: Tunnel
    /etc/ssh/sshd_config: line 41: Bad configuration option: TunnelDevice
    /etc/ssh/sshd_config: line 43: Bad configuration option: Host
    /etc/ssh/sshd_config: line 48: Bad configuration option: ForwardX11Trusted
    /etc/ssh/sshd_config: line 50: Bad configuration option: SendEnv
    /etc/ssh/sshd_config: line 51: Bad configuration option: SendEnv
    /etc/ssh/sshd_config: line 52: Bad configuration option: SendEnv
    /etc/ssh/sshd_config: terminating, 8 bad configuration options
    [ÉCHOUÉ]
     
  9. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Elastix 1.6 ou 2.0?
     
  10. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Tu ne t'ais pas planté de fichier?

    Ne pas confondre :
    ssh_config et
    sshd_config

    A mon avis tu as inversés les deux fichiers dans le contenu. :huh:
     
  11. mickael95370

    Joined:
    Oct 28, 2009
    Messages:
    63
    Likes Received:
    0
    j'ai remis les fichiers maintenant j'ai ce message : lol

    Impossible de démarrer le serveur SSH :
    Démarrage de sshd :/var/empty/sshd must be owned by root and not group or world-writable.
    [ÉCHOUÉ]


    Je suis en verson 2.0

    FREEPBX en 2.8.0.3

    JE galere a mort
     
  12. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Bon ben au niveau des permission et autre info du fichier /var/empty/sshd ça donne quoi.

    Il dit bien dans l'erreur:
    /var/empty/sshd must be owned by root and not group or world-writable.
    doit être propriétaire root et non pas un groupe ou inscriptible.

    Donc... ton fichier doit ressembler à çà:
    Code:
    # ll /var/empty
    total 8
    drwx--x--x 3 root root 4096 sep  5  2009 sshd
    t'as du faire mumuse avec les droits de fichiers, chmod, chgrp ou autre...
     
  13. mickael95370

    Joined:
    Oct 28, 2009
    Messages:
    63
    Likes Received:
    0
    desole je comprend pas se que tu veux que je fasse
     
  14. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Au pire.... si tu galères avec les droits des fichiers et autres problèmes à tiroir (un problème en engendrant un autre), fais une installation en VMWARE et copie les fichiers qui te posent problèmes.
    Ou même, ils te serviront de point de comparaison. ;)

    Bon courage.
     
  15. mickael95370

    Joined:
    Oct 28, 2009
    Messages:
    63
    Likes Received:
    0
    j'ai une autre install qui tourne en 1.6

    quel fichier recuperer ? je l'ai recuperer avec WINSPC

    comment je l'ai recopie sur mon ipbx qui merde ???


    Merci pour le temps que tu prend pour moi
     
  16. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Ha bon, car Mr ne connait pas Linux... :side: :S

    Aîe Aîe Aîe....

    Regardes ton fichier de ton coté et relèves le owner et le group du répertoire avec les droits respectif.
    Compares le avec le mien.
     
  17. mickael95370

    Joined:
    Oct 28, 2009
    Messages:
    63
    Likes Received:
    0
    j'ai une autre install qui tourne en 1.6

    quel fichier recuperer ? je l'ai recuperer avec WINSPC

    comment je l'ai recopie sur mon ipbx qui merde ???


    Merci pour le temps que tu prend pour moi
     
  18. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Enfin quand je dis fichier, non, c'est répertoire. (Excuses moi)
    Bref, c'est la même chose (même problème).
    Il faut que ton répertoire appartienne à root et appartienne au groupe root.
     
  19. mickael95370

    Joined:
    Oct 28, 2009
    Messages:
    63
    Likes Received:
    0
    Enfin quand je dis fichier, non, c'est répertoire. (Excuses moi)
    Bref, c'est la même chose (même problème).
    Il faut que ton répertoire appartienne à root et appartienne au groupe root.



    Je voie pas comment faire ca du tout


    tu vx pas prendre la main lol
     
  20. danardf

    Joined:
    Dec 3, 2007
    Messages:
    8,069
    Likes Received:
    12
    Ben si tu ne voies pas comment faire!!?, c'est un peu hasardeux de vouloir administrer un IPBX fonctionnant sous Linux sans en connaitre les bases UNIX! :side:

    Il y a des bons livres là dessus. ;)

    Pour changer les droits sur un répertoire, ou un fichier il y a 3 commandes à connaître.
    chmod
    chown et
    chgrp

    chown root nom_fichier change le propriétaire du fichier (ou répertoire)
    chgrp root mon_fichier change le groupe (le fichier or répertoire appartiendra au groupe root)
    chmod xxx x étant un chiffre décimal de 0 à 7 issue du binaire (000 à 111)

    rwx = 111 = 7 --- r-x = 5 ..etc

    premier x = pour le propriétaire
    deuziem x = pour le groupe
    troisiem x = pour les autres

    Bon je te laisse. Je fais un break pour ce soir. ;) :side:
     

Share This Page