Sangoma B6003DE, ZAPTEL and hardware det. problem

mehr

Joined
Jan 28, 2009
Messages
1
Likes
0
Points
0
#1
Hi All,

I am trying to install the B600 card.
Unfortunately the Elastix can not recognize the hardware, I have tried both Elastix 1.3 and 1.4, same issue with both.

I tried to install latest version of Winpipe from Sangoma website, but it shows the following error:

No zaptel/dahdi dirs found in /usr/src
Please use option "m" to enter zaptel/dahdi path

------------------------------------------
------------------------------------------
m : Enter zaptel path manually


I don't know where the zaptel folder is, I can find the following folders:

/usr/include/zaptel
/usr/share/zaptel
/sys/module/zaptel


but looks like they are not the zaptel source folder.


Any idea what is wrong?

I tried to install rpm -i --force wanpipe-modules-3.3.12-0.i686.rpm but it says:

error: Failed dependencies:
zaptel = 1.4.11-5 is needed by wanpipe-modules-3.3.12-0.i686
[root@elastix src]#



I thought the zaptel is installed by default on Elastix box isn't it?

Should I first install the wanpipe driver or is it installed already?
In some documentation in Sangoma website it says that Elastix comes with wanpipe driver.

If somebody here has any experiences with Sangoma cards and installing the drivers for it, and willing to share, it would be great help for me.
Thanks in advance,

Mehr
 

vloose

Joined
Dec 2, 2008
Messages
64
Likes
0
Points
0
#2
I ran into the exact same problem with an A101u card. After talking with Sangoma, they found the RPM's to be the problem.

1. remove wanpipe-util-3.2.7.1-1

[root@elastix wanpipe-3.2.7.1]# rpm -e wanpipe-util-3.2.7.1-1

error: Failed dependencies:

perl(A10u) is needed by (installed) elastix-1.4-4.noarch

perl(A10x) is needed by (installed) elastix-1.4-4.noarch

perl(A20x) is needed by (installed) elastix-1.4-4.noarch

perl(A50x) is needed by (installed) elastix-1.4-4.noarch

perl(Card) is needed by (installed) elastix-1.4-4.noarch

wanpipe-util is needed by (installed) elastix-additionals-1.1-2.noarch

2. Remove wanpipe-modules-3.2.7.1-1

[root@elastix wanpipe-3.2.7.1]# rpm -e wanpipe-modules-3.2.7.1-1

Uninstalling WANPIPE..

untar zaptel-1.4.12.1.tar.gz and zaptel-1.4.12.1.tar.gz in /usr/src directory

3. followed the steps at http://wiki.sangoma.com/wanpipe-asterisk-trixbox-rpms#drivfrmsource starting from step 6

This worked for me in both Elastix 1.4-1 beta and 1.4-4 beta.
 

eljerry

Joined
Jun 19, 2008
Messages
14
Likes
0
Points
1
#3

Members online

No members online now.

Latest posts

Forum statistics

Threads
30,980
Messages
131,059
Members
17,699
Latest member
oscarali1985
Top