Sangoma b600 blues

Discussion in 'General' started by calu, Oct 20, 2009.

  1. calu

    Joined:
    Oct 19, 2009
    Messages:
    3
    Likes Received:
    0
    Hi.

    I am new in this matter.
    I installed a Sangoma Card B600 (4fxo + 1 fxs) on Elastix 1.5.2-2.
    Everyhting seems ok with the harware detection however, when receiving a call there is no sound at all.
    By picking an extension and try to dial out nothing happens.
    By picking the phone using the fxs channel I can make a call to one extension however, no sound at all.
    I did create 4 trunks zap/dahdi for each channel as well as the outbound route so extensions can find the way out when using the trunk.
    I created an inbound route so I can define where the incomming calls goes.
    I really dont understand what I am missing here!
    I got a second sangoma card and the same happens.

    It has been two weeks now after installing an re-installing elastix without managing to fix this problem.
    Could you help me on this?

    Regards.
     
  2. aplusmiami

    Joined:
    Oct 20, 2009
    Messages:
    2
    Likes Received:
    0
    Check the Sangoma website for info on installing the wanpipe drivers. I believe your issues are related to the ver of Asterisk. You need to install the DAHDI drivers. I am no expert put I did resolve my A200 issues there.
     
  3. calu

    Joined:
    Oct 19, 2009
    Messages:
    3
    Likes Received:
    0
    dahdi drivers are installed correctly.
    the WANPIPE Release is 3.3.15. Running wanrouter restart i get the following output:
    Starting WAN Router...
    Loading WAN drivers: wanpipe done.
    Starting up device: wanpipe1
    --> Loading ec image OCT6116-64S.ima...
    Configuring interfaces: w1g1
    done.

    ... and running wanrouter hwprobe verbose
    -----------------------------------------
    | Wanpipe Hardware Probe Info (verbose) |
    -----------------------------------------
    1 . AFT-B600-SH : SLOT=1 : BUS=3 : IRQ=17 : CPU=A : PORT=PRI : HWEC=5 : V=02
    +01:FXO:pCI
    +02:FXO:pCI
    +03:FXO:pCI
    +04:FXO:pCI
    +05:FXS:pCI
    Card Cnt: A600=1

    ... which seems to be ok.

    Running wanpipemon -i w1g1 -c astats -m 1

    ------- Voltage Status (FXO,port 0) -------

    VOLTAGE : 38 Volts

    ------- Line Status (FXO,port 0) -------

    Line : connected

    ... which seems to be ok.

    Restarting dahdi i get the following output

    Loading Dahdi...
    DAHDI Tools Version - 2.2.0

    DAHDI Version: 2.1.0.4
    Echo Canceller(s): OSLEC
    Configuration
    ======================


    5 channels to configure.

    Setting echocan for channel 1 to none
    Setting echocan for channel 2 to none
    Setting echocan for channel 3 to none
    Setting echocan for channel 4 to none
    Setting echocan for channel 5 to none

    Starting Asterisk...

    Listing Asterisk channels...

    Chan Extension Context Language MOH Interpret
    pseudo default default
    1 from-zaptel default
    2 from-zaptel default
    3 from-zaptel default
    4 from-zaptel default
    5 from-internal default

    ... which seems ok.
    The chan_dahdi.conf shows the following:

    ;autogenerated by /usr/sbin/wancfg_dahdi do not hand edit
    ;autogenrated on 2009-10-20
    ;Dahdi Channels Configurations
    ;For detailed Dahdi options, view /etc/asterisk/chan_dahdi.conf.bak

    [trunkgroups]

    [channels]
    context=default
    usecallerid=yes
    hidecallerid=no
    callwaiting=yes
    usecallingpres=yes
    callwaitingcallerid=yes
    threewaycalling=yes
    transfer=yes
    canpark=yes
    cancallforward=yes
    callreturn=yes
    echocancel=yes
    echocancelwhenbridged=yes
    relaxdtmf=yes
    rxgain=0.0
    txgain=0.0
    group=1
    callgroup=1
    pickupgroup=1
    immediate=no

    ;Sangoma AFT-B600 [slot:1 bus:3 span:1] <wanpipe1>
    context=from-zaptel
    group=0
    echocancel=no
    signalling = fxs_ks
    channel => 1

    context=from-zaptel
    group=0
    echocancel=no
    signalling = fxs_ks
    channel => 2

    context=from-zaptel
    group=0
    echocancel=no
    signalling = fxs_ks
    channel => 3

    context=from-zaptel
    group=0
    echocancel=no
    signalling = fxs_ks
    channel => 4

    context=from-internal
    group=1
    echocancel=no
    signalling = fxo_ks
    channel => 5

    ... which also seems ok.
    The dahdi-channels.conf shows:

    ; Autogenerated by /usr/sbin/dahdi_genconf on Tue Oct 20 11:53:34 2009
    ; If you edit this file and execute /usr/sbin/dahdi_genconf again,
    ; your manual changes will be LOST.
    ; Dahdi Channels Configurations (chan_dahdi.conf)
    ;
    ; This is not intended to be a complete chan_dahdi.conf. Rather, it is intended
    ; to be #include-d by /etc/chan_dahdi.conf that will include the global settings
    ;

    ; Span 1: WRTDM/0 "wrtdm Board 1" (MASTER)
    ;;; line="1 WRTDM/0/0 FXSKS"
    signalling=fxs_ks
    callerid=asreceived
    group=0
    context=from-zaptel
    channel => 1
    callerid=
    group=
    context=default

    ;;; line="2 WRTDM/0/1 FXSKS"
    signalling=fxs_ks
    callerid=asreceived
    group=0
    context=from-zaptel
    channel => 2
    callerid=
    group=
    context=default

    ;;; line="3 WRTDM/0/2 FXSKS"
    signalling=fxs_ks
    callerid=asreceived
    group=0
    context=from-zaptel
    channel => 3
    callerid=
    group=
    context=default

    ;;; line="4 WRTDM/0/3 FXSKS"
    signalling=fxs_ks
    callerid=asreceived
    group=0
    context=from-zaptel
    channel => 4
    callerid=
    group=
    context=default

    ;;; line="5 WRTDM/0/4 FXOKS"
    signalling=fxo_ks
    callerid="Channel 5" <4005>
    mailbox=4005
    group=5
    context=from-internal
    channel => 5
    callerid=
    mailbox=
    group=
    context=default

    ...which also seems ok (I guess)
    Any ideas?

    Regards
     
  4. Jenriquez

    Joined:
    Oct 17, 2009
    Messages:
    6
    Likes Received:
    0
    Re: Re:Sangoma b600 blues

    For this card run wancfg_zaptel instead of setup-sangoma.. that worked for me.

    Javier Enriquez
    http://www.netcom-sonora.com
     
  5. tbooth

    Joined:
    Feb 24, 2007
    Messages:
    338
    Likes Received:
    0
    Re: Re:Sangoma b600 blues

    sangoma offer free tech support on their cards. Call them and be prepared to give them a ssh access. Their tech support is very good.
     
  6. trymes

    Joined:
    Aug 19, 2009
    Messages:
    228
    Likes Received:
    0
    Re: Re:Sangoma b600 blues

    This is an old, old thread, but for anyone browsing the archives, I can second the suggestion to contact Sangoma. Their support is excellent.
     

Share This Page